aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-12-12 02:55:33 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-12-12 02:55:33 +0000
commit5ac234b43d1b467ebffc17f4223b3ad18b4c4532 (patch)
tree373cde6d362d2775fb8021c4102dab4178e64906
parent3c4928be7df8fd42f381fa642474feca12f0b285 (diff)
downloadports-5ac234b43d1b467ebffc17f4223b3ad18b4c4532.tar.gz
ports-5ac234b43d1b467ebffc17f4223b3ad18b4c4532.zip
MFH: r456078
net/ns3: require C++11 toolchain (on powerpc*, mips*, sparc*) cc1plus: error: unrecognized command line option "-std=c++11" ../examples/wireless/wifi-multi-tos.cc:124:24: error: no matching constructor for initialization of 'std::vector<uint8_t>' (aka 'vector<unsigned char>') std::vector<uint8_t> tosValues = {0x70, 0x28, 0xb8, 0xc0}; //AC_BE, AC_BK, AC_VI, AC_VO ^ ~~~~~~~~~~~~~~~~~~~~~~~~ /usr/include/c++/4.2/bits/stl_vector.h:266:9: note: candidate constructor template not viable: requires at most 3 arguments, but 4 were provided vector(_InputIterator __first, _InputIterator __last, ^ /usr/include/c++/4.2/bits/stl_vector.h:224:7: note: candidate constructor not viable: requires at most 3 arguments, but 4 were provided vector(size_type __n, const value_type& __value = value_type(), ^ /usr/include/c++/4.2/bits/stl_vector.h:212:7: note: candidate constructor not viable: requires single argument '__a', but 4 arguments were provided vector(const allocator_type& __a) ^ /usr/include/c++/4.2/bits/stl_vector.h:242:7: note: candidate constructor not viable: requires single argument '__x', but 4 arguments were provided vector(const vector& __x) ^ /usr/include/c++/4.2/bits/stl_vector.h:208:7: note: candidate constructor not viable: requires 0 arguments, but 4 were provided vector() ^ 1 error generated. Reported by: pkg-fallout (mips64) Approved by: ports-secteam blanket
Notes
Notes: svn path=/branches/2017Q4/; revision=456085
-rw-r--r--net/ns3/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/net/ns3/Makefile b/net/ns3/Makefile
index 03861e0341b7..d8313b45c837 100644
--- a/net/ns3/Makefile
+++ b/net/ns3/Makefile
@@ -12,9 +12,7 @@ COMMENT= Network simulator for Internet systems
LICENSE= GPLv2
-BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option -std=c++11
-
-USES= gettext pkgconfig python sqlite tar:bzip2 waf
+USES= compiler:c++11-lib gettext pkgconfig python sqlite tar:bzip2 waf
USE_GNOME= libxml2
USE_LDCONFIG= yes
WRKSRC_SUBDIR= ns-${DISTVERSION}