aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-05-09 08:03:21 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-05-09 08:03:21 +0000
commit5bffcf99fed1ff8a80a24cb69355c71fd6a73f20 (patch)
treeaed0496e99d0d44b4f29990582f840d76a95d6c7
parent85e67b7e02c82a8efafd41bafd4799ea04b8de8a (diff)
downloadports-5bffcf99fed1ff8a80a24cb69355c71fd6a73f20.tar.gz
ports-5bffcf99fed1ff8a80a24cb69355c71fd6a73f20.zip
Notes
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/py-gtkextra/Makefile27
-rw-r--r--x11-toolkits/py-gtkextra/distinfo1
-rw-r--r--x11-toolkits/py-gtkextra/pkg-descr5
-rw-r--r--x11-toolkits/py-gtkextra/pkg-plist5
5 files changed, 39 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 710e14925cf4..d0e3dd852bb6 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -137,6 +137,7 @@
SUBDIR += py-gnome2
SUBDIR += py-gtk
SUBDIR += py-gtk2
+ SUBDIR += py-gtkextra
SUBDIR += py-gtkglext
SUBDIR += py-gtkscintilla
SUBDIR += py-kde
diff --git a/x11-toolkits/py-gtkextra/Makefile b/x11-toolkits/py-gtkextra/Makefile
new file mode 100644
index 000000000000..785d9ba9dec3
--- /dev/null
+++ b/x11-toolkits/py-gtkextra/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: py-gtkextra
+# Date created: May 9, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtkextra
+PORTVERSION= 0.22
+CATEGORIES= x11-toolkits python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= python-${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= GtkExtra Python Language Bindings
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-1.2/GTK.py:${PORTSDIR}/x11-toolkits/py-gtk
+LIB_DEPENDS= gtkextra.17:${PORTSDIR}/x11-toolkits/gtkextra
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-1.2/GTK.py:${PORTSDIR}/x11-toolkits/py-gtk
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/py-gtkextra/distinfo b/x11-toolkits/py-gtkextra/distinfo
new file mode 100644
index 000000000000..46b8f9a68942
--- /dev/null
+++ b/x11-toolkits/py-gtkextra/distinfo
@@ -0,0 +1 @@
+MD5 (python-gtkextra-0.22.tar.gz) = ab9faef7865c69965dba5fdd1a7d7737
diff --git a/x11-toolkits/py-gtkextra/pkg-descr b/x11-toolkits/py-gtkextra/pkg-descr
new file mode 100644
index 000000000000..ae33bb504557
--- /dev/null
+++ b/x11-toolkits/py-gtkextra/pkg-descr
@@ -0,0 +1,5 @@
+Python language bindings for the GtkExtra widget set. GtkExtra is a useful
+set of widgets for the GIMP Toolkit, aka GTK+. It provides a spreadsheet-like
+matrix widget and widgets for 2-D and 3-D graphing.
+
+WWW: http://python-gtkextra.sourceforge.net/
diff --git a/x11-toolkits/py-gtkextra/pkg-plist b/x11-toolkits/py-gtkextra/pkg-plist
new file mode 100644
index 000000000000..6d2f60dc30bd
--- /dev/null
+++ b/x11-toolkits/py-gtkextra/pkg-plist
@@ -0,0 +1,5 @@
+%%PYTHON_SITELIBDIR%%/gtkextra/__init__.py
+%%PYTHON_SITELIBDIR%%/gtkextra/__init__.pyc
+%%PYTHON_SITELIBDIR%%/gtkextra/__init__.pyo
+%%PYTHON_SITELIBDIR%%/gtkextra/_gtkextramodule.so
+@dirrm %%PYTHON_SITELIBDIR%%/gtkextra