aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2006-01-05 21:05:30 +0000
committerAde Lovett <ade@FreeBSD.org>2006-01-05 21:05:30 +0000
commit64d283b01f9e0bdb39d78191cbdd76f83c64f50b (patch)
tree112b2cbdef68b3fbde1fc05abc880016cab64b24
parent9b7d382ebc09a22fe2c3c3a216667528d4c8654a (diff)
downloadports-64d283b01f9e0bdb39d78191cbdd76f83c64f50b.tar.gz
ports-64d283b01f9e0bdb39d78191cbdd76f83c64f50b.zip
Notes
-rw-r--r--Mk/bsd.autotools.mk71
1 files changed, 2 insertions, 69 deletions
diff --git a/Mk/bsd.autotools.mk b/Mk/bsd.autotools.mk
index 8c347d19714b..9589471ad7b7 100644
--- a/Mk/bsd.autotools.mk
+++ b/Mk/bsd.autotools.mk
@@ -26,73 +26,6 @@ Autotools_Include_MAINTAINER= ade@FreeBSD.org
#---------------------------------------------------------------------------
#---------------------------------------------------------------------------
-# Compatibility shims for the old method of using autotools. These are
-# slated for removal on January 1st 2006
-#---------------------------------------------------------------------------
-
-USE_AUTOTOOLS_COMPAT=
-
-.if defined(USE_AUTOMAKE_VER)
-USE_AUTOTOOLS_COMPAT+= automake:${USE_AUTOMAKE_VER}
-.endif
-
-.if defined(WANT_AUTOMAKE_VER)
-USE_AUTOTOOLS_COMPAT+= automake:${WANT_AUTOMAKE_VER}:env
-.endif
-
-.if defined(USE_ACLOCAL_VER)
-USE_AUTOTOOLS_COMPAT+= aclocal:${USE_ACLOCAL_VER}
-.endif
-
-.if defined(USE_AUTOHEADER_VER)
-USE_AUTOTOOLS_COMPAT+= autoheader:${USE_AUTOHEADER_VER}
-.endif
-
-.if defined(USE_AUTOCONF_VER)
-USE_AUTOTOOLS_COMPAT+= autoconf:${USE_AUTOCONF_VER}
-.endif
-
-.if defined(WANT_AUTOCONF_VER)
-USE_AUTOTOOLS_COMPAT+= autoconf:${WANT_AUTOCONF_VER}:env
-.endif
-
-.if defined(USE_LIBLTDL)
-USE_AUTOTOOLS_COMPAT+= libltdl:15
-.endif
-
-.if defined(USE_LIBTOOL_VER)
-USE_AUTOTOOLS_COMPAT+= libtool:${USE_LIBTOOL_VER}
-.endif
-
-.if defined(USE_INC_LIBTOOL_VER)
-USE_AUTOTOOLS_COMPAT+= libtool:${USE_INC_LIBTOOL_VER}:inc
-.endif
-
-.if defined(WANT_LIBTOOL_VER)
-USE_AUTOTOOLS_COMPAT+= libtool:${WANT_LIBTOOL_VER}:env
-.endif
-
-# Ensure that we're not mixing and matching old and new systems
-#
-.if ${USE_AUTOTOOLS_COMPAT}!=""
-. if defined(USE_AUTOTOOLS)
-BROKEN+= "Mix and match of old and new autotools system prohibited"
-. else
-USE_AUTOTOOLS= ${USE_AUTOTOOLS_COMPAT}
-_AUTOTOOLS_PN= ${.CURDIR:C/${PORTSDIR}\///}
-pre-everything::
- @${ECHO} "*** AUTOTOOLS WARNING for ${_AUTOTOOLS_PN}"
- @${ECHO} "This port is using old autotools constructs which will be"
- @${ECHO} "disappearing on 1st January 2006"
- @${ECHO} ""
- @${ECHO} "In most cases, this warning can be fixed by removing"
- @${ECHO} "all the old constructs and replacing them with:"
- @${ECHO} " USE_AUTOTOOLS= ${USE_AUTOTOOLS_COMPAT}"
- @${ECHO} ""
-. endif
-.endif
-
-#---------------------------------------------------------------------------
# Entry point into the autotools system
#---------------------------------------------------------------------------
#
@@ -338,8 +271,8 @@ ${item:U}_ENV+= ${AUTOTOOLS_VARS}
# the order of autotools running.
.if !target(run-autotools)
-run-autotools:: run-autotools-aclocal run-autotools-automake \
- run-autotools-autoconf run-autotools-autoheader
+run-autotools:: run-autotools-aclocal run-autotools-autoheader \
+ run-autotools-autoconf run-autotools-automake
.endif
.if !target(run-autotools-aclocal)