aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2014-08-18 16:43:24 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2014-08-18 16:43:24 +0000
commit69f82727cfeeeb49cb58c2d1960548e0ee5cb501 (patch)
tree5cc71aad2369347e372daa82cf3849f910e182fc
parentda1ccc4d38452561e2972b98fb43ef0df6027577 (diff)
downloadports-69f82727cfeeeb49cb58c2d1960548e0ee5cb501.tar.gz
ports-69f82727cfeeeb49cb58c2d1960548e0ee5cb501.zip
Notes
-rw-r--r--Mk/bsd.port.mk3
-rw-r--r--databases/py-carbon/Makefile1
-rw-r--r--devel/hadoop2/Makefile3
-rw-r--r--devel/zookeeper/Makefile1
-rw-r--r--mail/dma/Makefile1
-rw-r--r--mail/exim/Makefile1
-rw-r--r--mail/postfix-current/Makefile2
-rw-r--r--mail/postfix/Makefile2
-rw-r--r--mail/py-spambayes/Makefile3
-rw-r--r--multimedia/universal-media-server/Makefile1
-rw-r--r--net-mgmt/collectd5/Makefile2
-rw-r--r--net-mgmt/flow-tools-ng/Makefile1
-rw-r--r--net-p2p/amule-devel/Makefile1
-rw-r--r--net-p2p/amule/Makefile1
-rw-r--r--security/clamav/Makefile3
-rw-r--r--security/munge/Makefile1
-rw-r--r--security/opencryptoki/Makefile1
-rw-r--r--security/openvas-server/Makefile2
-rw-r--r--sysutils/mnrpes/Makefile5
-rw-r--r--sysutils/puppet/Makefile1
-rw-r--r--sysutils/puppet27/Makefile1
-rw-r--r--www/free-sa-devel/Makefile1
-rw-r--r--www/linux-f10-flashplugin11/Makefile1
-rw-r--r--www/polipo/Makefile1
-rw-r--r--www/py-graphite-web/Makefile1
-rw-r--r--x11-wm/compiz/Makefile2
26 files changed, 8 insertions, 35 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 44ec83aa8cf4..8457f51162be 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1570,7 +1570,8 @@ CONFIGURE_WRKSRC?= ${WRKSRC}
BUILD_WRKSRC?= ${WRKSRC}
INSTALL_WRKSRC?=${WRKSRC}
-PLIST_SUB+= OSREL=${OSREL} PREFIX=%D LOCALBASE=${LOCALBASE}
+PLIST_SUB+= OSREL=${OSREL} PREFIX=%D LOCALBASE=${LOCALBASE} \
+ RESETPREFIX=${PREFIX}
SUB_LIST+= PREFIX=${PREFIX} LOCALBASE=${LOCALBASE} \
DATADIR=${DATADIR} DOCSDIR=${DOCSDIR} EXAMPLESDIR=${EXAMPLESDIR} \
WWWDIR=${WWWDIR} ETCDIR=${ETCDIR}
diff --git a/databases/py-carbon/Makefile b/databases/py-carbon/Makefile
index 7873c772cdfa..979879dfcc88 100644
--- a/databases/py-carbon/Makefile
+++ b/databases/py-carbon/Makefile
@@ -22,6 +22,5 @@ USE_PYDISTUTILS= yes
USES= twisted:run
FETCH_ARGS= -o ${DISTNAME}${EXTRACT_SUFX}
USE_RC_SUBR= carbon
-PLIST_SUB+= RESETPREFIX=${PREFIX}
.include <bsd.port.mk>
diff --git a/devel/hadoop2/Makefile b/devel/hadoop2/Makefile
index b42ab4344336..9910fba80d2e 100644
--- a/devel/hadoop2/Makefile
+++ b/devel/hadoop2/Makefile
@@ -55,8 +55,7 @@ PLIST_SUB= PORTVERSION="${PORTVERSION}" \
HADOOP_RUNDIR="${HADOOP_RUNDIR}" \
HDFS_USER="${HDFS_USER}" \
MAPRED_USER="${MAPRED_USER}" \
- HADOOP_GROUP="${HADOOP_GROUP}" \
- RESETPREFIX=${PREFIX}
+ HADOOP_GROUP="${HADOOP_GROUP}"
SUB_LIST= HDFS_USER="${HDFS_USER}" \
MAPRED_USER="${MAPRED_USER}" \
HADOOP_GROUP="${HADOOP_GROUP}" \
diff --git a/devel/zookeeper/Makefile b/devel/zookeeper/Makefile
index 54dfcd279cce..93002d661987 100644
--- a/devel/zookeeper/Makefile
+++ b/devel/zookeeper/Makefile
@@ -33,7 +33,6 @@ PORTDOCS= *
PLIST_SUB= PORTNAME=${PORTNAME} \
PORTVERSION=${PORTVERSION} \
- RESETPREFIX=${PREFIX} \
JAVA_HOME=${JAVA_HOME}
ZOOKEEPER_LOGDIR?= /var/log/${PORTNAME}
diff --git a/mail/dma/Makefile b/mail/dma/Makefile
index 62f01af8f61e..d5a6b3ff3307 100644
--- a/mail/dma/Makefile
+++ b/mail/dma/Makefile
@@ -27,7 +27,6 @@ LDFLAGS+= -L${OPENSSLLIB}
USE_RC_SUBR= dma_flushq
SUB_FILES= pkg-message
-PLIST_SUB+= RESETPREFIX=${PREFIX}
# Allow subports to extend.
CONFFILES+= dma.conf auth.conf
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 631bfbc0839b..e0f276fb7109 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -485,7 +485,6 @@ SEDLIST+= -e 's,^\# (TRUSTED_CONFIG_LIST=).*$$,\1${TRUSTED_CONFIG_LIST:S/,/\\,/g
.endif
MAKE_ENV+= INSTALL_ARG="${EXIM_INSTALL_ARG}"
-PLIST_SUB+= RESETPREFIX=${PREFIX}
DUMMY_LDFLAGS!= ${ECHO_CMD} ${LDFLAGS} | ${SED} -e 's|-Wl,-rpath|-Wl,-DUMMYrpath|g; s|-rpath|-Wl,-rpath|g; s|-DUMMYrpath|-rpath|g'
pre-everything::
diff --git a/mail/postfix-current/Makefile b/mail/postfix-current/Makefile
index c32dea4dea05..887fb1777743 100644
--- a/mail/postfix-current/Makefile
+++ b/mail/postfix-current/Makefile
@@ -104,7 +104,7 @@ USE_RC_SUBR= postfix
PLIST_SUB+= BASE="@comment " BMAN=""
.endif
-PLIST_SUB+= PFETC=${ETCDIR} RESETPREFIX=${PREFIX}
+PLIST_SUB+= PFETC=${ETCDIR}
.if ${PORT_OPTIONS:MDOCS}
READMEDIR= ${DOCSDIR}
diff --git a/mail/postfix/Makefile b/mail/postfix/Makefile
index 3f3bb4bd4130..f0d3aef8db96 100644
--- a/mail/postfix/Makefile
+++ b/mail/postfix/Makefile
@@ -105,7 +105,7 @@ USE_RC_SUBR= postfix
PLIST_SUB+= BASE="@comment " BMAN=""
.endif
-PLIST_SUB+= PFETC=${ETCDIR} RESETPREFIX=${PREFIX}
+PLIST_SUB+= PFETC=${ETCDIR}
.if ${PORT_OPTIONS:MDOCS}
READMEDIR= ${DOCSDIR}
diff --git a/mail/py-spambayes/Makefile b/mail/py-spambayes/Makefile
index d4db6e18c616..f811a854492e 100644
--- a/mail/py-spambayes/Makefile
+++ b/mail/py-spambayes/Makefile
@@ -29,8 +29,7 @@ CACHEDIR?= ${LOCALSTATDIR}/cache
PLIST_SUB+= LOCALSTATDIR=${LOCALSTATDIR} \
DBDIR=${DBDIR} \
- CACHEDIR=${CACHEDIR} \
- RESETPREFIX=${PREFIX}
+ CACHEDIR=${CACHEDIR}
SUB_LIST+= PYTHON_CMD=${PYTHON_CMD}
diff --git a/multimedia/universal-media-server/Makefile b/multimedia/universal-media-server/Makefile
index 879a3b0d0085..3c14f3cc1b5a 100644
--- a/multimedia/universal-media-server/Makefile
+++ b/multimedia/universal-media-server/Makefile
@@ -57,7 +57,6 @@ UMS_PID_DIR= /var/run/${PORTNAME}
SUB_LIST= RCNAME=${USE_RC_SUBR} JAVA_HOME=${JAVA_HOME} JAVA=${JAVA} \
UMS_PROFILE_PATH=${UMS_PROFILE_PATH}
PLIST_SUB= ${SUB_LIST}
-PLIST_SUB+= RESETPREFIX=${PREFIX}
SUB_FILES= pkg-message
USE_RC_SUBR= universal_media_server
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index 50744cf91c8d..0e2becf6155c 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -67,8 +67,6 @@ CONFLICTS= collectd-4.[0-9]*
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
-PLIST_SUB+= RESETPREFIX=${PREFIX}
-
.include <bsd.port.options.mk>
# NOTE: Plugins without dependencies are defined further down.
diff --git a/net-mgmt/flow-tools-ng/Makefile b/net-mgmt/flow-tools-ng/Makefile
index 9c82889740b8..fa10e8a8065b 100644
--- a/net-mgmt/flow-tools-ng/Makefile
+++ b/net-mgmt/flow-tools-ng/Makefile
@@ -32,7 +32,6 @@ USE_PYTHON_RUN= yes
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-PLIST_SUB= RESETPREFIX=${PREFIX}
SUB_LIST= FLOW_CAPTURE_SPOOL="${FLOW_CAPTURE_SPOOL}" \
FLOW_CAPTURE_PIDDIR="${FLOW_CAPTURE_PIDDIR}"
USE_RC_SUBR= flow_capture flow_fanout
diff --git a/net-p2p/amule-devel/Makefile b/net-p2p/amule-devel/Makefile
index 92be55bd5eda..5ba35c573276 100644
--- a/net-p2p/amule-devel/Makefile
+++ b/net-p2p/amule-devel/Makefile
@@ -96,7 +96,6 @@ PLASMAMULE_CONFIGURE_ENV= \
ac_cv_path_KDE4_CONFIG=${KDE4_PREFIX}/bin/kde4-config \
KBUILDSYCOCA=${KDE4_PREFIX}/bin/kbuildsycoca4 \
UPDATE_MIME_DATABASE=/usr/bin/true
-PLASMAMULE_PLIST_SUB+= RESETPREFIX=${PREFIX}
UPNP_LIB_DEPENDS= libupnp.so:${PORTSDIR}/devel/upnp
UPNP_CONFIGURE_OFF= --disable-upnp
diff --git a/net-p2p/amule/Makefile b/net-p2p/amule/Makefile
index cefb2adfaa99..803144e307ae 100644
--- a/net-p2p/amule/Makefile
+++ b/net-p2p/amule/Makefile
@@ -95,7 +95,6 @@ PLASMAMULE_CONFIGURE_ENV= \
ac_cv_path_KDE4_CONFIG=${KDE4_PREFIX}/bin/kde4-config \
KBUILDSYCOCA=${KDE4_PREFIX}/bin/kbuildsycoca4 \
UPDATE_MIME_DATABASE=/usr/bin/true
-PLASMAMULE_PLIST_SUB+= RESETPREFIX=${PREFIX}
UPNP_LIB_DEPENDS= libupnp.so:${PORTSDIR}/devel/upnp
UPNP_CONFIGURE_OFF= --disable-upnp
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 997310b0a555..af3b9a0f3bae 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -62,8 +62,7 @@ PLIST_SUB+= DBDIR=${DBDIR:S/^\///} \
LOGDIR=${LOGDIR:S/^\///} \
RUNDIR=${RUNDIR:S/^\///} \
CLAMAVUSER=${CLAMAVUSER} \
- CLAMAVGROUP=${CLAMAVGROUP} \
- RESETPREFIX=${PREFIX}
+ CLAMAVGROUP=${CLAMAVGROUP}
PY_NO_THREAD= ${WRKDIR}/.python-has-no-threads
USE_AUTOTOOLS= libltdl
OPTIONS_SUB= yes
diff --git a/security/munge/Makefile b/security/munge/Makefile
index da59534bd18e..58eb9b799884 100644
--- a/security/munge/Makefile
+++ b/security/munge/Makefile
@@ -15,7 +15,6 @@ LICENSE_COMB= dual
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var
-PLIST_SUB= RESETPREFIX=${PREFIX}
USES= libtool pathfix perl5 tar:bzip2
USE_LDCONFIG= yes
USE_RC_SUBR= munged
diff --git a/security/opencryptoki/Makefile b/security/opencryptoki/Makefile
index 0201167ff921..0c1d88725909 100644
--- a/security/opencryptoki/Makefile
+++ b/security/opencryptoki/Makefile
@@ -31,7 +31,6 @@ CONFIGURE_ARGS= --enable-swtok --enable-tpmtok \
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_RC_SUBR= pkcsslotd
-PLIST_SUB= RESETPREFIX=${PREFIX}
SUB_FILES= pkg-message
SUB_LIST= USERS=${USERS} GROUPS=${GROUPS}
USERS= _pkcs11
diff --git a/security/openvas-server/Makefile b/security/openvas-server/Makefile
index 71884381af83..2ea0caebc96d 100644
--- a/security/openvas-server/Makefile
+++ b/security/openvas-server/Makefile
@@ -21,6 +21,4 @@ CONFIGURE_ARGS= --localstatedir=/var
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lgcrypt
-PLIST_SUB= RESETPREFIX=${PREFIX}
-
.include <bsd.port.mk>
diff --git a/sysutils/mnrpes/Makefile b/sysutils/mnrpes/Makefile
index 9fe6dab7c346..e87a0ac555e5 100644
--- a/sysutils/mnrpes/Makefile
+++ b/sysutils/mnrpes/Makefile
@@ -21,10 +21,7 @@ GH_COMMIT= 3f9942c
USE_RC_SUBR= mnrpes_receiver \
mnrpes_scheduler
-RESETPREFIX= ${PREFIX}
-
-PLIST_SUB+= PORTNAME=${PORTNAME} \
- RESETPREFIX=${RESETPREFIX}
+PLIST_SUB+= PORTNAME=${PORTNAME}
NO_BUILD= yes
diff --git a/sysutils/puppet/Makefile b/sysutils/puppet/Makefile
index ef48a80407c1..c6d6e1c1c0f8 100644
--- a/sysutils/puppet/Makefile
+++ b/sysutils/puppet/Makefile
@@ -29,7 +29,6 @@ USERS= puppet
GROUPS= puppet
SUB_FILES+= pkg-message
SUB_LIST= RUBY=${RUBY}
-PLIST_SUB+= RESETPREFIX=${PREFIX}
OPTIONS_DEFINE= DOCS EXAMPLES
OPTIONS_DEFAULT= PACKAGE_ORIGIN
diff --git a/sysutils/puppet27/Makefile b/sysutils/puppet27/Makefile
index 0d31277c731c..a4ab2e86bce7 100644
--- a/sysutils/puppet27/Makefile
+++ b/sysutils/puppet27/Makefile
@@ -26,7 +26,6 @@ PORTEXAMPLES= *
USERS= puppet
GROUPS= puppet
SUB_FILES+= pkg-message
-PLIST_SUB+= RESETPREFIX=${PREFIX}
PORTSCOUT= limit:^2\.7\.
diff --git a/www/free-sa-devel/Makefile b/www/free-sa-devel/Makefile
index 8e160affcb8c..5f640e496e59 100644
--- a/www/free-sa-devel/Makefile
+++ b/www/free-sa-devel/Makefile
@@ -22,7 +22,6 @@ DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${DISTVERSION}
SUB_FILES= pkg-deinstall
SUB_LIST= CACHEDIR="/var/cache/free-sa"
-PLIST_SUB+= RESETPREFIX=${PREFIX}
USE_CSTD= gnu89
diff --git a/www/linux-f10-flashplugin11/Makefile b/www/linux-f10-flashplugin11/Makefile
index 505479f66f12..97739828a176 100644
--- a/www/linux-f10-flashplugin11/Makefile
+++ b/www/linux-f10-flashplugin11/Makefile
@@ -32,7 +32,6 @@ OPTIONS_DEFINE= GNOME
GNOME_DESC= include gnome support for .desktop file
OPTIONS_SUB= yes
-PLIST_SUB+=RESETPREFIX=${PREFIX}
.include <bsd.port.options.mk>
diff --git a/www/polipo/Makefile b/www/polipo/Makefile
index 36c93d9a3527..33c9cba4d602 100644
--- a/www/polipo/Makefile
+++ b/www/polipo/Makefile
@@ -27,7 +27,6 @@ SUB_FILES= pkg-message pkg-install pkg-deinstall 400.polipo
SUB_LIST+= USER=${PUSER} GROUP=${PGRP} DESTDIR=${DESTDIR} PCONFIGDIR=${PCONFIGDIR} \
PCACHEDIR=${PCACHEDIR} PPIDDIR=${PPIDDIR} PPIDFILE=${PPIDFILE} \
PLOGFILE=${PLOGFILE}
-PLIST_SUB+= RESETPREFIX=${PREFIX}
# polipo installation options, propagated to install scripts
PUSER?= polipo
diff --git a/www/py-graphite-web/Makefile b/www/py-graphite-web/Makefile
index 0b656059ad30..dc7d41fbaded 100644
--- a/www/py-graphite-web/Makefile
+++ b/www/py-graphite-web/Makefile
@@ -25,7 +25,6 @@ USE_PYDISTUTILS=yes
SUB_FILES= pkg-message
SUB_LIST+= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR} WWWOWN=${WWWOWN} \
WWWGRP=${WWWGRP} DATADIR=${DATADIR}
-PLIST_SUB+= RESETPREFIX=${PREFIX}
post-patch:
@${RM} ${WRKSRC}/bin/build-index.sh.orig
diff --git a/x11-wm/compiz/Makefile b/x11-wm/compiz/Makefile
index 59c8783983f1..225973244b30 100644
--- a/x11-wm/compiz/Makefile
+++ b/x11-wm/compiz/Makefile
@@ -23,8 +23,6 @@ USE_GNOME= gconf2 libxslt
USE_XORG= glproto ice sm x11 xcomposite xdamage xext xfixes xinerama \
xrandr xrender
USE_LDCONFIG= yes
-# Workaround buggy pkg_install
-PLIST_SUB= RESETPREFIX=${PREFIX}
GCONF_SCHEMAS= gwd.schemas \
compiz-annotate.schemas \