aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-09-28 01:53:59 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-09-28 01:53:59 +0000
commit6cf6bed8241173839b755f22667ccd6d403a831f (patch)
tree74b01b1c6f8dcf7bfe8a49b10b3db378e45cfd67
parentc1481d696ea1e6b43e904d2eb4ca228684773d27 (diff)
downloadports-6cf6bed8241173839b755f22667ccd6d403a831f.tar.gz
ports-6cf6bed8241173839b755f22667ccd6d403a831f.zip
Notes
-rw-r--r--devel/autogen/Makefile8
-rw-r--r--devel/mingw32-gcc/Makefile4
-rw-r--r--devel/msp430-gcc/Makefile5
-rw-r--r--devel/msp430-gcc3/Makefile5
-rw-r--r--games/xracer/Makefile13
-rw-r--r--japanese/xjman/Makefile4
-rw-r--r--math/GiNaC/Makefile4
7 files changed, 11 insertions, 32 deletions
diff --git a/devel/autogen/Makefile b/devel/autogen/Makefile
index 3e966c2f85a1..6806c118d653 100644
--- a/devel/autogen/Makefile
+++ b/devel/autogen/Makefile
@@ -30,10 +30,4 @@ MAN3= optionFree.3 optionLoadLine.3 optionProcess.3 optionRestore.3 \
optionSaveFile.3 optionSaveState.3 optionVersion.3
INFO= autogen
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-BROKEN= "Build fails on amd64"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/mingw32-gcc/Makefile b/devel/mingw32-gcc/Makefile
index 7c048836c64b..5e9f6449c5da 100644
--- a/devel/mingw32-gcc/Makefile
+++ b/devel/mingw32-gcc/Makefile
@@ -76,10 +76,6 @@ BINARIES= gcc cpp g++ g77 gcov gcj gcjh jcf-dump jv-scan grepjar jar
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64"
-BROKEN= "Does not compile on amd64 die to platform rename"
-.endif
-
.if ${ARCH} == "alpha"
BROKEN= "C++ could not be compiled on Alphas"
.endif
diff --git a/devel/msp430-gcc/Makefile b/devel/msp430-gcc/Makefile
index e405fc9656d5..b8e747aceabb 100644
--- a/devel/msp430-gcc/Makefile
+++ b/devel/msp430-gcc/Makefile
@@ -51,11 +51,6 @@ BINARIES= gcc gcc-${GCCVERSION} gcov cpp
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64"
-BROKEN= "Does not compile on amd64 due to platform rename"
-.endif
-
-
post-configure:
@${PERL} -pi.bak -e 's,^(TARGET_CONFIGDIRS\s*=).+$$,\1,' ${WRKSRC}/Makefile
# @${PERL} -pi.bak -e 's,^(install-info:),\1\ndonot-\1,' ${WRKSRC}/gcc/Makefile
diff --git a/devel/msp430-gcc3/Makefile b/devel/msp430-gcc3/Makefile
index e405fc9656d5..b8e747aceabb 100644
--- a/devel/msp430-gcc3/Makefile
+++ b/devel/msp430-gcc3/Makefile
@@ -51,11 +51,6 @@ BINARIES= gcc gcc-${GCCVERSION} gcov cpp
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64"
-BROKEN= "Does not compile on amd64 due to platform rename"
-.endif
-
-
post-configure:
@${PERL} -pi.bak -e 's,^(TARGET_CONFIGDIRS\s*=).+$$,\1,' ${WRKSRC}/Makefile
# @${PERL} -pi.bak -e 's,^(install-info:),\1\ndonot-\1,' ${WRKSRC}/gcc/Makefile
diff --git a/games/xracer/Makefile b/games/xracer/Makefile
index 30a5da9d2e31..1dfb0bf5cb26 100644
--- a/games/xracer/Makefile
+++ b/games/xracer/Makefile
@@ -15,10 +15,6 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} xracer-data.tar.gz
MAINTAINER= troll@digitalspark.net
COMMENT= Awesome WipeOut clone for OpenGL and X11!
-.if ${MACHINE_ARCH} != i386
-BROKEN= "Does not build on ${MACHINE_ARCH}"
-.endif
-
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
USE_XLIB= yes
@@ -30,6 +26,13 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_C
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --disable-esd
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != i386 && ${ARCH} != "amd64"
+BROKEN= "Does not build on ${ARCH}"
+.endif
+
+
post-patch:
@${TOUCH} ${WRKSRC}/stamp-h.in
@@ -49,4 +52,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/japanese/xjman/Makefile b/japanese/xjman/Makefile
index 8511cbbb2324..1ffa55f7e40d 100644
--- a/japanese/xjman/Makefile
+++ b/japanese/xjman/Makefile
@@ -30,8 +30,8 @@ MANSECS= 1 3 5
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
+.if ${ARCH} != "i386" && ${ARCH} != "amd64"
+BROKEN= "Does not compile on !i386 and !amd64"
.endif
post-extract:
diff --git a/math/GiNaC/Makefile b/math/GiNaC/Makefile
index b4678ff635e4..f80ba15e8ad9 100644
--- a/math/GiNaC/Makefile
+++ b/math/GiNaC/Makefile
@@ -34,10 +34,6 @@ LDFLAGS= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64"
-BROKEN= "Configure fails on amd64"
-.endif
-
post-extract:
@${RM} -f ${WRKSRC}/doc/tutorial/ginac.info*