aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-19 13:00:38 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-19 13:00:38 +0000
commit983cf9112463b598c3e53d0cf503d2204df3280a (patch)
tree795707e1d8695b514c98e955b2c0ccf103f9a51a
parenta9ace119ca58c904a66d66cff7dc10ad87039d1a (diff)
downloadports-983cf9112463b598c3e53d0cf503d2204df3280a.tar.gz
ports-983cf9112463b598c3e53d0cf503d2204df3280a.zip
Notes
-rw-r--r--security/bcwipe/Makefile4
-rw-r--r--security/bcwipe/distinfo2
-rw-r--r--security/bcwipe/files/patch-aa18
3 files changed, 16 insertions, 8 deletions
diff --git a/security/bcwipe/Makefile b/security/bcwipe/Makefile
index 3bcc0593ffdf..2c1b283ccd25 100644
--- a/security/bcwipe/Makefile
+++ b/security/bcwipe/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= bcwipe
-PORTVERSION= 0.2.4
+PORTVERSION= 1.2.1
CATEGORIES= security
MASTER_SITES= http://www.jetico.com/linux/ \
- http://www.edunet.hu/~crow/
+ http://www.underworld.hu/~crow/distfiles/
DISTNAME= BCWipe-${PORTVERSION:S/./-/g:S/-/./}
MAINTAINER= crow@nektor.hu
diff --git a/security/bcwipe/distinfo b/security/bcwipe/distinfo
index 92ea0435dfab..31ec14c9005b 100644
--- a/security/bcwipe/distinfo
+++ b/security/bcwipe/distinfo
@@ -1 +1 @@
-MD5 (BCWipe-0.2-4.tar.gz) = a1fd3b04bfddbef19182010d2426907d
+MD5 (BCWipe-1.2-1.tar.gz) = 54fedd9835d436a9eacf3eec6d9c5bcb
diff --git a/security/bcwipe/files/patch-aa b/security/bcwipe/files/patch-aa
index 5130be390cee..1e876cd57911 100644
--- a/security/bcwipe/files/patch-aa
+++ b/security/bcwipe/files/patch-aa
@@ -1,6 +1,14 @@
---- wipe.c.orig Thu Jun 6 17:25:28 2002
-+++ wipe.c Thu Jun 6 17:26:36 2002
-@@ -66,7 +66,7 @@
+--- wipe.c Fri Nov 8 11:21:30 2002
++++ wipe.c Fri Nov 8 11:15:03 2002
+@@ -28,7 +28,6 @@
+ #include <utime.h>
+ #include <stdlib.h>
+ #include <sys/ioctl.h>
+-#include <sys/vfs.h>
+ #include <time.h>
+ #include <ctype.h>
+ #include <sys/mount.h>
+@@ -68,7 +67,7 @@
int ask_y_n(char *string)
{
char c;
@@ -9,7 +17,7 @@
c = tolower(fgetc(stdin));
if ( '\n' == c ) return FALSE;
while ( '\n' != fgetc(stdin) );
-@@ -675,7 +675,7 @@
+@@ -700,7 +699,7 @@
case '?':
case 'h':
default:
@@ -18,7 +26,7 @@
exit(0);
} /* end of switch */
} /* end of while */
-@@ -685,7 +685,7 @@
+@@ -710,7 +709,7 @@
if ( 0 == argc )
{