aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-30 08:19:46 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-30 08:19:46 +0000
commit9f54922ba98dcf47dc80fdafd3688780aec58b48 (patch)
treeae7be49ab6732da9d214b4e213f25bb9c13514a0
parent3899c624611d989505a26a6f9a7dad06565c2c28 (diff)
downloadports-9f54922ba98dcf47dc80fdafd3688780aec58b48.tar.gz
ports-9f54922ba98dcf47dc80fdafd3688780aec58b48.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Types-Path-Tiny/Makefile30
-rw-r--r--devel/p5-Types-Path-Tiny/distinfo2
-rw-r--r--devel/p5-Types-Path-Tiny/pkg-descr9
-rw-r--r--devel/p5-Types-Path-Tiny/pkg-plist1
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c01ba88409f6..eb9997de7140 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2971,6 +2971,7 @@
SUBDIR += p5-Tree-Simple-VisitorFactory
SUBDIR += p5-Type-Tie
SUBDIR += p5-Type-Tiny
+ SUBDIR += p5-Types-Path-Tiny
SUBDIR += p5-Types-Serialiser
SUBDIR += p5-UDCode
SUBDIR += p5-UI-Dialog
diff --git a/devel/p5-Types-Path-Tiny/Makefile b/devel/p5-Types-Path-Tiny/Makefile
new file mode 100644
index 000000000000..62f39032269d
--- /dev/null
+++ b/devel/p5-Types-Path-Tiny/Makefile
@@ -0,0 +1,30 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Types-Path-Tiny
+PORTVERSION= 0.005
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:DAGOLDEN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Path::Tiny types and coercions for Moose and Moo
+
+LICENSE= AL2
+
+BUILD_DEPENDS= p5-Path-Tiny>=0:${PORTSDIR}/devel/p5-Path-Tiny \
+ p5-Type-Tiny>=0.008:${PORTSDIR}/devel/p5-Type-Tiny
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-File-pushd>=0:${PORTSDIR}/devel/p5-File-pushd
+
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501400
+TEST_DEPENDS+= p5-Test-Simple>=0.96:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Types-Path-Tiny/distinfo b/devel/p5-Types-Path-Tiny/distinfo
new file mode 100644
index 000000000000..5b82d8d33d8d
--- /dev/null
+++ b/devel/p5-Types-Path-Tiny/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Types-Path-Tiny-0.005.tar.gz) = f702772c56695696d520313b7f9bb4c1f4f6c7e5d47f08917c9944ad8f09ce26
+SIZE (Types-Path-Tiny-0.005.tar.gz) = 12834
diff --git a/devel/p5-Types-Path-Tiny/pkg-descr b/devel/p5-Types-Path-Tiny/pkg-descr
new file mode 100644
index 000000000000..3276fd7ca197
--- /dev/null
+++ b/devel/p5-Types-Path-Tiny/pkg-descr
@@ -0,0 +1,9 @@
+Types::Path::Tiny provides Path::Tiny types for Moose, Moo, etc.
+
+It handles two important types of coercion:
+- coercing objects with overloaded stringification
+- coercing to absolute paths
+
+It also can check to ensure that files or directories exist.
+
+WWW: http://search.cpan.org/dist/Types-Path-Tiny/
diff --git a/devel/p5-Types-Path-Tiny/pkg-plist b/devel/p5-Types-Path-Tiny/pkg-plist
new file mode 100644
index 000000000000..8fb5cc4556d5
--- /dev/null
+++ b/devel/p5-Types-Path-Tiny/pkg-plist
@@ -0,0 +1 @@
+@comment $FreeBSD$