aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2002-07-24 11:00:09 +0000
committerStefan Eßer <se@FreeBSD.org>2002-07-24 11:00:09 +0000
commita28a7425c4728087700b76fded553ad9bc406ddf (patch)
tree45400290bb56db6ae59e9bce1ad72fd31ed14371
parent24686b7073fef6e91ac97f11f5c9a4bc70e20c24 (diff)
downloadports-a28a7425c4728087700b76fded553ad9bc406ddf.tar.gz
ports-a28a7425c4728087700b76fded553ad9bc406ddf.zip
Notes
-rw-r--r--dns/ez-ipupdate/Makefile26
-rw-r--r--dns/ez-ipupdate/distinfo2
-rw-r--r--dns/ez-ipupdate/pkg-comment1
-rw-r--r--dns/ez-ipupdate/pkg-descr23
-rw-r--r--dns/ez-ipupdate/pkg-plist13
-rw-r--r--net/Makefile1
-rw-r--r--net/ez-ipupdate/Makefile26
-rw-r--r--net/ez-ipupdate/distinfo2
-rw-r--r--net/ez-ipupdate/pkg-comment1
-rw-r--r--net/ez-ipupdate/pkg-descr23
-rw-r--r--net/ez-ipupdate/pkg-plist13
11 files changed, 131 insertions, 0 deletions
diff --git a/dns/ez-ipupdate/Makefile b/dns/ez-ipupdate/Makefile
new file mode 100644
index 000000000000..0b30b781dee4
--- /dev/null
+++ b/dns/ez-ipupdate/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: ez-ipupdate
+# Date created: 24 July 2002
+# Whom: se
+#
+# $FreeBSD$
+#
+
+PORTNAME= ez-ipupdate
+PORTVERSION= 3.0.11b7
+CATEGORIES= net
+MASTER_SITES= http://gusnet.cx/proj/ez-ipupdate/dist/
+
+MAINTAINER= se@FreeBSD.org
+
+GNU_CONFIGURE= yes
+
+post-install:
+ ${MKDIR} ${PREFIX}/share/examples/ez-ipupdate
+ for f in ${WRKSRC}/example-*.conf; \
+ do \
+ ${INSTALL_DATA} $$f ${PREFIX}/share/examples/ez-ipupdate/; \
+ done
+ ${INSTALL_DATA} ${WRKSRC}/example.conf \
+ ${PREFIX}/etc/ez-ipupdate.conf.sample
+
+.include <bsd.port.mk>
diff --git a/dns/ez-ipupdate/distinfo b/dns/ez-ipupdate/distinfo
new file mode 100644
index 000000000000..1f0fac3dea99
--- /dev/null
+++ b/dns/ez-ipupdate/distinfo
@@ -0,0 +1,2 @@
+MD5 (ez-ipupdate-3.0.11b7.tar.gz) = 525be4550b4461fdf105aed8e753b020
+SIZE (ez-ipupdate-3.0.11b7.tar.gz) = 82481
diff --git a/dns/ez-ipupdate/pkg-comment b/dns/ez-ipupdate/pkg-comment
new file mode 100644
index 000000000000..8f18e608cc5c
--- /dev/null
+++ b/dns/ez-ipupdate/pkg-comment
@@ -0,0 +1 @@
+Update your host name on any dynamic DNS service
diff --git a/dns/ez-ipupdate/pkg-descr b/dns/ez-ipupdate/pkg-descr
new file mode 100644
index 000000000000..432067e25e89
--- /dev/null
+++ b/dns/ez-ipupdate/pkg-descr
@@ -0,0 +1,23 @@
+ez-ipupdate is a small utility for updating your host name
+if you are using any of the following dynamic DNS services:
+
+ http://gnudip.cheapnet.net (GNUDip)
+ http://www.dhs.org
+ http://www.dyn.ca (GNUDip)
+ http://www.dyndns.org
+ http://www.dyns.cx
+ http://www.easydns.com
+ http://www.ez-ip.net
+ http://www.hn.org
+ http://www.justlinux.com
+ http://www.ods.org
+ http://www.tzo.com
+ http://www.zoneedit.com
+
+It is pure C and works on Linux, *BSD and Solaris.
+
+The key features are: support for multiple service types, daemon
+mode that monitors your IP address and only sends updates when
+your IP address changes.
+
+WWW: http://gusnet.cx/proj/ez-ipupdate/
diff --git a/dns/ez-ipupdate/pkg-plist b/dns/ez-ipupdate/pkg-plist
new file mode 100644
index 000000000000..218cc8411137
--- /dev/null
+++ b/dns/ez-ipupdate/pkg-plist
@@ -0,0 +1,13 @@
+bin/ez-ipupdate
+etc/ez-ipupdate.conf.sample
+share/examples/ez-ipupdate/example-dhs.conf
+share/examples/ez-ipupdate/example-dyndns.conf
+share/examples/ez-ipupdate/example-dyns.conf
+share/examples/ez-ipupdate/example-easydns.conf
+share/examples/ez-ipupdate/example-gnudip.conf
+share/examples/ez-ipupdate/example-heipv6tb.conf
+share/examples/ez-ipupdate/example-justlinux.conf
+share/examples/ez-ipupdate/example-ods.conf
+share/examples/ez-ipupdate/example-pgpow.conf
+share/examples/ez-ipupdate/example-tzo.conf
+@dirrm share/examples/ez-ipupdate
diff --git a/net/Makefile b/net/Makefile
index 156a0dde1583..96b3d437f576 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -120,6 +120,7 @@
SUBDIR += ettercap
SUBDIR += eudc-emacs20
SUBDIR += everybuddy
+ SUBDIR += ez-ipupdate
SUBDIR += fidelio
SUBDIR += firedns
SUBDIR += firetalk
diff --git a/net/ez-ipupdate/Makefile b/net/ez-ipupdate/Makefile
new file mode 100644
index 000000000000..0b30b781dee4
--- /dev/null
+++ b/net/ez-ipupdate/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: ez-ipupdate
+# Date created: 24 July 2002
+# Whom: se
+#
+# $FreeBSD$
+#
+
+PORTNAME= ez-ipupdate
+PORTVERSION= 3.0.11b7
+CATEGORIES= net
+MASTER_SITES= http://gusnet.cx/proj/ez-ipupdate/dist/
+
+MAINTAINER= se@FreeBSD.org
+
+GNU_CONFIGURE= yes
+
+post-install:
+ ${MKDIR} ${PREFIX}/share/examples/ez-ipupdate
+ for f in ${WRKSRC}/example-*.conf; \
+ do \
+ ${INSTALL_DATA} $$f ${PREFIX}/share/examples/ez-ipupdate/; \
+ done
+ ${INSTALL_DATA} ${WRKSRC}/example.conf \
+ ${PREFIX}/etc/ez-ipupdate.conf.sample
+
+.include <bsd.port.mk>
diff --git a/net/ez-ipupdate/distinfo b/net/ez-ipupdate/distinfo
new file mode 100644
index 000000000000..1f0fac3dea99
--- /dev/null
+++ b/net/ez-ipupdate/distinfo
@@ -0,0 +1,2 @@
+MD5 (ez-ipupdate-3.0.11b7.tar.gz) = 525be4550b4461fdf105aed8e753b020
+SIZE (ez-ipupdate-3.0.11b7.tar.gz) = 82481
diff --git a/net/ez-ipupdate/pkg-comment b/net/ez-ipupdate/pkg-comment
new file mode 100644
index 000000000000..8f18e608cc5c
--- /dev/null
+++ b/net/ez-ipupdate/pkg-comment
@@ -0,0 +1 @@
+Update your host name on any dynamic DNS service
diff --git a/net/ez-ipupdate/pkg-descr b/net/ez-ipupdate/pkg-descr
new file mode 100644
index 000000000000..432067e25e89
--- /dev/null
+++ b/net/ez-ipupdate/pkg-descr
@@ -0,0 +1,23 @@
+ez-ipupdate is a small utility for updating your host name
+if you are using any of the following dynamic DNS services:
+
+ http://gnudip.cheapnet.net (GNUDip)
+ http://www.dhs.org
+ http://www.dyn.ca (GNUDip)
+ http://www.dyndns.org
+ http://www.dyns.cx
+ http://www.easydns.com
+ http://www.ez-ip.net
+ http://www.hn.org
+ http://www.justlinux.com
+ http://www.ods.org
+ http://www.tzo.com
+ http://www.zoneedit.com
+
+It is pure C and works on Linux, *BSD and Solaris.
+
+The key features are: support for multiple service types, daemon
+mode that monitors your IP address and only sends updates when
+your IP address changes.
+
+WWW: http://gusnet.cx/proj/ez-ipupdate/
diff --git a/net/ez-ipupdate/pkg-plist b/net/ez-ipupdate/pkg-plist
new file mode 100644
index 000000000000..218cc8411137
--- /dev/null
+++ b/net/ez-ipupdate/pkg-plist
@@ -0,0 +1,13 @@
+bin/ez-ipupdate
+etc/ez-ipupdate.conf.sample
+share/examples/ez-ipupdate/example-dhs.conf
+share/examples/ez-ipupdate/example-dyndns.conf
+share/examples/ez-ipupdate/example-dyns.conf
+share/examples/ez-ipupdate/example-easydns.conf
+share/examples/ez-ipupdate/example-gnudip.conf
+share/examples/ez-ipupdate/example-heipv6tb.conf
+share/examples/ez-ipupdate/example-justlinux.conf
+share/examples/ez-ipupdate/example-ods.conf
+share/examples/ez-ipupdate/example-pgpow.conf
+share/examples/ez-ipupdate/example-tzo.conf
+@dirrm share/examples/ez-ipupdate