aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2017-11-28 20:27:09 +0000
committerBernard Spil <brnrd@FreeBSD.org>2017-11-28 20:27:09 +0000
commitac6e638304a2b52f2c07b61e0dfa6991ca15f4b1 (patch)
tree5977084ae1c699e6ba29d6192867f549e447d848
parent377b0146b16df424857ed6f8ba5fa5ed86a3e906 (diff)
downloadports-ac6e638304a2b52f2c07b61e0dfa6991ca15f4b1.tar.gz
ports-ac6e638304a2b52f2c07b61e0dfa6991ca15f4b1.zip
MFH: r454922
security/acme-client: Chase upstream URL update - Unbreaks users fresh installing port Reported by: David Gessel <gessel blackrosetech com> Approved by: ports-secteam (swills)
Notes
Notes: svn path=/branches/2017Q4/; revision=455074
-rw-r--r--security/acme-client/Makefile4
-rw-r--r--security/acme-client/files/patch-main.c11
2 files changed, 13 insertions, 2 deletions
diff --git a/security/acme-client/Makefile b/security/acme-client/Makefile
index a287f4a0d69a..40f08d0f7517 100644
--- a/security/acme-client/Makefile
+++ b/security/acme-client/Makefile
@@ -3,7 +3,7 @@
PORTNAME= acme-client
PORTVERSION= 0.1.16
-PORTREVISION= 1
+PORTREVISION= 2
DISTVERSIONPREFIX= portable-
CATEGORIES= security
MASTER_SITES= https://kristaps.bsd.lv/${PORTNAME}/snapshots/ \
@@ -58,7 +58,7 @@ STAGEDIR_libressl!= ${MAKE} -V STAGEDIR -C ${PORTSDIR}/security/libressl
. endif
pre-configure:
- @(cd ${STAGEDIR_libressl}${LOCALBASE} && ${COPYTREE_SHARE} \
+ (cd ${STAGEDIR_libressl}${LOCALBASE} && ${COPYTREE_SHARE} \
. ${WRKDIR}/libressl "! -name *.so*")
.endif # SSL_DEFAULT
diff --git a/security/acme-client/files/patch-main.c b/security/acme-client/files/patch-main.c
new file mode 100644
index 000000000000..961578b4b494
--- /dev/null
+++ b/security/acme-client/files/patch-main.c
@@ -0,0 +1,11 @@
+--- main.c.orig 2017-02-01 15:20:14 UTC
++++ main.c
+@@ -33,7 +33,7 @@
+ #include "extern.h"
+
+ #define AGREEMENT "https://letsencrypt.org" \
+- "/documents/LE-SA-v1.1.1-August-1-2016.pdf"
++ "/documents/LE-SA-v1.2-November-15-2017.pdf"
+ #define SSL_DIR "/etc/ssl/acme"
+ #define SSL_PRIV_DIR "/etc/ssl/acme/private"
+ #define ETC_DIR "/etc/acme"