aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-12-11 00:04:24 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-12-11 00:04:24 +0000
commitb03db50f3506c0f4b459262d327866abd6b2244c (patch)
treeff1eae047de2c8cf8634ced4fdb52a9cd5a83c27
parent9568c9c738eb8a83477ca48a295a280503511875 (diff)
downloadports-b03db50f3506c0f4b459262d327866abd6b2244c.tar.gz
ports-b03db50f3506c0f4b459262d327866abd6b2244c.zip
MFH: r455904
textproc/hunspell: always link against C++11 library C++11 isn't ABI-compatible with C++98 on GCC platforms, so build the port using lang/gcc which since r449590 defaults to C++14. This should fix C++11 consumers like www/firefox. ../../extensions/spellcheck/hunspell/glue/Unified_cpp_hunspell_glue0.o: In function `mozHunspell::SetDictionary(char16_t const*)': Unified_cpp_hunspell_glue0.cpp:(.text._ZN11mozHunspell13SetDictionaryEPKDs+0x4a4): undefined reference to `Hunspell::get_dict_encoding[abi:cxx11]() const' ../../extensions/spellcheck/hunspell/glue/Unified_cpp_hunspell_glue0.o: In function `mozHunspell::Check(char16_t const*, bool*)': Unified_cpp_hunspell_glue0.cpp:(.text._ZN11mozHunspell5CheckEPKDsPb+0x148): undefined reference to `Hunspell::spell(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, int*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >*)' ../../extensions/spellcheck/hunspell/glue/Unified_cpp_hunspell_glue0.o: In function `mozHunspell::Suggest(char16_t const*, char16_t***, unsigned int*)': Unified_cpp_hunspell_glue0.cpp:(.text._ZN11mozHunspell7SuggestEPKDsPPPDsPj+0x16c): undefined reference to `Hunspell::suggest(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)' Submitted by: jhibbits (based on) Approved by: ports-secteam blanket Differential Revision: https://reviews.freebsd.org/D12515
Notes
Notes: svn path=/branches/2017Q4/; revision=455915
-rw-r--r--textproc/hunspell/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/textproc/hunspell/Makefile b/textproc/hunspell/Makefile
index f752514a0cf1..0fe0426b34b3 100644
--- a/textproc/hunspell/Makefile
+++ b/textproc/hunspell/Makefile
@@ -19,8 +19,8 @@ LICENSE_FILE_MPL11= ${WRKSRC}/COPYING.MPL
CONFLICTS_INSTALL= tinker-[0-9]*
CONFIGURE_ARGS= --disable-nls ${ICONV_CONFIGURE_ARG} --with-readline --with-ui
GNU_CONFIGURE= yes
-USES= autoreconf libtool:keepla pathfix iconv ncurses \
- readline shebangfix perl5
+USES= autoreconf compiler:c++11-lib libtool:keepla pathfix \
+ iconv ncurses readline shebangfix perl5
USE_GITHUB= yes
SHEBANG_FILES= src/tools/ispellaff2myspell
USE_LDCONFIG= yes