aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2003-12-22 02:13:59 +0000
committerEric Anholt <anholt@FreeBSD.org>2003-12-22 02:13:59 +0000
commitbe6732eb44f26e65a619d74aae3e0ffdf06e4ce8 (patch)
tree73453d62fb17dab20039b728b4a803cca717a970
parentb3faf157647268c1a3803a777cb426561718d21d (diff)
downloadports-be6732eb44f26e65a619d74aae3e0ffdf06e4ce8.tar.gz
ports-be6732eb44f26e65a619d74aae3e0ffdf06e4ce8.zip
Notes
-rw-r--r--x11/Makefile1
-rw-r--r--x11/libXrandr/Makefile33
-rw-r--r--x11/libXrandr/distinfo1
-rw-r--r--x11/libXrandr/files/patch-Makefile.in11
-rw-r--r--x11/libXrandr/pkg-descr6
-rw-r--r--x11/libXrandr/pkg-plist6
6 files changed, 58 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 184f4a054a86..6beffda98060 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -82,6 +82,7 @@
SUBDIR += libXext
SUBDIR += libXfont
SUBDIR += libXi
+ SUBDIR += libXrandr
SUBDIR += libXres
SUBDIR += libXtrans
SUBDIR += libXv
diff --git a/x11/libXrandr/Makefile b/x11/libXrandr/Makefile
new file mode 100644
index 000000000000..79b8a8b621c4
--- /dev/null
+++ b/x11/libXrandr/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libXrandr
+# Date Created: 9 Nov, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libXrandr
+PORTVERSION= 1.0.1.p1
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X Resize and Rotate extension library
+
+LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/xext.pc:${PORTSDIR}/x11/libXext \
+ ${X11BASE}/libdata/pkgconfig/xrender.pc:${PORTSDIR}/x11-toolkits/xrender
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ${X11BASE}/libdata/pkgconfig/randr.pc:${PORTSDIR}/x11/randrext \
+ ${X11BASE}/libdata/pkgconfig/xextensions.pc:${PORTSDIR}/x11/xextensions \
+ ${LIB_PC_DEPENDS}
+RUN_DEPENDS= ${LIB_PC_DEPENDS}
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GMAKE= yes
+CFLAGS+= -DMALLOC_0_RETURNS_NULL
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.0.1
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/x11/libXrandr/distinfo b/x11/libXrandr/distinfo
new file mode 100644
index 000000000000..d4c8d49782af
--- /dev/null
+++ b/x11/libXrandr/distinfo
@@ -0,0 +1 @@
+MD5 (libXrandr-1.0.1.p1.tar.bz2) = 653efec2840a244c05a762058f5b3331
diff --git a/x11/libXrandr/files/patch-Makefile.in b/x11/libXrandr/files/patch-Makefile.in
new file mode 100644
index 000000000000..7cfdef76cefd
--- /dev/null
+++ b/x11/libXrandr/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sun Nov 9 23:52:13 2003
++++ Makefile.in Sun Nov 9 23:52:26 2003
+@@ -184,7 +184,7 @@
+ libXrandrincludedir = $(includedir)/X11/extensions
+ libXrandrinclude_HEADERS = Xrandr.h
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = xrandr.pc
+
+ EXTRA_DIST = xrandr.pc.in autogen.sh test.c
diff --git a/x11/libXrandr/pkg-descr b/x11/libXrandr/pkg-descr
new file mode 100644
index 000000000000..a33730683f80
--- /dev/null
+++ b/x11/libXrandr/pkg-descr
@@ -0,0 +1,6 @@
+This package contains the X Resize and Rotate extension library.
+
+WWW: http://www.freedesktop.org/Software/xlibs
+
+- Eric Anholt
+anholt@FreeBSD.org
diff --git a/x11/libXrandr/pkg-plist b/x11/libXrandr/pkg-plist
new file mode 100644
index 000000000000..1b0f1f3393e5
--- /dev/null
+++ b/x11/libXrandr/pkg-plist
@@ -0,0 +1,6 @@
+include/X11/extensions/Xrandr.h
+lib/libXrandr.a
+lib/libXrandr.la
+lib/libXrandr.so
+lib/libXrandr.so.2
+libdata/pkgconfig/xrandr.pc