aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-01-03 23:26:25 +0000
committerWill Andrews <will@FreeBSD.org>2001-01-03 23:26:25 +0000
commitcfe47e3876dd5373c866479448ea8f5583675eee (patch)
treeaa482abc62ecf1078148c7a6c19df5cf1594edb9
parentc6b6c065ac5c0b024d23e89c4361c5a43885e3d1 (diff)
downloadports-cfe47e3876dd5373c866479448ea8f5583675eee.tar.gz
ports-cfe47e3876dd5373c866479448ea8f5583675eee.zip
Notes
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-Rijndael/Makefile23
-rw-r--r--security/p5-Crypt-Rijndael/distinfo1
-rw-r--r--security/p5-Crypt-Rijndael/pkg-comment1
-rw-r--r--security/p5-Crypt-Rijndael/pkg-descr7
-rw-r--r--security/p5-Crypt-Rijndael/pkg-plist5
6 files changed, 38 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index bf093c64e0e4..992346d1bb6a 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -79,6 +79,7 @@
SUBDIR += p5-Crypt-DES
SUBDIR += p5-Crypt-ECB
SUBDIR += p5-Crypt-IDEA
+ SUBDIR += p5-Crypt-Rijndael
SUBDIR += p5-Crypt-SSLeay
SUBDIR += p5-Digest-MD5
SUBDIR += p5-GnuPG-Interface
diff --git a/security/p5-Crypt-Rijndael/Makefile b/security/p5-Crypt-Rijndael/Makefile
new file mode 100644
index 000000000000..f5b8cd6d9321
--- /dev/null
+++ b/security/p5-Crypt-Rijndael/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: Crypt-Rijndael
+# Date created: Wed Jan 3 16:15:20 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-Rijndael
+PORTVERSION= 0.01
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Crypt::Rijndael.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Rijndael/distinfo b/security/p5-Crypt-Rijndael/distinfo
new file mode 100644
index 000000000000..8665e6499e23
--- /dev/null
+++ b/security/p5-Crypt-Rijndael/distinfo
@@ -0,0 +1 @@
+MD5 (Crypt-Rijndael-0.01.tar.gz) = 7e1638e42d0cbc7545bebca7b45d5d16
diff --git a/security/p5-Crypt-Rijndael/pkg-comment b/security/p5-Crypt-Rijndael/pkg-comment
new file mode 100644
index 000000000000..3079b2feea80
--- /dev/null
+++ b/security/p5-Crypt-Rijndael/pkg-comment
@@ -0,0 +1 @@
+Perl module that implements the Rijndael cipher
diff --git a/security/p5-Crypt-Rijndael/pkg-descr b/security/p5-Crypt-Rijndael/pkg-descr
new file mode 100644
index 000000000000..1a70d2eca34e
--- /dev/null
+++ b/security/p5-Crypt-Rijndael/pkg-descr
@@ -0,0 +1,7 @@
+Crypt::Rijndael is a Crypt::CBC compliant Rijndael encryption module that
+implements the Rijndael cipher, which has just been selected as the new
+Advanced Encryption Standard (AES).
+
+Author: Rafael R. Sevilla <dido@pacific.net.ph>
+
+--will
diff --git a/security/p5-Crypt-Rijndael/pkg-plist b/security/p5-Crypt-Rijndael/pkg-plist
new file mode 100644
index 000000000000..e0eb6c94feb2
--- /dev/null
+++ b/security/p5-Crypt-Rijndael/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Crypt/Rijndael.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/Rijndael/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/Rijndael/Rijndael.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/Rijndael/Rijndael.so
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/Rijndael