aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-10-19 08:59:55 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-10-19 08:59:55 +0000
commitd7fe414482dff66c41b46b8fc2207df1b68b2ecd (patch)
treeef8fa231751a942b504c73a338ec69846fc58460
parent473635d704c5d1ba38394b69604cc0ac426a2659 (diff)
downloadports-d7fe414482dff66c41b46b8fc2207df1b68b2ecd.tar.gz
ports-d7fe414482dff66c41b46b8fc2207df1b68b2ecd.zip
Notes
-rw-r--r--devel/libds/files/patch-Makefile22
-rw-r--r--devel/mk/files/patch-lib::9::Makefile11
-rw-r--r--devel/mk/files/patch-lib::bio::Makefile11
-rw-r--r--devel/mk/files/patch-lib::regexp::Makefile11
-rw-r--r--devel/mk/files/patch-src::Makefile11
5 files changed, 66 insertions, 0 deletions
diff --git a/devel/libds/files/patch-Makefile b/devel/libds/files/patch-Makefile
new file mode 100644
index 000000000000..90e1ca220b18
--- /dev/null
+++ b/devel/libds/files/patch-Makefile
@@ -0,0 +1,22 @@
+--- Makefile.orig Sun Oct 19 01:56:50 2003
++++ Makefile Sun Oct 19 01:56:43 2003
+@@ -5,8 +5,8 @@
+ # Makefile for LibDS 2.0
+ #
+
+-CC = cc
+-CCOPTFLAGS = -O2
++CC ?= cc
++CCOPTFLAGS = $(CFLAGS)
+
+ CCEXTRAFLAGS = -DStandAlone
+
+@@ -42,7 +42,7 @@
+ $(TARGET)
+
+ gcc:
+- @-$(MAKE) CC="gcc -pipe" CCWARNFLAGS="-Wall -W -Wshadow \
++ @-$(MAKE) CC=$(CC) CCWARNFLAGS="-Wall -W -Wshadow \
+ -Wnested-externs -Wwrite-strings -Wpointer-arith \
+ -Wmissing-declarations -Wredundant-decls -Winline \
+ -Wstrict-prototypes" SHARED="-shared" release
diff --git a/devel/mk/files/patch-lib::9::Makefile b/devel/mk/files/patch-lib::9::Makefile
new file mode 100644
index 000000000000..afbee6123466
--- /dev/null
+++ b/devel/mk/files/patch-lib::9::Makefile
@@ -0,0 +1,11 @@
+--- lib/9/Makefile.orig Sun Oct 19 01:51:44 2003
++++ lib/9/Makefile Sun Oct 19 01:51:50 2003
+@@ -16,7 +16,7 @@
+ newprint.o
+
+ TARG=../lib9.a
+-CFLAGS=-g -I../../include
++CFLAGS+=-g -I../../include
+
+ all: $(TARG)
+
diff --git a/devel/mk/files/patch-lib::bio::Makefile b/devel/mk/files/patch-lib::bio::Makefile
new file mode 100644
index 000000000000..4d8fc3abc2d8
--- /dev/null
+++ b/devel/mk/files/patch-lib::bio::Makefile
@@ -0,0 +1,11 @@
+--- lib/bio/Makefile.orig Sun Oct 19 01:51:44 2003
++++ lib/bio/Makefile Sun Oct 19 01:51:55 2003
+@@ -12,7 +12,7 @@
+ OFILES=bflush.o bgetc.o bgetrune.o binit.o bprint.o bputc.o bwrite.o
+
+ TARG=../libbio.a
+-CFLAGS=-g -I../../include
++CFLAGS+=-g -I../../include
+
+ all: $(TARG)
+
diff --git a/devel/mk/files/patch-lib::regexp::Makefile b/devel/mk/files/patch-lib::regexp::Makefile
new file mode 100644
index 000000000000..61593dd658b6
--- /dev/null
+++ b/devel/mk/files/patch-lib::regexp::Makefile
@@ -0,0 +1,11 @@
+--- lib/regexp/Makefile.orig Sun Oct 19 01:51:44 2003
++++ lib/regexp/Makefile Sun Oct 19 01:51:59 2003
+@@ -8,7 +8,7 @@
+ OFILES=regaux.o regcomp.o regexec.o regsub.o
+
+ TARG=../libregexp.a
+-CFLAGS=-g -I../../include
++CFLAGS+=-g -I../../include
+
+ all: $(TARG)
+
diff --git a/devel/mk/files/patch-src::Makefile b/devel/mk/files/patch-src::Makefile
new file mode 100644
index 000000000000..a2c23537184d
--- /dev/null
+++ b/devel/mk/files/patch-src::Makefile
@@ -0,0 +1,11 @@
+--- src/Makefile.orig Sun Oct 19 01:50:46 2003
++++ src/Makefile Sun Oct 19 01:50:14 2003
+@@ -5,7 +5,7 @@
+
+
+ TARG=../mk
+-CFLAGS=-g -I../include
++CFLAGS+=-g -I../include
+
+ $(TARG): $(OFILES) ../lib/libregexp.a ../lib/libbio.a ../lib/lib9.a
+ $(CC) -o $(TARG) $(OFILES) -L../lib -lregexp -lbio -l9