aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-01-25 01:55:16 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-01-25 01:55:16 +0000
commitdc91ddc6dfb06df8f060f6aade778dc49b2199a8 (patch)
tree8e7c0a55ab6ebcff9defa22dc03f87678a688047
parent2fe60d75552ecc9ee7fed802400ede2466543024 (diff)
downloadports-dc91ddc6dfb06df8f060f6aade778dc49b2199a8.tar.gz
ports-dc91ddc6dfb06df8f060f6aade778dc49b2199a8.zip
Notes
-rw-r--r--ftp/gwget/Makefile2
-rw-r--r--ftp/gwget/distinfo4
-rw-r--r--ftp/gwget/files/patch-src_main.c18
3 files changed, 21 insertions, 3 deletions
diff --git a/ftp/gwget/Makefile b/ftp/gwget/Makefile
index 4d204f1205c3..b927106c1553 100644
--- a/ftp/gwget/Makefile
+++ b/ftp/gwget/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gwget
-PORTVERSION= 0.92.1
+PORTVERSION= 0.93
CATEGORIES= ftp www gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/ftp/gwget/distinfo b/ftp/gwget/distinfo
index 2891bfb19616..928e7eb686ab 100644
--- a/ftp/gwget/distinfo
+++ b/ftp/gwget/distinfo
@@ -1,2 +1,2 @@
-MD5 (gwget-0.92.1.tar.gz) = 54de1302be77e1a1460baf7a27c6cbd8
-SIZE (gwget-0.92.1.tar.gz) = 516157
+MD5 (gwget-0.93.tar.gz) = 79a3625ef99a5a417164e0d97020fcc5
+SIZE (gwget-0.93.tar.gz) = 526996
diff --git a/ftp/gwget/files/patch-src_main.c b/ftp/gwget/files/patch-src_main.c
new file mode 100644
index 000000000000..9bba1055e4a1
--- /dev/null
+++ b/ftp/gwget/files/patch-src_main.c
@@ -0,0 +1,18 @@
+--- src/main.c.orig Mon Jan 24 20:50:50 2005
++++ src/main.c Mon Jan 24 20:51:46 2005
+@@ -145,12 +145,13 @@
+ static void
+ gnome_session_join(int argc,char *argv[])
+ {
+- Args *args = g_malloc(sizeof(Args));
++ GnomeClient* client;
++ Args *args= g_malloc(sizeof(Args));
+
+ (*args).argc = argc;
+ (*args).argv = argv;
+
+- GnomeClient* client = gnome_master_client();
++ client = gnome_master_client();
+
+ gnome_client_set_restart_style(client,GNOME_RESTART_IF_RUNNING);
+ gtk_signal_connect(GTK_OBJECT(client),"save_yourself",