aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-05 14:40:25 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-05 14:40:25 +0000
commitffba9de11af0db8c5f775ee245df4871e0953068 (patch)
treea6da29d7349f8e0aa67345a4e06d4c8135ff6b8b
parent951990e938e20a19333b795aca33f2750314a3e5 (diff)
downloadports-ffba9de11af0db8c5f775ee245df4871e0953068.tar.gz
ports-ffba9de11af0db8c5f775ee245df4871e0953068.zip
Notes
-rw-r--r--sysutils/x86info/Makefile7
-rw-r--r--sysutils/x86info/distinfo4
-rw-r--r--sysutils/x86info/files/patch-bench_benchmarks.c12
-rw-r--r--sysutils/x86info/files/patch-cpuid_UP.S27
-rw-r--r--sysutils/x86info/files/patch-mptable.c11
-rw-r--r--sysutils/x86info/files/patch-x86info.h23
6 files changed, 24 insertions, 60 deletions
diff --git a/sysutils/x86info/Makefile b/sysutils/x86info/Makefile
index 151c7dce967c..42ed75ef161d 100644
--- a/sysutils/x86info/Makefile
+++ b/sysutils/x86info/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= x86info
-PORTVERSION= 1.14
+PORTVERSION= 1.16
CATEGORIES= sysutils
MASTER_SITES= http://www.codemonkey.org.uk/projects/x86info/ \
${MASTER_SITE_SOURCEFORGE}
@@ -21,11 +21,6 @@ PLIST_FILES= bin/x86info
USE_REINPLACE= yes
MAKE_ARGS= CFLAGS="${CFLAGS}"
-post-patch:
-.for file in x86info.h mptable.c
- @${REINPLACE_CMD} -e "s|machine/types.h|sys/types.h|g" ${WRKSRC}/${file}
-.endfor
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/x86info ${PREFIX}/bin
diff --git a/sysutils/x86info/distinfo b/sysutils/x86info/distinfo
index 2138d41d3925..a3bb85d080e4 100644
--- a/sysutils/x86info/distinfo
+++ b/sysutils/x86info/distinfo
@@ -1,2 +1,2 @@
-MD5 (x86info-1.14.tgz) = a819dcf9b5deff3dee383edffa81fbca
-SIZE (x86info-1.14.tgz) = 59072
+MD5 (x86info-1.16.tgz) = 57cfb84b006f0f5634ee8bd458330328
+SIZE (x86info-1.16.tgz) = 51410
diff --git a/sysutils/x86info/files/patch-bench_benchmarks.c b/sysutils/x86info/files/patch-bench_benchmarks.c
index 3e644835d648..d6885d16938f 100644
--- a/sysutils/x86info/files/patch-bench_benchmarks.c
+++ b/sysutils/x86info/files/patch-bench_benchmarks.c
@@ -1,21 +1,17 @@
---- bench/benchmarks.c.orig Sun Aug 24 11:04:51 2003
-+++ bench/benchmarks.c Sun Aug 24 11:08:26 2003
-@@ -1,7 +1,8 @@
+--- bench/benchmarks.c.orig Tue Oct 4 19:22:20 2005
++++ bench/benchmarks.c Tue Oct 4 19:22:40 2005
+@@ -1,6 +1,5 @@
#include <time.h>
#include <sys/time.h>
-#include <asm/unistd.h>
-+#include <sys/unistd.h>
#include <sys/stat.h>
-+#include <sys/syscall.h>
#include <stdio.h>
#include "../x86info.h"
- #include "bench.h"
-@@ -13,7 +14,7 @@
+@@ -13,7 +12,6 @@
if (show_bench != 1)
return;
- TIME(asm volatile("int $0x80" :"=a" (ret) :"0" (__NR_getppid)), "int 0x80");
-+ TIME(asm volatile("int $0x80" :"=a" (ret) :"0" (SYS_getppid)), "int 0x80");
TIME(asm volatile("cpuid": : :"ax", "dx", "cx", "bx"), "cpuid");
TIME(asm volatile("addl $1,0(%esp)"), "addl");
diff --git a/sysutils/x86info/files/patch-cpuid_UP.S b/sysutils/x86info/files/patch-cpuid_UP.S
deleted file mode 100644
index 2c660e1ebeac..000000000000
--- a/sysutils/x86info/files/patch-cpuid_UP.S
+++ /dev/null
@@ -1,27 +0,0 @@
---- cpuid_UP.S.orig Wed Aug 24 20:15:46 2005
-+++ cpuid_UP.S Wed Aug 24 20:16:16 2005
-@@ -1,24 +1,9 @@
- .align 4
- .text
-
--#ifdef linux
--
- .globl cpuid_UP
- .type cpuid_UP,@function
- cpuid_UP:
--
--#else /* BSD or WIN32 */
--
--.globl _cpuid_UP
--
--#ifdef __WIN32__
-- .def _cpuid_UP; .scl 2; .type 32; .endef
--#else /* BSD */
-- .type _cpuid_UP,@function
--#endif /* __WIN32__ */
--
--_cpuid_UP:
--#endif /* linux */
-
- #ifdef __x86_64__
- /* x86_64 calling convention: Args passed in rdi, rsi, rdx, rcx, r8, r9;
diff --git a/sysutils/x86info/files/patch-mptable.c b/sysutils/x86info/files/patch-mptable.c
new file mode 100644
index 000000000000..735ac673263d
--- /dev/null
+++ b/sysutils/x86info/files/patch-mptable.c
@@ -0,0 +1,11 @@
+--- mptable.c.orig Tue Oct 4 19:15:02 2005
++++ mptable.c Tue Oct 4 19:15:09 2005
+@@ -39,8 +39,6 @@
+ #include "mptable.h"
+ #include "x86info.h"
+
+-typedef unsigned long vm_offset_t;
+-
+ /* EBDA is @ 40:0e in real-mode terms */
+ #define EBDA_POINTER 0x040e /* location of EBDA pointer */
+
diff --git a/sysutils/x86info/files/patch-x86info.h b/sysutils/x86info/files/patch-x86info.h
index 5c195f3563d0..54957188c8eb 100644
--- a/sysutils/x86info/files/patch-x86info.h
+++ b/sysutils/x86info/files/patch-x86info.h
@@ -1,22 +1,11 @@
---- x86info.h.orig Sun Aug 24 10:59:27 2003
-+++ x86info.h Sun Aug 24 11:00:47 2003
-@@ -1,15 +1,10 @@
+--- x86info.h.orig Tue Oct 4 19:13:58 2005
++++ x86info.h Tue Oct 4 19:14:04 2005
+@@ -1,7 +1,7 @@
#ifndef _X86INFO_H
#define _X86INFO_H
--#ifdef linux
-#include <linux/types.h>
--typedef unsigned char u8;
--typedef unsigned short u16;
--typedef unsigned int u32;
--#else
--#include <machine/types.h>
--#define __u32 int
--#endif /* linux */
+#include <sys/types.h>
-+typedef u_int8_t u8;
-+typedef u_int16_t u16;
-+typedef u_int32_t u32;
-
- #define VENDOR_AMD 1
- #define VENDOR_CENTAUR 2
+ typedef unsigned char u8;
+ typedef unsigned short u16;
+ typedef unsigned int u32;