aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2016-08-12 11:40:38 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2016-08-12 11:40:38 +0000
commit22e37cd71076a04ea849fe577ba31aaf147ef169 (patch)
tree18d76f7b041afbb3f0e69ba904b70671c1029361
parent0d95bb78d08aa6651fa667eba9ff5ad25c533727 (diff)
downloadports-22e37cd71076a04ea849fe577ba31aaf147ef169.tar.gz
ports-22e37cd71076a04ea849fe577ba31aaf147ef169.zip
Notes
-rw-r--r--security/Makefile1
-rw-r--r--security/py-tuf/Makefile28
-rw-r--r--security/py-tuf/distinfo3
-rw-r--r--security/py-tuf/files/patch-setup.py10
-rw-r--r--security/py-tuf/pkg-descr9
5 files changed, 51 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 65f3d619ff8e..49b8384aea47 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -911,6 +911,7 @@
SUBDIR += py-stix
SUBDIR += py-tlslite
SUBDIR += py-trustedpickle
+ SUBDIR += py-tuf
SUBDIR += py-twistedConch
SUBDIR += py-twofish
SUBDIR += py-volatility
diff --git a/security/py-tuf/Makefile b/security/py-tuf/Makefile
new file mode 100644
index 000000000000..0175760cda3a
--- /dev/null
+++ b/security/py-tuf/Makefile
@@ -0,0 +1,28 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= tuf
+PORTVERSION= 0.10.0
+CATEGORIES= security devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Framework for securing software update systems
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}iso8601>0:devel/py-iso8601 \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>0:security/py-cryptography \
+ ${PYTHON_PKGNAMEPREFIX}pycrypto>0:security/py-pycrypto \
+ ${PYTHON_PKGNAMEPREFIX}pynacl>0:security/py-pynacl
+
+# Actually 2.6-3.5
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+do-test:
+ @cd ${WRKSRC}/tests && ${PYTHON_CMD} -m pytest -rsv
+
+.include <bsd.port.mk>
diff --git a/security/py-tuf/distinfo b/security/py-tuf/distinfo
new file mode 100644
index 000000000000..7015d6563a7b
--- /dev/null
+++ b/security/py-tuf/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1470662351
+SHA256 (tuf-0.10.0.tar.gz) = 34042699053ded003c7029c4c450f7ba464cb3a154c4947002432471b392f73e
+SIZE (tuf-0.10.0.tar.gz) = 1719235
diff --git a/security/py-tuf/files/patch-setup.py b/security/py-tuf/files/patch-setup.py
new file mode 100644
index 000000000000..3158e6ee64fa
--- /dev/null
+++ b/security/py-tuf/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- setup.py.orig 2016-08-08 13:44:46 UTC
++++ setup.py
+@@ -111,6 +111,7 @@ setup(
+ install_requires = ['iso8601', 'six'],
+ packages = find_packages(exclude=['tests']),
+ extras_require = extras,
++ test_suite='tests',
+ scripts = [
+ 'tuf/client/basic_client.py'
+ ]
diff --git a/security/py-tuf/pkg-descr b/security/py-tuf/pkg-descr
new file mode 100644
index 000000000000..3917dbff7ec7
--- /dev/null
+++ b/security/py-tuf/pkg-descr
@@ -0,0 +1,9 @@
+TUF (The Update Framework) helps developers secure their new or existing
+software update systems.
+
+Software update systems are vulnerable to many known attacks, including
+those that can result in clients being compromised or crashed. TUF helps
+solve this problem by providing a flexible security framework that can
+be added to software updaters.
+
+WWW: https://www.updateframework.com