aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-06-23 00:34:09 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-06-23 00:34:09 +0000
commit64918cfc644f2140fc9a1c65e9a09f1314507bd2 (patch)
treefd8239ad9c37b7e716ae904e21ee5b91fe6ba069
parent2c3b1ec98fdca0446fc9a6f5de24d8a6dca277f3 (diff)
downloadports-64918cfc644f2140fc9a1c65e9a09f1314507bd2.tar.gz
ports-64918cfc644f2140fc9a1c65e9a09f1314507bd2.zip
MFH: r473095
www/waterfox: apply some FF61 fix Approved by: ports-secteam blanket
Notes
Notes: svn path=/branches/2018Q2/; revision=473108
-rw-r--r--www/waterfox/Makefile2
-rw-r--r--www/waterfox/files/patch-bug145804840
2 files changed, 41 insertions, 1 deletions
diff --git a/www/waterfox/Makefile b/www/waterfox/Makefile
index 3abf17912749..1837d7130cf4 100644
--- a/www/waterfox/Makefile
+++ b/www/waterfox/Makefile
@@ -3,7 +3,7 @@
PORTNAME= waterfox
DISTVERSION= 56.2.1-19
DISTVERSIONSUFFIX= -gff88ad0b627dc
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www ipv6
MAINTAINER= jbeich@FreeBSD.org
diff --git a/www/waterfox/files/patch-bug1458048 b/www/waterfox/files/patch-bug1458048
new file mode 100644
index 000000000000..a15e4d51b559
--- /dev/null
+++ b/www/waterfox/files/patch-bug1458048
@@ -0,0 +1,40 @@
+commit 66dfec8053be
+Author: Daniel Minor <dminor@mozilla.com>
+Date: Wed Jun 20 21:18:50 2018 -0400
+
+ Bug 1458048 - Cherry pick usersctp rev 8789a6da02e2c7c03522bc6f275b302f6ef977fe; r=drno, a=RyanVM
+
+ --HG--
+ extra : source : 492697e43fb4abf3cca014249bc35797f3312236
+ extra : amend_source : 2a960ee15610dd344ceffd22dab70994cbf52198
+---
+ netwerk/sctp/src/netinet/sctp_auth.c | 4 +++-
+ netwerk/sctp/src/netinet/sctp_pcb.c | 4 +++-
+ 2 files changed, 6 insertions(+), 2 deletions(-)
+
+diff --git netwerk/sctp/src/netinet/sctp_auth.c netwerk/sctp/src/netinet/sctp_auth.c
+index 50432ad8a5954..ee5ca36ce37b1 100755
+--- netwerk/sctp/src/netinet/sctp_auth.c
++++ netwerk/sctp/src/netinet/sctp_auth.c
+@@ -1525,6 +1525,8 @@ sctp_auth_get_cookie_params(struct sctp_tcb *stcb, struct mbuf *m,
+ if (p_random != NULL) {
+ keylen = sizeof(*p_random) + random_len;
+ bcopy(p_random, new_key->key, keylen);
++ } else {
++ keylen = 0;
+ }
+ /* append in the AUTH chunks */
+ if (chunks != NULL) {
+diff --git netwerk/sctp/src/netinet/sctp_pcb.c netwerk/sctp/src/netinet/sctp_pcb.c
+index 2970970250a2a..58c164f5039c7 100755
+--- netwerk/sctp/src/netinet/sctp_pcb.c
++++ netwerk/sctp/src/netinet/sctp_pcb.c
+@@ -7688,6 +7688,8 @@ sctp_load_addresses_from_init(struct sctp_tcb *stcb, struct mbuf *m,
+ if (p_random != NULL) {
+ keylen = sizeof(*p_random) + random_len;
+ bcopy(p_random, new_key->key, keylen);
++ } else {
++ keylen = 0;
+ }
+ /* append in the AUTH chunks */
+ if (chunks != NULL) {