aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2018-06-12 14:17:10 +0000
committerBernard Spil <brnrd@FreeBSD.org>2018-06-12 14:17:10 +0000
commit8b030ab1e4c19162fe2172391844d246e0ad0ccf (patch)
treed4a298bb1f52eb838201a1cb553c5373ffd629c6
parent5b606f2b16229726142b7cfd08d27a245ac9c4aa (diff)
downloadports-8b030ab1e4c19162fe2172391844d246e0ad0ccf.tar.gz
ports-8b030ab1e4c19162fe2172391844d246e0ad0ccf.zip
MFH: r472245
security/openssl: Actually add patch file Security: c82ecac5-6e3f-11e8-8777-b499baebfeaf Approved by: ports-secteam (miwi)
Notes
Notes: svn path=/branches/2018Q2/; revision=472254
-rw-r--r--security/openssl/Makefile2
-rw-r--r--security/openssl/files/patch-CVE-2018-073239
2 files changed, 40 insertions, 1 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index a9a9cd1521db..98e074931c56 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openssl
PORTVERSION= 1.0.2o
-PORTREVISION= 2
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/source/ \
diff --git a/security/openssl/files/patch-CVE-2018-0732 b/security/openssl/files/patch-CVE-2018-0732
new file mode 100644
index 000000000000..f6ef0008152a
--- /dev/null
+++ b/security/openssl/files/patch-CVE-2018-0732
@@ -0,0 +1,39 @@
+From 3984ef0b72831da8b3ece4745cac4f8575b19098 Mon Sep 17 00:00:00 2001
+From: Guido Vranken <guidovranken@gmail.com>
+Date: Mon, 11 Jun 2018 19:38:54 +0200
+Subject: [PATCH] Reject excessively large primes in DH key generation.
+
+CVE-2018-0732
+
+Signed-off-by: Guido Vranken <guidovranken@gmail.com>
+
+(cherry picked from commit 91f7361f47b082ae61ffe1a7b17bb2adf213c7fe)
+
+Reviewed-by: Tim Hudson <tjh@openssl.org>
+Reviewed-by: Matt Caswell <matt@openssl.org>
+(Merged from https://github.com/openssl/openssl/pull/6457)
+---
+ crypto/dh/dh_key.c | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/crypto/dh/dh_key.c b/crypto/dh/dh_key.c
+index 387558f1467..f235e0d682b 100644
+--- crypto/dh/dh_key.c.orig
++++ crypto/dh/dh_key.c
+@@ -130,10 +130,15 @@ static int generate_key(DH *dh)
+ int ok = 0;
+ int generate_new_key = 0;
+ unsigned l;
+- BN_CTX *ctx;
++ BN_CTX *ctx = NULL;
+ BN_MONT_CTX *mont = NULL;
+ BIGNUM *pub_key = NULL, *priv_key = NULL;
+
++ if (BN_num_bits(dh->p) > OPENSSL_DH_MAX_MODULUS_BITS) {
++ DHerr(DH_F_GENERATE_KEY, DH_R_MODULUS_TOO_LARGE);
++ return 0;
++ }
++
+ ctx = BN_CTX_new();
+ if (ctx == NULL)
+ goto err;