aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2018-06-23 09:19:21 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2018-06-23 09:19:21 +0000
commit95dd3f8171e68bb6b3def83a9599f9b2b7ef6c24 (patch)
treed36544329ae623c5de0b6ffc04d604c3bdeb6924
parentc555666aa7881885485bb85b8e7d477b7387ef3d (diff)
downloadports-95dd3f8171e68bb6b3def83a9599f9b2b7ef6c24.tar.gz
ports-95dd3f8171e68bb6b3def83a9599f9b2b7ef6c24.zip
MFH: r468537 r470823 r473096
* Review port dependencies based on composer.json files included in the source - Add hash as a required dependency [1] - Move xml from optional to required - Add curl, gmp, opcache and sodium as optional dependencies: all of these default to off. sodium only works with php >= 7.2, but there is no mechanism for modifying options dependent on flavour settings at the moment. - Move mbstring from required to optional dependency: defaults to on * Sort lists of options * Remove references to the redundant 'OPTIONS_MULTI_DB_connect': this was a remnant from an earlier version of the port which allowed switching between the old 'mysql' and the current 'mysqli' modules. * Add an empty %%WWWDIR%%/tmp directory to the plist: this is referenced in the configuration defaults [2]. Make this writable by the www group. PR: 227803 Submitted by: marko.cupac@mimar.rs [1] Reported by: marko.cupac@mimar.rs [2] Update to 4.8.1 ChangeLog: https://www.phpmyadmin.net/files/4.8.1/ Security update to 4.8.2 ChangeLog: https://www.phpmyadmin.net/files/4.8.2/ Security: 17cb6ff3-7670-11e8-8854-6805ca0b3d42 Approved by: ports-secteam (miwi)
Notes
Notes: svn path=/branches/2018Q2/; revision=473119
-rw-r--r--databases/phpmyadmin/Makefile25
-rw-r--r--databases/phpmyadmin/distinfo6
-rw-r--r--databases/phpmyadmin/pkg-plist-chunk1
3 files changed, 23 insertions, 9 deletions
diff --git a/databases/phpmyadmin/Makefile b/databases/phpmyadmin/Makefile
index d09795625504..6d0b7c02d47a 100644
--- a/databases/phpmyadmin/Makefile
+++ b/databases/phpmyadmin/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= phpMyAdmin
-DISTVERSION= 4.8.0.1
+DISTVERSION= 4.8.2
CATEGORIES= databases www
MASTER_SITES= https://files.phpmyadmin.net/${PORTNAME}/${DISTVERSION}/
DISTNAME= ${PORTNAME}-${DISTVERSION}-all-languages
@@ -19,21 +19,33 @@ CPE_PRODUCT= ${PORTNAME:tl}
NO_ARCH= yes
NO_BUILD= yes
.if !defined(WITHOUT_PHP_DEPENDS)
-USE_PHP= ctype session filter mbstring json spl mysqli
+
+# Note: composer.json files in the source list pcre as a required
+# extension, but pcre is compiled into PHP as standard on FreeBSD.
+# spl, libsodium are only required in the bundled vendor code. PMA
+# could, in principle, also use the PHP dbase extension, but it's not
+# available for PHP >= 7.0 and of only minority interest.
+
+USE_PHP= ctype filter hash json mysqli session spl xml
.endif
# Note: default settings will pull in X11 client support. If you don't
# want this, either turn off GD in the config dialog, or else turn off
# FONTCONFIG in the graphics/gd port options.
-OPTIONS_DEFINE= BZ2 GD OPENSSL PDF XML ZIP ZLIB
-OPTIONS_DEFAULT= BZ2 GD OPENSSL XML ZIP ZLIB
+OPTIONS_DEFINE= BZ2 CURL GD GMP MBSTRING OPCACHE OPENSSL PDF \
+ SODIUM ZIP ZLIB
+OPTIONS_DEFAULT= BZ2 GD MBSTRING OPENSSL ZIP ZLIB
BZ2_DESC= PHP bzip2 library support
+CURL_DESC= PHP curl support
GD_DESC= PHP GD library support (requires X11)
+GMP_DESC= PHP GMP library support
+MBSTRING_DESC= PHP Multi-byte String support
+OPCACHE_DESC= PHP Opcache support
OPENSSL_DESC= PHP OpenSSL support
PDF_DESC= PHP PDFlib support
-XML_DESC= PHP XML support (Export to OpenDoc)
+SODIUM_DESC= PHP libsodium support (only available for PHP >= 7.2)
ZIP_DESC= PHP Zip compression support
ZLIB_DESC= PHP ZLIB support
@@ -51,7 +63,7 @@ SUB_FILES+= pkg-message
.if !defined(WITHOUT_PHP_DEPENDS)
-.for opt in ${OPTIONS_DEFINE} ${OPTIONS_MULTI_DB_connect}
+.for opt in ${OPTIONS_DEFINE}
. if ${PORT_OPTIONS:M${opt}}
USE_PHP+= ${opt:tl}
. endif
@@ -82,5 +94,6 @@ do-install:
${INSTALL_DATA} "$$src" "$$dst" ; \
fi \
done
+ @${MKDIR} ${STAGEDIR}${WWWDIR}/tmp
.include <bsd.port.mk>
diff --git a/databases/phpmyadmin/distinfo b/databases/phpmyadmin/distinfo
index 47440294b380..a7c802098bf5 100644
--- a/databases/phpmyadmin/distinfo
+++ b/databases/phpmyadmin/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1524165110
-SHA256 (phpMyAdmin-4.8.0.1-all-languages.tar.xz) = 36b586d310374a062244adb919d847379aebf4c41ba0e5d11d6ed3186fa052d5
-SIZE (phpMyAdmin-4.8.0.1-all-languages.tar.xz) = 5926908
+TIMESTAMP = 1529708065
+SHA256 (phpMyAdmin-4.8.2-all-languages.tar.xz) = 2b42e75274ab078a0c2ca3aff767f45d1d81849f9f762a2ed0674819f061ba1d
+SIZE (phpMyAdmin-4.8.2-all-languages.tar.xz) = 5914400
diff --git a/databases/phpmyadmin/pkg-plist-chunk b/databases/phpmyadmin/pkg-plist-chunk
index ebe62554314e..45a66a99133a 100644
--- a/databases/phpmyadmin/pkg-plist-chunk
+++ b/databases/phpmyadmin/pkg-plist-chunk
@@ -1 +1,2 @@
@sample(,%%PMA_GRP%%,640) %%WWWDIR%%/config.inc.php.sample
+@dir(,%%PMA_GRP%%,770) %%WWWDIR%%/tmp