aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-02-20 13:52:00 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-02-20 13:52:00 +0000
commit9e35da574c6c0d489c5fae3a0fc1ea812fff713c (patch)
tree663a75c16d49d872667c563b3ab5537d6a82cc9b
parente61fd6cd3c0e76c4090888eadecdffdf0036d262 (diff)
downloadports-9e35da574c6c0d489c5fae3a0fc1ea812fff713c.tar.gz
ports-9e35da574c6c0d489c5fae3a0fc1ea812fff713c.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-ExtUtils-CBuilder/Makefile29
-rw-r--r--devel/p5-ExtUtils-CBuilder/distinfo2
-rw-r--r--devel/p5-ExtUtils-CBuilder/pkg-descr8
-rw-r--r--devel/p5-ExtUtils-CBuilder/pkg-plist15
5 files changed, 55 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e0b3b70145f4..04acf4fead9d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -682,6 +682,7 @@
SUBDIR += p5-Event
SUBDIR += p5-Exception-Class
SUBDIR += p5-Exporter-Lite
+ SUBDIR += p5-ExtUtils-CBuilder
SUBDIR += p5-ExtUtils-Depends
SUBDIR += p5-ExtUtils-ParseXS
SUBDIR += p5-ExtUtils-PkgConfig
diff --git a/devel/p5-ExtUtils-CBuilder/Makefile b/devel/p5-ExtUtils-CBuilder/Makefile
new file mode 100644
index 000000000000..328df6789991
--- /dev/null
+++ b/devel/p5-ExtUtils-CBuilder/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: ExtUtils::CBuilder
+# Date created: 20 Feb 2004
+# Whom: Mathieu Arnold <mat@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ExtUtils-CBuilder
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ExtUtils
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Compile and link C code for Perl modules
+
+PERL_CONFIGURE= yes
+
+MAN3= ExtUtils::CBuilder.3 ExtUtils::CBuilder::Platform::Windows.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} <= 500600
+BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-ExtUtils-CBuilder/distinfo b/devel/p5-ExtUtils-CBuilder/distinfo
new file mode 100644
index 000000000000..507acfb45ca5
--- /dev/null
+++ b/devel/p5-ExtUtils-CBuilder/distinfo
@@ -0,0 +1,2 @@
+MD5 (ExtUtils-CBuilder-0.01.tar.gz) = e318cf8a2f53a11091bb535283818dcc
+SIZE (ExtUtils-CBuilder-0.01.tar.gz) = 10248
diff --git a/devel/p5-ExtUtils-CBuilder/pkg-descr b/devel/p5-ExtUtils-CBuilder/pkg-descr
new file mode 100644
index 000000000000..3550b9001fe8
--- /dev/null
+++ b/devel/p5-ExtUtils-CBuilder/pkg-descr
@@ -0,0 +1,8 @@
+This module can build the C portions of Perl modules by invoking the
+appropriate compilers and linkers in a cross-platform manner. It was motivated
+by the Module::Build project, but may be useful for other purposes as well.
+However, it is not intended as a general cross-platform interface to all your C
+building needs. That would have been a much more ambitious goal!
+
+--
+mat
diff --git a/devel/p5-ExtUtils-CBuilder/pkg-plist b/devel/p5-ExtUtils-CBuilder/pkg-plist
new file mode 100644
index 000000000000..64a974c072b2
--- /dev/null
+++ b/devel/p5-ExtUtils-CBuilder/pkg-plist
@@ -0,0 +1,15 @@
+%%SITE_PERL%%/ExtUtils/CBuilder.pm
+%%SITE_PERL%%/ExtUtils/CBuilder/Base.pm
+%%SITE_PERL%%/ExtUtils/CBuilder/Platform/Unix.pm
+%%SITE_PERL%%/ExtUtils/CBuilder/Platform/VMS.pm
+%%SITE_PERL%%/ExtUtils/CBuilder/Platform/Windows.pm
+%%SITE_PERL%%/ExtUtils/CBuilder/Platform/aix.pm
+%%SITE_PERL%%/ExtUtils/CBuilder/Platform/cygwin.pm
+%%SITE_PERL%%/ExtUtils/CBuilder/Platform/darwin.pm
+%%SITE_PERL%%/ExtUtils/CBuilder/Platform/os2.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils/CBuilder/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils/CBuilder
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils 2>/dev/null || true
+@dirrm %%SITE_PERL%%/ExtUtils/CBuilder/Platform
+@dirrm %%SITE_PERL%%/ExtUtils/CBuilder
+@unexec rmdir %D/%%SITE_PERL%%/ExtUtils 2>/dev/null || true