aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2018-06-12 14:18:39 +0000
committerBernard Spil <brnrd@FreeBSD.org>2018-06-12 14:18:39 +0000
commitc85aa609e102d5729345afd7dd4318c16ffc0592 (patch)
tree0d31940f2721379a43fe3c60a89e4cef51ce72d7
parent8b030ab1e4c19162fe2172391844d246e0ad0ccf (diff)
downloadports-c85aa609e102d5729345afd7dd4318c16ffc0592.tar.gz
ports-c85aa609e102d5729345afd7dd4318c16ffc0592.zip
MFH: r472247
security/openssl-devel: Security update - Upstream update for CVE-2018-0732 Security: c82ecac5-6e3f-11e8-8777-b499baebfeaf Approved by: ports-secteam (miwi)
Notes
Notes: svn path=/branches/2018Q2/; revision=472255
-rw-r--r--security/openssl-devel/Makefile4
-rw-r--r--security/openssl-devel/files/patch-CVE-2018-073239
2 files changed, 41 insertions, 2 deletions
diff --git a/security/openssl-devel/Makefile b/security/openssl-devel/Makefile
index ce93f5133fdc..9dec9c2f7ef8 100644
--- a/security/openssl-devel/Makefile
+++ b/security/openssl-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openssl
PORTVERSION= 1.1.0h
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security devel
MASTER_SITES= https://www.openssl.org/source/ \
ftp://ftp.cert.dfn.de/pub/tools/net/openssl/source/
@@ -23,7 +23,7 @@ HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= config
CONFIGURE_ENV= PERL="${PERL}"
CONFIGURE_ARGS= --openssldir=${OPENSSLDIR} \
- --prefix=${PREFIX}
+ --prefix=${PREFIX} -v
OPTIONS_GROUP= CIPHERS HASHES OPTIMIZE PROTOCOLS
OPTIONS_GROUP_CIPHERS= IDEA JPAKE RC2 RC4 RC5
diff --git a/security/openssl-devel/files/patch-CVE-2018-0732 b/security/openssl-devel/files/patch-CVE-2018-0732
new file mode 100644
index 000000000000..ccc444c8bf5c
--- /dev/null
+++ b/security/openssl-devel/files/patch-CVE-2018-0732
@@ -0,0 +1,39 @@
+From ea7abeeabf92b7aca160bdd0208636d4da69f4f4 Mon Sep 17 00:00:00 2001
+From: Guido Vranken <guidovranken@gmail.com>
+Date: Mon, 11 Jun 2018 19:38:54 +0200
+Subject: [PATCH] Reject excessively large primes in DH key generation.
+
+CVE-2018-0732
+
+Signed-off-by: Guido Vranken <guidovranken@gmail.com>
+
+(cherry picked from commit 91f7361f47b082ae61ffe1a7b17bb2adf213c7fe)
+
+Reviewed-by: Tim Hudson <tjh@openssl.org>
+Reviewed-by: Matt Caswell <matt@openssl.org>
+(Merged from https://github.com/openssl/openssl/pull/6457)
+---
+ crypto/dh/dh_key.c | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/crypto/dh/dh_key.c b/crypto/dh/dh_key.c
+index fce9ff47f36..58003d70878 100644
+--- crypto/dh/dh_key.c.orig
++++ crypto/dh/dh_key.c
+@@ -78,10 +78,15 @@ static int generate_key(DH *dh)
+ int ok = 0;
+ int generate_new_key = 0;
+ unsigned l;
+- BN_CTX *ctx;
++ BN_CTX *ctx = NULL;
+ BN_MONT_CTX *mont = NULL;
+ BIGNUM *pub_key = NULL, *priv_key = NULL;
+
++ if (BN_num_bits(dh->p) > OPENSSL_DH_MAX_MODULUS_BITS) {
++ DHerr(DH_F_GENERATE_KEY, DH_R_MODULUS_TOO_LARGE);
++ return 0;
++ }
++
+ ctx = BN_CTX_new();
+ if (ctx == NULL)
+ goto err;