aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-02 14:44:50 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-02 14:44:50 +0000
commit06613f44814ccfb65a102dc8e1907be054c81a5e (patch)
tree980cc23a759774a0b5556a8f06591ba0a26e1425
parentb39095cedbce5aa16b893bbeb51f7402ab9241d5 (diff)
downloadports-06613f44814ccfb65a102dc8e1907be054c81a5e.tar.gz
ports-06613f44814ccfb65a102dc8e1907be054c81a5e.zip
Notes
-rw-r--r--lang/ofc/Makefile21
1 files changed, 8 insertions, 13 deletions
diff --git a/lang/ofc/Makefile b/lang/ofc/Makefile
index 16787e2664a7..405e5b4db3fd 100644
--- a/lang/ofc/Makefile
+++ b/lang/ofc/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: ofc
-# Date created: 06/21/2006
-# Whom: vanilla
-#
+# Created by: vanilla
# $FreeBSD$
-#
PORTNAME= ofc
PORTVERSION= 0.8.1
@@ -27,29 +23,28 @@ USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15 ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-OPTIONS= GDBM "Add gdbm support" off \
- GMP "Add gmp support" off
+OPTIONS_DEFINE= GDBM GMP
-.if defined (WITH_GDBM)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGDBM}
LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
.endif
-.if defined (WITH_GMP)
+.if ${PORT_OPTIONS:MGMP}
LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
.endif
-.include <bsd.port.pre.mk>
-
.if ${OSVERSION} >= 900000
# needs libobjc
GCCSUFFIX=42
CC= gcc${GCCSUFFIX}
CXX= g++${GCCSUFFIX}
OFC_GCC_PORT?= lang/gcc${GCCSUFFIX}
-TARGLIB!= (cd ${PORTSDIR}/${OFC_GCC_PORT} && make -V TARGLIB)
+TARGLIB!= ${MAKE} -C ${PORTSDIR}/${OFC_GCC_PORT} -V TARGLIB
LDFLAGS+= -L${TARGLIB}
BUILD_DEPENDS+= ${TARGLIB}/libobjc.so:${PORTSDIR}/${OFC_GCC_PORT}
RUN_DEPENDS+= ${TARGLIB}/libobjc.so:${PORTSDIR}/${OFC_GCC_PORT}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>