aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-10 03:32:30 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-10 03:32:30 +0000
commit1a9bd7debaac0d7f2f44673b312d619bb1a36844 (patch)
treeaf8d64edf7dccb98deb7624079825e503130b71b
parent513231299134011ff880262948d69b860e9b0273 (diff)
downloadports-1a9bd7debaac0d7f2f44673b312d619bb1a36844.tar.gz
ports-1a9bd7debaac0d7f2f44673b312d619bb1a36844.zip
Notes
-rw-r--r--devel/automake14/Makefile8
-rw-r--r--devel/p5-AnyEvent-DBI-Abstract/Makefile9
-rw-r--r--devel/p5-CPS/Makefile3
-rw-r--r--devel/p5-Capture-Tiny/Makefile3
-rw-r--r--devel/p5-Data-Throttler/Makefile3
-rw-r--r--devel/p5-Devel-CheckOS/Makefile3
-rw-r--r--devel/p5-Devel-Size-Report/Makefile9
-rw-r--r--devel/p5-File-DirSync/Makefile9
-rw-r--r--devel/p5-File-Spec-Native/Makefile8
-rw-r--r--devel/p5-IO-Handle-Util/Makefile8
-rw-r--r--devel/p5-Module-Loaded/Makefile9
-rw-r--r--devel/p5-Object-Array/Makefile9
-rw-r--r--devel/p5-POSIX-strptime/Makefile9
-rw-r--r--devel/p5-SVN-Hooks/Makefile3
-rw-r--r--devel/p5-SVN-Log/Makefile3
-rw-r--r--devel/p5-SVN-S4/Makefile3
-rw-r--r--devel/p5-Sys-MemInfo/Makefile9
-rw-r--r--devel/p5-Test-Module-Used/Makefile9
-rw-r--r--devel/p5-autobox/Makefile3
19 files changed, 46 insertions, 74 deletions
diff --git a/devel/automake14/Makefile b/devel/automake14/Makefile
index 15c2f0bfe228..0bc009897e0f 100644
--- a/devel/automake14/Makefile
+++ b/devel/automake14/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: automake
-# Date created: 15 March 1997
-# Whom: FUJIMOTO Kensaku <fujimoto@oscar.elec.waseda.ac.jp>
-#
+# Created by: FUJIMOTO Kensaku <fujimoto@oscar.elec.waseda.ac.jp>
# $FreeBSD$
-#
PORTNAME= automake
PORTVERSION= 1.4.6
@@ -26,7 +22,7 @@ USE_AUTOTOOLS= autoconf:env
BUILD_VERSION= 1.4
PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
LATEST_LINK= automake14
-USE_PERL5= yes
+USES= perl5
GNU_CONFIGURE= yes
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS= --program-suffix=-${BUILD_VERSION}
diff --git a/devel/p5-AnyEvent-DBI-Abstract/Makefile b/devel/p5-AnyEvent-DBI-Abstract/Makefile
index e51aad2cf201..7fa159c626db 100644
--- a/devel/p5-AnyEvent-DBI-Abstract/Makefile
+++ b/devel/p5-AnyEvent-DBI-Abstract/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-AnyEvent-DBI-Abstract
-# Date created: 19 Mar 2010
-# Whom: Denis Pokataev <catone@cpan.org>
-#
+# Created by: Denis Pokataev <catone@cpan.org>
# $FreeBSD$
-#
PORTNAME= AnyEvent-DBI-Abstract
PORTVERSION= 0.01
@@ -19,7 +15,8 @@ RUN_DEPENDS= p5-AnyEvent-DBI>=0:${PORTSDIR}/devel/p5-AnyEvent-DBI \
p5-parent>=0:${PORTSDIR}/devel/p5-parent
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= AnyEvent::DBI::Abstract.3
diff --git a/devel/p5-CPS/Makefile b/devel/p5-CPS/Makefile
index 5971c6a1f686..dd796348f54e 100644
--- a/devel/p5-CPS/Makefile
+++ b/devel/p5-CPS/Makefile
@@ -21,7 +21,8 @@ TEST_DEPENDS= p5-Test-Identity>0:${PORTSDIR}/devel/p5-Test-Identity \
p5-Test-Refcount>0:${PORTSDIR}/devel/p5-Test-Refcount \
p5-Test-Fatal>0:${PORTSDIR}/devel/p5-Test-Fatal
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= CPS.3 \
CPS::Functional.3 \
diff --git a/devel/p5-Capture-Tiny/Makefile b/devel/p5-Capture-Tiny/Makefile
index 28c89f2c00e9..011731f5bbe6 100644
--- a/devel/p5-Capture-Tiny/Makefile
+++ b/devel/p5-Capture-Tiny/Makefile
@@ -13,7 +13,8 @@ COMMENT= Capture STDOUT and STDERR from Perl, XS, or external programs
LICENSE= AL2
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Capture::Tiny.3
diff --git a/devel/p5-Data-Throttler/Makefile b/devel/p5-Data-Throttler/Makefile
index 30c071ec2bb4..26fb0ac59b55 100644
--- a/devel/p5-Data-Throttler/Makefile
+++ b/devel/p5-Data-Throttler/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-Log-Log4perl>=1:${PORTSDIR}/devel/p5-Log-Log4perl \
p5-YAML>=0.62:${PORTSDIR}/textproc/p5-YAML
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Data::Throttler.3
diff --git a/devel/p5-Devel-CheckOS/Makefile b/devel/p5-Devel-CheckOS/Makefile
index c13b4d8c77f2..d26e62df5a8e 100644
--- a/devel/p5-Devel-CheckOS/Makefile
+++ b/devel/p5-Devel-CheckOS/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-Data-Compare>=1.2100:${PORTSDIR}/devel/p5-Data-Compare \
p5-File-Find-Rule>=0.28:${PORTSDIR}/devel/p5-File-Find-Rule
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= use-devel-assertos.1
MAN3= Devel::AssertOS.3 \
diff --git a/devel/p5-Devel-Size-Report/Makefile b/devel/p5-Devel-Size-Report/Makefile
index 8ce1e61404a2..94841e0cd16d 100644
--- a/devel/p5-Devel-Size-Report/Makefile
+++ b/devel/p5-Devel-Size-Report/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Devel-Size-Report
-# Date created: Wed 04 Nov 2009
-# Whom: Alexey V. Degtyarev
-#
+# Created by: Alexey V. Degtyarev
# $FreeBSD$
-#
PORTNAME= Devel-Size-Report
PORTVERSION= 0.13
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-Array-RefElem>=1.00:${PORTSDIR}/misc/p5-Array-RefElem \
p5-Devel-Size>=0.69:${PORTSDIR}/devel/p5-Devel-Size
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Devel::Size::Report.3
diff --git a/devel/p5-File-DirSync/Makefile b/devel/p5-File-DirSync/Makefile
index 61c57f247c72..43f55d1acc67 100644
--- a/devel/p5-File-DirSync/Makefile
+++ b/devel/p5-File-DirSync/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: File::DirSync
-# Date created: 31 Dec 2001
-# Whom: Seamus Venasse <svenasse@polaris.ca>
-#
+# Created by: Seamus Venasse <svenasse@polaris.ca>
# $FreeBSD$
-#
PORTNAME= File-DirSync
PORTVERSION= 1.22
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= mhjacks@swbell.net
COMMENT= Perl5 module for synchronizing two directories rapidly
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= dirsync.1
MAN3= File::DirSync.3
diff --git a/devel/p5-File-Spec-Native/Makefile b/devel/p5-File-Spec-Native/Makefile
index 42f5efdbf2e8..13f1d90d6a8d 100644
--- a/devel/p5-File-Spec-Native/Makefile
+++ b/devel/p5-File-Spec-Native/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: File::Spec::Native
-# Date created: 27 May 2012
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= File-Spec-Native
PORTVERSION= 1.003
@@ -14,7 +9,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension for native OS implementation of File::Spec
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= File::Spec::Native.3
diff --git a/devel/p5-IO-Handle-Util/Makefile b/devel/p5-IO-Handle-Util/Makefile
index ed49bc2621f0..68559e4f3283 100644
--- a/devel/p5-IO-Handle-Util/Makefile
+++ b/devel/p5-IO-Handle-Util/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: IO::Handle::Util
-# Date created: 16 Apr 2010
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= IO-Handle-Util
PORTVERSION= 0.01
@@ -21,7 +16,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= IO::Handle::Iterator.3 \
IO::Handle::Prototype.3 \
diff --git a/devel/p5-Module-Loaded/Makefile b/devel/p5-Module-Loaded/Makefile
index 9242eaf5b955..b66e3b2c88e5 100644
--- a/devel/p5-Module-Loaded/Makefile
+++ b/devel/p5-Module-Loaded/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Module-Loaded
-# Date created: 31 May 2006
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Module-Loaded
PORTVERSION= 0.08
@@ -16,6 +12,7 @@ COMMENT= Mark modules as loaded or unloaded
MAN3= Module::Loaded.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/devel/p5-Object-Array/Makefile b/devel/p5-Object-Array/Makefile
index 77418fa91050..850d3eece58f 100644
--- a/devel/p5-Object-Array/Makefile
+++ b/devel/p5-Object-Array/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Object-Array
-# Date created: 2006-08-30
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Object-Array
PORTVERSION= 0.060
@@ -20,7 +16,8 @@ BUILD_DEPENDS= p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
p5-Sub-Install>=0:${PORTSDIR}/devel/p5-Sub-Install
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Object::Array.3 Object::Array::Plugin::Builtins.3 \
Object::Array::Plugin::ListMoreUtils.3
diff --git a/devel/p5-POSIX-strptime/Makefile b/devel/p5-POSIX-strptime/Makefile
index b0cec9ad01f4..eae46c762ce5 100644
--- a/devel/p5-POSIX-strptime/Makefile
+++ b/devel/p5-POSIX-strptime/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-POSIX-strptime
-# Date created: 3 January 2007
-# Whom: Douglas Thrift <douglas@douglasthrift.net>
-#
+# Created by: Douglas Thrift <douglas@douglasthrift.net>
# $FreeBSD$
-#
PORTNAME= POSIX-strptime
PORTVERSION= 0.10
@@ -17,7 +13,8 @@ COMMENT= Perl interface to strptime(3)
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POSIX::strptime.3
diff --git a/devel/p5-SVN-Hooks/Makefile b/devel/p5-SVN-Hooks/Makefile
index 2f67c5d65084..006d9c203a9e 100644
--- a/devel/p5-SVN-Hooks/Makefile
+++ b/devel/p5-SVN-Hooks/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-Data-Util>=0:${PORTSDIR}/devel/p5-Data-Util \
subversion>=1.4.0:${PORTSDIR}/devel/subversion
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SVN::Hooks.3 \
SVN::Hooks::AllowLogChange.3 \
diff --git a/devel/p5-SVN-Log/Makefile b/devel/p5-SVN-Log/Makefile
index 0aa158d1aae9..61169434fc66 100644
--- a/devel/p5-SVN-Log/Makefile
+++ b/devel/p5-SVN-Log/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-subversion>=0:${PORTSDIR}/devel/p5-subversion \
p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= SVN::Log.3
diff --git a/devel/p5-SVN-S4/Makefile b/devel/p5-SVN-S4/Makefile
index 44a26b5341cc..1156d305a93a 100644
--- a/devel/p5-SVN-S4/Makefile
+++ b/devel/p5-SVN-S4/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= p5-Config-Tiny>=0:${PORTSDIR}/devel/p5-Config-Tiny \
p5-IO-AIO>=0:${PORTSDIR}/devel/p5-IO-AIO \
p5-subversion>=0:${PORTSDIR}/devel/p5-subversion
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
INSTALL_TARGET= pure_install
MAN1= s4.1
diff --git a/devel/p5-Sys-MemInfo/Makefile b/devel/p5-Sys-MemInfo/Makefile
index 77d57569b543..9587a63770fc 100644
--- a/devel/p5-Sys-MemInfo/Makefile
+++ b/devel/p5-Sys-MemInfo/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Sys-MemInfo
-# Date created: 25 July 2008
-# Whom: Terry Sposato <terry@sucked-in.com>
-#
+# Created by: Terry Sposato <terry@sucked-in.com>
# $FreeBSD$
-#
PORTNAME= Sys-MemInfo
PORTVERSION= 0.91
@@ -16,7 +12,8 @@ COMMENT= Sys::MemInfo - Perl extension for getting Memory information
WRKSRC= ${WRKDIR}/${PORTNAME}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Sys::MemInfo.3
diff --git a/devel/p5-Test-Module-Used/Makefile b/devel/p5-Test-Module-Used/Makefile
index 639fca4630a8..e01ba389491b 100644
--- a/devel/p5-Test-Module-Used/Makefile
+++ b/devel/p5-Test-Module-Used/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Test-Module-Used
-# Date created: 2010-01-14
-# Whom: Takuya Tsuchida <tsucchi@cpan.org>
-#
+# Created by: Takuya Tsuchida <tsucchi@cpan.org>
# $FreeBSD$
-#
PORTNAME= Test-Module-Used
PORTVERSION= 0.2.3
@@ -23,7 +19,8 @@ RUN_DEPENDS= p5-CPAN-Meta>=2.102400:${PORTSDIR}/devel/p5-CPAN-Meta \
p5-version>=0.77:${PORTSDIR}/devel/p5-version
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Test::Module::Used.3
.include <bsd.port.mk>
diff --git a/devel/p5-autobox/Makefile b/devel/p5-autobox/Makefile
index 09a02509fec0..cc5c15108d5c 100644
--- a/devel/p5-autobox/Makefile
+++ b/devel/p5-autobox/Makefile
@@ -14,7 +14,8 @@ COMMENT= Call methods on native Perl types
BUILD_DEPENDS= p5-Scope-Guard>=0.20:${PORTSDIR}/devel/p5-Scope-Guard
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= autobox.3