aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2018-09-18 15:10:04 +0000
committerThomas Zander <riggs@FreeBSD.org>2018-09-18 15:10:04 +0000
commit32d7b113e64ef4170986eade5579416e2ec13073 (patch)
tree677cd4464e6fbdb960174b263cf6a9ad04af6a14
parent4aa64770260aabba30139ace6d9b201d340511ee (diff)
downloadports-32d7b113e64ef4170986eade5579416e2ec13073.tar.gz
ports-32d7b113e64ef4170986eade5579416e2ec13073.zip
MFH: r480029
Fix runtime error: remove -march=native as optimisation target Details: The upstream Makefile contains -march=native as optimisation which leads to unconditional use of AVX instructions if built on a machine that has AVX support. Subsequently this causes SIGILL on processors without AVX, including latest-generation Atom descendants. PR: 225922 Reported by: arthur@qeng-ho.org Approved by: hsw@bitmark.com (maintainer, implicit) Approved by: ports-secteam (riggs)
Notes
Notes: svn path=/branches/2018Q3/; revision=480031
-rw-r--r--security/libargon2/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/security/libargon2/Makefile b/security/libargon2/Makefile
index 4ddde7fbedb2..4541ca180657 100644
--- a/security/libargon2/Makefile
+++ b/security/libargon2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libargon2
PORTVERSION= 20171227
+PORTREVISION= 1
CATEGORIES= security devel
MAINTAINER= hsw@bitmark.com
@@ -20,7 +21,8 @@ GH_PROJECT= phc-winner-argon2
MAKE_JOBS_UNSAFE= yes
LIBARGON2= libargon2.so.0
-MAKE_ARGS+= SO_LDFLAGS="-shared -Wl,-soname=${LIBARGON2}"
+MAKE_ARGS+= SO_LDFLAGS="-shared -Wl,-soname=${LIBARGON2}" \
+ OPTTARGET="generic"
# remove multiarch as this is only for Linux
SUBST= s/@HOST_MULTIARCH@//g;