aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2010-05-15 19:23:21 +0000
committerGabor Pali <pgj@FreeBSD.org>2010-05-15 19:23:21 +0000
commit36ac22a6a8ebe42a12406d0da3674213bea7d91e (patch)
tree1c46dc91439b12d1c723e3470639bbbe7180bd49
parent24ddc72704e708f39fb01f400903c2b7f2db6640 (diff)
downloadports-36ac22a6a8ebe42a12406d0da3674213bea7d91e.tar.gz
ports-36ac22a6a8ebe42a12406d0da3674213bea7d91e.zip
Notes
-rw-r--r--lang/ghc/bsd.hackage.mk1
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/hs-hs-bibutils/Makefile19
-rw-r--r--textproc/hs-hs-bibutils/distinfo3
-rw-r--r--textproc/hs-hs-bibutils/pkg-descr14
-rw-r--r--textproc/hs-hs-bibutils/pkg-plist14
6 files changed, 52 insertions, 0 deletions
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index c570672f486e..2b377c7ee04f 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -56,6 +56,7 @@ hint_port= devel/hs-hint
hoogle_port= devel/hs-hoogle # executable
hscolour_port= print/hs-hscolour # executable
hslogger_port= devel/hs-hslogger
+hs-bibutils_port= textproc/hs-hs-bibutils
HTTP_port= www/hs-HTTP
http-server_port= www/hs-http-server
json_port= converters/hs-json
diff --git a/textproc/Makefile b/textproc/Makefile
index 702349818c87..ca592992e7d8 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -223,6 +223,7 @@
SUBDIR += hs-feed
SUBDIR += hs-haxml
SUBDIR += hs-highlighting-kate-ghc
+ SUBDIR += hs-hs-bibutils
SUBDIR += hs-polyparse-ghc
SUBDIR += hs-stringsearch
SUBDIR += hs-tagsoup
diff --git a/textproc/hs-hs-bibutils/Makefile b/textproc/hs-hs-bibutils/Makefile
new file mode 100644
index 000000000000..37fc4a7feb11
--- /dev/null
+++ b/textproc/hs-hs-bibutils/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: hs-hs-bibutils
+# Date created: May 14, 2010
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hs-bibutils
+PORTVERSION= 0.3
+CATEGORIES= textproc haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Haskell bindings to bibutils, the bibliography conversion utilities
+
+BUILD_DEPENDS= bibutils>=4.9:${PORTSDIR}/textproc/bibutils
+RUN_DEPENDS= bibutils>=4.9:${PORTSDIR}/textproc/bibutils
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/textproc/hs-hs-bibutils/distinfo b/textproc/hs-hs-bibutils/distinfo
new file mode 100644
index 000000000000..e62df7c21d83
--- /dev/null
+++ b/textproc/hs-hs-bibutils/distinfo
@@ -0,0 +1,3 @@
+MD5 (hs-bibutils-0.3.tar.gz) = 1c17fc71397cd91e7a4fa22eb47bff2e
+SHA256 (hs-bibutils-0.3.tar.gz) = 162e04d8c4187c2edc3b302554efbd3286ac08b9b8bf82844b59f9a954055e5e
+SIZE (hs-bibutils-0.3.tar.gz) = 404384
diff --git a/textproc/hs-hs-bibutils/pkg-descr b/textproc/hs-hs-bibutils/pkg-descr
new file mode 100644
index 000000000000..822de78e8f51
--- /dev/null
+++ b/textproc/hs-hs-bibutils/pkg-descr
@@ -0,0 +1,14 @@
+Haskell bindings to Chris Putnam's bibutils, a library that
+interconverts between various bibliography formats using a common
+MODS-format XML intermediate.
+
+hs-bibutils is available under the GNU GPL license. See the LICENSE file
+for details.
+
+For more details about bibutils, please check:
+<http://www.scripps.edu/~cdputnam/software/bibutils/>.
+
+The original API documentation is available here:
+<http://www.scripps.edu/~cdputnam/software/bibutils/library_specs.html>.
+
+WWW: http://code.haskell.org/hs-bibutils
diff --git a/textproc/hs-hs-bibutils/pkg-plist b/textproc/hs-hs-bibutils/pkg-plist
new file mode 100644
index 000000000000..b8d37e402516
--- /dev/null
+++ b/textproc/hs-hs-bibutils/pkg-plist
@@ -0,0 +1,14 @@
+@comment $FreeBSD$
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/Bibutils.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
+%%LIBDIR_REL%%/register.sh
+%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
+%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%LIBDIR_REL%%
+@exec /bin/sh %D/%%LIBDIR_REL%%/register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister %%PORTNAME%%-%%PORTVERSION%%
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old