aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2013-08-03 12:51:18 +0000
committerMathieu Arnold <mat@FreeBSD.org>2013-08-03 12:51:18 +0000
commit3d7ef3e463a5e930be63835c21dd2d345f88ea2d (patch)
tree8f1b59cfbbd73620cc4a151c90372baa46f5e797
parentd0f4eef0d7b9cfaab7394602c3c80cfe605a0d31 (diff)
downloadports-3d7ef3e463a5e930be63835c21dd2d345f88ea2d.tar.gz
ports-3d7ef3e463a5e930be63835c21dd2d345f88ea2d.zip
Notes
-rw-r--r--audio/pacpl/Makefile3
-rw-r--r--graphics/p5-PGPLOT/Makefile2
-rw-r--r--lang/parrot/Makefile3
-rw-r--r--lang/rakudo/Makefile4
-rw-r--r--net/p5-S3/Makefile3
-rw-r--r--textproc/btparse/Makefile3
-rw-r--r--textproc/p5-SGMLSpm/Makefile4
7 files changed, 11 insertions, 11 deletions
diff --git a/audio/pacpl/Makefile b/audio/pacpl/Makefile
index cc2ae7065176..a28c2d3b4403 100644
--- a/audio/pacpl/Makefile
+++ b/audio/pacpl/Makefile
@@ -10,8 +10,7 @@ MASTER_SITES= SF
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl Audio Converter
-USES= shebangfix
-USE_PERL5= yes
+USES= shebangfix perl5
ONLY_FOR_ARCHS= i386 amd64
NO_BUILD= yes
diff --git a/graphics/p5-PGPLOT/Makefile b/graphics/p5-PGPLOT/Makefile
index 31016e4697b2..df28082daffa 100644
--- a/graphics/p5-PGPLOT/Makefile
+++ b/graphics/p5-PGPLOT/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= pgplot.5:${PORTSDIR}/graphics/pgplot
INSTALL_TARGET= pure_install
SCRIPTS_ENV= PERL=${PERL}
USE_FORTRAN= yes
-USE_PERL5= yes
+USES= perl5
MAN3= PGPLOT.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VER}
diff --git a/lang/parrot/Makefile b/lang/parrot/Makefile
index f930409eadf1..1d5ad80c25a0 100644
--- a/lang/parrot/Makefile
+++ b/lang/parrot/Makefile
@@ -35,8 +35,7 @@ MAKE_JOBS_UNSAFE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
-USE_PERL5= yes
-USES= bison
+USES= bison perl5
MAN1= ops2c.1 \
parrot.1 \
diff --git a/lang/rakudo/Makefile b/lang/rakudo/Makefile
index 2f64562efb5b..34ba7f16ef76 100644
--- a/lang/rakudo/Makefile
+++ b/lang/rakudo/Makefile
@@ -35,7 +35,8 @@ CONFIGURE_PARROT_ARGS= --cc=${CC} --cxx=${CXX} --ld=${CC} --ccflags="${CFLAGS}"
CONFIGURE_ARGS= --with-parrot=${PREFIX}/bin/parrot \
--with-nqp=${PREFIX}/bin/nqp
-USES= bison
+USES= bison perl5
+USE_PERL5= build
.include <bsd.port.pre.mk>
@@ -43,7 +44,6 @@ USES= bison
BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
-USE_PERL5_BUILD= yes
USE_GMAKE= yes
MAN1= perl6.1 rakudo.1
diff --git a/net/p5-S3/Makefile b/net/p5-S3/Makefile
index 6092c2ff3980..1a2a565d6923 100644
--- a/net/p5-S3/Makefile
+++ b/net/p5-S3/Makefile
@@ -17,7 +17,8 @@ RUN_DEPENDS= p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
NO_BUILD= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
USE_ZIP= yes
WRKSRC= ${WRKDIR}/s3-example-libraries/perl
diff --git a/textproc/btparse/Makefile b/textproc/btparse/Makefile
index 5fe6618d26bf..64d60ec52076 100644
--- a/textproc/btparse/Makefile
+++ b/textproc/btparse/Makefile
@@ -12,7 +12,8 @@ COMMENT= C library for parsing and processing BibTeX data files
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_PERL5_BUILD=yes
+USES= perl5
+USE_PERL5= build
MAN3= btparse.3 bt_language.3 bt_input.3 bt_traversal.3 \
bt_postprocess.3 bt_macros.3 bt_split_names.3 \
diff --git a/textproc/p5-SGMLSpm/Makefile b/textproc/p5-SGMLSpm/Makefile
index 9f93c4d7be8c..a4b683d4ef94 100644
--- a/textproc/p5-SGMLSpm/Makefile
+++ b/textproc/p5-SGMLSpm/Makefile
@@ -13,8 +13,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}ii
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module for postprocessing the output from sgmls and nsgmls
-USE_PERL5_RUN= yes
-USES= shebangfix
+USE_PERL5= run
+USES= shebangfix perl5
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}