aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-10-01 00:17:59 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-10-01 00:17:59 +0000
commit7c956b7a8bdb7dc2ba58116a81fba87deaa793f4 (patch)
treeccd5423701c2fd49cf4ef76cc1ba3dce2c01e566
parent46cf3b569a7e680e21e42b01099227b4737c41c1 (diff)
downloadports-7c956b7a8bdb7dc2ba58116a81fba87deaa793f4.tar.gz
ports-7c956b7a8bdb7dc2ba58116a81fba87deaa793f4.zip
MFH: r480987
devel/googletest: unbreak on GCC architectures after r478607 In file included from ./include/gtest/gtest.h:59, from src/gtest_main.cc:31: ./include/gtest/internal/gtest-internal.h:657: error: expected ',' or '...' before '>' token ./include/gtest/internal/gtest-internal.h:657: error: parse error in template argument list ./include/gtest/internal/gtest-internal.h:657: error: default argument missing for parameter 7 of 'static bool testing::internal::TypeParameterizedTest<Fixture, TestSel, Types>::Register(const char*, const testing::internal::CodeLocation&, const char*, const char*, int, const std::vector<std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::basic_string<char, std::char_traits<char>, std::allocator<char> > > >&, Types)' In file included from src/gtest_main.cc:31: In file included from ./include/gtest/gtest.h:59: ./include/gtest/internal/gtest-internal.h:947:44: error: no member named 'declval' in namespace 'std' class Iterator = decltype(::std::declval<const C&>().begin()), ~~~~~~~^ ./include/gtest/internal/gtest-internal.h:947:52: error: expected expression class Iterator = decltype(::std::declval<const C&>().begin()), ^ ./include/gtest/internal/gtest-internal.h:948:35: error: no member named 'declval' in namespace 'std' class = decltype(::std::declval<const C&>().end()), ~~~~~~~^ ./include/gtest/internal/gtest-internal.h:948:43: error: expected expression class = decltype(::std::declval<const C&>().end()), ^ ./include/gtest/internal/gtest-internal.h:949:37: error: no member named 'declval' in namespace 'std' class = decltype(++::std::declval<Iterator&>()), ~~~~~~~^ ./include/gtest/internal/gtest-internal.h:949:45: error: 'Iterator' does not refer to a value class = decltype(++::std::declval<Iterator&>()), ^ ./include/gtest/internal/gtest-internal.h:947:17: note: declared here class Iterator = decltype(::std::declval<const C&>().begin()), ^ ./include/gtest/internal/gtest-internal.h:949:54: error: expected expression class = decltype(++::std::declval<Iterator&>()), ^ ./include/gtest/internal/gtest-internal.h:949:56: error: expected expression class = decltype(++::std::declval<Iterator&>()), ^ ./include/gtest/internal/gtest-internal.h:950:36: error: no member named 'declval' in namespace 'std' class = decltype(*::std::declval<Iterator>()), ~~~~~~~^ ./include/gtest/internal/gtest-internal.h:950:44: error: 'Iterator' does not refer to a value class = decltype(*::std::declval<Iterator>()), ^ ./include/gtest/internal/gtest-internal.h:947:17: note: declared here class Iterator = decltype(::std::declval<const C&>().begin()), ^ ./include/gtest/internal/gtest-internal.h:950:54: error: expected expression class = decltype(*::std::declval<Iterator>()), ^ PR: 231835 Submitted by: Piotr Kubaj (based on) Approved by: ports-secteam blanket
Notes
Notes: svn path=/branches/2018Q3/; revision=480988
-rw-r--r--devel/googletest/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/googletest/Makefile b/devel/googletest/Makefile
index 9cd722b8b103..3ccd8c21205a 100644
--- a/devel/googletest/Makefile
+++ b/devel/googletest/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USE_GITHUB= yes
GH_ACCOUNT= google
-USES= autoreconf libtool
+USES= autoreconf compiler:c++11-lib libtool
WRKSRC_SUBDIR= ${PORTNAME}
GNU_CONFIGURE= yes
# fused-src python tests are only useful for bundling. There's no point in