aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-09-09 18:30:10 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-09-09 18:30:10 +0000
commite9bd637dd02fcd96b91fb80ba311012435435f6b (patch)
tree1462b961ad61216f85817c7e4d143262dfbae524
parentb45c510091c3a7e41e33fdb7f7f019ef370b004d (diff)
downloadports-e9bd637dd02fcd96b91fb80ba311012435435f6b.tar.gz
ports-e9bd637dd02fcd96b91fb80ba311012435435f6b.zip
Notes
-rw-r--r--www/mod_access_identd/Makefile5
-rw-r--r--www/mod_access_referer/Makefile7
-rw-r--r--www/mod_auth_any/Makefile5
-rw-r--r--www/mod_auth_pgsql/Makefile9
-rw-r--r--www/mod_bf/Makefile5
-rw-r--r--www/mod_blowchunks/Makefile5
-rw-r--r--www/mod_cgi_debug/Makefile5
-rw-r--r--www/mod_color/Makefile5
-rw-r--r--www/mod_gzip/Makefile7
-rw-r--r--www/mod_gzip2/Makefile7
-rw-r--r--www/mod_hosts_access/Makefile5
-rw-r--r--www/mod_index_rss/Makefile5
-rw-r--r--www/mod_mp3/Makefile5
-rw-r--r--www/mod_put/Makefile6
-rw-r--r--www/mod_python/Makefile5
-rw-r--r--www/mod_python3/Makefile5
-rw-r--r--www/mod_roaming/Makefile7
-rw-r--r--www/mod_sed/Makefile5
-rw-r--r--www/mod_sequester/Makefile5
-rw-r--r--www/mod_snake/Makefile3
-rw-r--r--www/mod_ticket/Makefile5
21 files changed, 71 insertions, 45 deletions
diff --git a/www/mod_access_identd/Makefile b/www/mod_access_identd/Makefile
index 47fec0a8d0b0..8a8d90a78b45 100644
--- a/www/mod_access_identd/Makefile
+++ b/www/mod_access_identd/Makefile
@@ -12,11 +12,12 @@ MASTER_SITES= http://MeepZor.Com/packages/mod_access_identd/
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
WRKSRC= ${WRKDIR}/mod_access_identd
APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
do-build:
@cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c
diff --git a/www/mod_access_referer/Makefile b/www/mod_access_referer/Makefile
index 59064c7cc12a..4def9ccd7890 100644
--- a/www/mod_access_referer/Makefile
+++ b/www/mod_access_referer/Makefile
@@ -13,10 +13,11 @@ MASTER_SITE_SUBDIR= accessreferer
MAINTAINER= ports@freebsd.org
-BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
-APXS= ${LOCALBASE}/sbin/apxs
+APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
DOCS= HACKING LICENSE.txt ChangeLog README TODO mod_access_referer.html
diff --git a/www/mod_auth_any/Makefile b/www/mod_auth_any/Makefile
index b04a82f2b6f3..e1483c44343d 100644
--- a/www/mod_auth_any/Makefile
+++ b/www/mod_auth_any/Makefile
@@ -13,10 +13,11 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
do-build:
@cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c
diff --git a/www/mod_auth_pgsql/Makefile b/www/mod_auth_pgsql/Makefile
index 7c3f671a6863..1fbde23fdcd4 100644
--- a/www/mod_auth_pgsql/Makefile
+++ b/www/mod_auth_pgsql/Makefile
@@ -11,17 +11,18 @@ MASTER_SITES= http://www.giuseppetanzilli.it/mod_auth_pgsql/dist/
MAINTAINER= ports@freebsd.org
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/${AP_PORT}
-RUN_DEPENDS= ${LOCALBASE}/sbin/${AP_TARGET}:${PORTSDIR}/www/${AP_PORT}
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${LOCALBASE}/sbin/${AP_TARGET}:${APACHE_PORT}
LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/a//}
.include <bsd.port.pre.mk>
-APXS= ${LOCALBASE}/sbin/apxs
-
+APXS?= ${LOCALBASE}/sbin/apxs
AP_PORT?= apache13
+APACHE_PORT?= ${PORTSDIR}/www/${AP_PORT}
+
.if exists(${APXS})
APXS_WORKS!= ${APXS} -q TARGET 2>/dev/null || echo no
.endif
diff --git a/www/mod_bf/Makefile b/www/mod_bf/Makefile
index f4b65e5f4f6c..c7152c7412b5 100644
--- a/www/mod_bf/Makefile
+++ b/www/mod_bf/Makefile
@@ -13,10 +13,11 @@ MASTER_SITE_SUBDIR= modbf
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
do-build:
@cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c
diff --git a/www/mod_blowchunks/Makefile b/www/mod_blowchunks/Makefile
index a4a81ba6f33e..aba5233d5c11 100644
--- a/www/mod_blowchunks/Makefile
+++ b/www/mod_blowchunks/Makefile
@@ -14,12 +14,13 @@ EXTRACT_SUFX= .c
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
NO_WRKSUBDIR= YES
APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
APXSFLAGS= -DTRUE=1 -DFALSE=0
.if !defined(WITHOUT_BLOWCHUNK_LOG)
APXSFLAGS+= -DLOG_BLOWCHUNK
diff --git a/www/mod_cgi_debug/Makefile b/www/mod_cgi_debug/Makefile
index 2a4f10c1cfbe..c5eb5eb3bff5 100644
--- a/www/mod_cgi_debug/Makefile
+++ b/www/mod_cgi_debug/Makefile
@@ -12,10 +12,11 @@ MASTER_SITES= http://software.tangent.org/download/
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
do-build:
@cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c
diff --git a/www/mod_color/Makefile b/www/mod_color/Makefile
index d17f0821eac6..20a468c40a1a 100644
--- a/www/mod_color/Makefile
+++ b/www/mod_color/Makefile
@@ -14,10 +14,11 @@ EXTRACT_SUFX= .l
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
NO_WRKSUBDIR= yes
do-extract:
diff --git a/www/mod_gzip/Makefile b/www/mod_gzip/Makefile
index cfc1aa7b34a7..56b388637945 100644
--- a/www/mod_gzip/Makefile
+++ b/www/mod_gzip/Makefile
@@ -14,8 +14,11 @@ EXTRACT_ONLY= ${DISTFILES:M*.gz}
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
+
+APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
.if !defined(NOPORTDOCS)
DISTFILES+= changes.txt commands.txt samples.txt
diff --git a/www/mod_gzip2/Makefile b/www/mod_gzip2/Makefile
index cfc1aa7b34a7..56b388637945 100644
--- a/www/mod_gzip2/Makefile
+++ b/www/mod_gzip2/Makefile
@@ -14,8 +14,11 @@ EXTRACT_ONLY= ${DISTFILES:M*.gz}
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
+
+APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
.if !defined(NOPORTDOCS)
DISTFILES+= changes.txt commands.txt samples.txt
diff --git a/www/mod_hosts_access/Makefile b/www/mod_hosts_access/Makefile
index 24295afdac17..34afa18731f6 100644
--- a/www/mod_hosts_access/Makefile
+++ b/www/mod_hosts_access/Makefile
@@ -13,10 +13,11 @@ MASTER_SITES= http://www.klomp.org/mod_hosts_access/
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
APXS_FLAGS?= -S LDFLAGS_SHLIB="-shared -lwrap"
do-build:
diff --git a/www/mod_index_rss/Makefile b/www/mod_index_rss/Makefile
index fe7332a6a772..453f76a5822c 100644
--- a/www/mod_index_rss/Makefile
+++ b/www/mod_index_rss/Makefile
@@ -14,10 +14,11 @@ MASTER_SITES= http://software.tangent.org/download/ \
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
do-build:
@cd ${WRKSRC} && ${APXS} -c mod_index_rss.c
diff --git a/www/mod_mp3/Makefile b/www/mod_mp3/Makefile
index 6b0297bd5c23..c3357e8c411f 100644
--- a/www/mod_mp3/Makefile
+++ b/www/mod_mp3/Makefile
@@ -14,13 +14,14 @@ MASTER_SITES= http://software.tangent.org/download/ \
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
HAS_CONFIGURE= yes
MAKE_ARGS+= APXS="${APXS}"
APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
DOCS= ChangeLog README TODO faq.html
do-install:
diff --git a/www/mod_put/Makefile b/www/mod_put/Makefile
index 31217ddb2d48..10d1c447572b 100644
--- a/www/mod_put/Makefile
+++ b/www/mod_put/Makefile
@@ -13,9 +13,11 @@ DISTFILES= mod_put.tar.gz
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
+APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
do-build:
diff --git a/www/mod_python/Makefile b/www/mod_python/Makefile
index 591db4ae4e58..dd217311cd59 100644
--- a/www/mod_python/Makefile
+++ b/www/mod_python/Makefile
@@ -15,8 +15,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
NO_PACKAGE= "Requires Python without threads support"
USE_PYTHON= yes
@@ -24,6 +24,7 @@ USE_PYTHON= yes
.include <bsd.port.pre.mk>
APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-apxs=${APXS}
diff --git a/www/mod_python3/Makefile b/www/mod_python3/Makefile
index 591db4ae4e58..dd217311cd59 100644
--- a/www/mod_python3/Makefile
+++ b/www/mod_python3/Makefile
@@ -15,8 +15,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
NO_PACKAGE= "Requires Python without threads support"
USE_PYTHON= yes
@@ -24,6 +24,7 @@ USE_PYTHON= yes
.include <bsd.port.pre.mk>
APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-apxs=${APXS}
diff --git a/www/mod_roaming/Makefile b/www/mod_roaming/Makefile
index 77d48d0dae30..aa7eebec1c6c 100644
--- a/www/mod_roaming/Makefile
+++ b/www/mod_roaming/Makefile
@@ -13,10 +13,11 @@ MASTER_SITES= http://www.klomp.org/mod_roaming/
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
-APXS= ${LOCALBASE}/sbin/apxs
+APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
DOCS= CHANGES INSTALL LICENSE README
diff --git a/www/mod_sed/Makefile b/www/mod_sed/Makefile
index e17f38a72acf..8ebe06c3c2aa 100644
--- a/www/mod_sed/Makefile
+++ b/www/mod_sed/Makefile
@@ -13,10 +13,11 @@ MASTER_SITES= http://www.myrddin.demon.co.uk/dist/
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
MAKE_ARGS= APXS=${APXS}
diff --git a/www/mod_sequester/Makefile b/www/mod_sequester/Makefile
index ffe026282e97..e8ac1e621555 100644
--- a/www/mod_sequester/Makefile
+++ b/www/mod_sequester/Makefile
@@ -12,11 +12,12 @@ MASTER_SITES= http://MeepZor.Com/packages/mod_sequester/
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
WRKSRC= ${WRKDIR}/mod_sequester
APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
do-build:
@cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c
diff --git a/www/mod_snake/Makefile b/www/mod_snake/Makefile
index 980af3b18def..302025271525 100644
--- a/www/mod_snake/Makefile
+++ b/www/mod_snake/Makefile
@@ -13,12 +13,13 @@ MASTER_SITE_SUBDIR= modsnake
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13 \
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT} \
${PYTHON_CMD}:${PYTHON_PORTSDIR}
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_BZIP2= yes
APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
USE_PYTHON= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-apxs="${APXS}"
diff --git a/www/mod_ticket/Makefile b/www/mod_ticket/Makefile
index dfe5e5d37a8c..1e1c3ee64562 100644
--- a/www/mod_ticket/Makefile
+++ b/www/mod_ticket/Makefile
@@ -14,10 +14,11 @@ EXTRACT_SUFX= .c
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
do-extract:
${MKDIR} ${WRKSRC}