aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2018-09-25 15:41:48 +0000
committerMark Felder <feld@FreeBSD.org>2018-09-25 15:41:48 +0000
commiteff261da934851df1ce4dbf7565071d75f948b4e (patch)
treef0b5e6dd71573cc114a5a0e34d09eafb9b51e425
parentf2fdc67b2385691ce0b4a065b09b7a157a64e858 (diff)
downloadports-eff261da934851df1ce4dbf7565071d75f948b4e.tar.gz
ports-eff261da934851df1ce4dbf7565071d75f948b4e.zip
MFH: r480668
www/varnish6: Add patch to fix output of varnishhist Obtained from: https://github.com/varnishcache/varnish-cache/issues/2780
Notes
Notes: svn path=/branches/2018Q3/; revision=480669
-rw-r--r--www/varnish6/Makefile2
-rw-r--r--www/varnish6/files/patch-bin_varnishhist_varnishhist.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/www/varnish6/Makefile b/www/varnish6/Makefile
index 5b531460b0b8..914fa7d5fea8 100644
--- a/www/varnish6/Makefile
+++ b/www/varnish6/Makefile
@@ -3,7 +3,7 @@
PORTNAME= varnish
PORTVERSION= 6.0.1
DISTVERSIONPREFIX= varnish-
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= www
PKGNAMESUFFIX= 6
diff --git a/www/varnish6/files/patch-bin_varnishhist_varnishhist.c b/www/varnish6/files/patch-bin_varnishhist_varnishhist.c
new file mode 100644
index 000000000000..5c708468cdf1
--- /dev/null
+++ b/www/varnish6/files/patch-bin_varnishhist_varnishhist.c
@@ -0,0 +1,11 @@
+--- bin/varnishhist/varnishhist.c.orig 2018-08-29 09:52:28 UTC
++++ bin/varnishhist/varnishhist.c
+@@ -299,7 +299,7 @@ accumulate(struct VSL_data *vsl, struct VSL_transactio
+ continue;
+
+ /* select bucket */
+- i = HIST_RES * lround(log(value) / log_ten);
++ i = lround(HIST_RES * log(value) / log_ten);
+ if (i < hist_low * HIST_RES)
+ i = hist_low * HIST_RES;
+ if (i >= hist_high * HIST_RES)