aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimur I. Bakeyev <timur@FreeBSD.org>2014-08-08 14:09:13 +0000
committerTimur I. Bakeyev <timur@FreeBSD.org>2014-08-08 14:09:13 +0000
commit05439fec22628a09ee6aa3591eba9acf6e645fcd (patch)
tree11b44031e6ac25010f71225542249a711fdabfae
parentea3e5032723ac98a9ae1f492df3c052b6755c57e (diff)
Notes
-rw-r--r--net/samba36/Makefile5
-rw-r--r--net/samba36/files/patch-source3__script__findsmb.in8
-rw-r--r--net/samba36/pkg-plist1
-rw-r--r--net/samba4/Makefile4
-rw-r--r--net/samba41/Makefile4
5 files changed, 10 insertions, 12 deletions
diff --git a/net/samba36/Makefile b/net/samba36/Makefile
index 54836f13e9fd..af463277b831 100644
--- a/net/samba36/Makefile
+++ b/net/samba36/Makefile
@@ -20,6 +20,8 @@ PATCH_STRIP= -p1
EXTRA_PATCHES= ${PATCHDIR}/sernet.patch
SAMBA_BASENAME= samba
+CPE_VENDOR= samba
+CPE_PRODUCT= samba
LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
@@ -30,7 +32,7 @@ AUTOHEADER_ARGS= ${IPATHS}
AUTOCONF_ARGS= ${IPATHS}
GNU_CONFIGURE= yes
-USES= gmake pkgconfig iconv
+USES= gmake pkgconfig iconv cpe
USE_AUTOTOOLS= autoconf autoheader
USE_LDCONFIG= ${SAMBA_LIBDIR}
# pkg-config is used to find talloc
@@ -483,6 +485,7 @@ pre-install:
.endif
post-install:
+ @${RM} -f ${STAGEDIR}/${PREFIX}/bin/findsmb
.for sect in 1 3 5 7 8
@${MKDIR} ${STAGEDIR}${MAN${sect}PREFIX}/man/man${sect}
. for man in ${SAMBA_MAN${sect}}
diff --git a/net/samba36/files/patch-source3__script__findsmb.in b/net/samba36/files/patch-source3__script__findsmb.in
deleted file mode 100644
index 2ef15a45bb90..000000000000
--- a/net/samba36/files/patch-source3__script__findsmb.in
+++ /dev/null
@@ -1,8 +0,0 @@
---- ./source3/script/findsmb.in.orig 2014-07-12 21:37:56.512194098 +0000
-+++ ./source3/script/findsmb.in 2014-07-12 21:38:19.976192656 +0000
-@@ -1,4 +1,4 @@
--#!@PERL@
-+#!%%PREFIX%%/bin/perl
- #
- # Prints info on all smb responding machines on a subnet.
- # This script needs to be run on a machine without nmbd running and be
diff --git a/net/samba36/pkg-plist b/net/samba36/pkg-plist
index a6ecf0802f12..c8d60808c946 100644
--- a/net/samba36/pkg-plist
+++ b/net/samba36/pkg-plist
@@ -1,6 +1,5 @@
etc/%%SAMBA_CONFIG%%.sample
bin/eventlogadm
-bin/findsmb
bin/make_smbpasswd
bin/net
bin/nmblookup
diff --git a/net/samba4/Makefile b/net/samba4/Makefile
index c4ca4938a430..db7345c93d55 100644
--- a/net/samba4/Makefile
+++ b/net/samba4/Makefile
@@ -24,6 +24,8 @@ SAMBA4_DISTNAME= ${SAMBA4_BASENAME}-${SAMBA4_VERSION:S|.p|pre|:S|.r|rc|:S|.t|tp|
WRKSRC?= ${WRKDIR}/${DISTNAME}
.if !defined(SAMBA4_SUBPORT)
+CPE_VENDOR= samba
+CPE_PRODUCT= samba
# Directories
VARDIR= ${DESTDIR}/var
SAMBA4_RUNDIR= ${VARDIR}/run/${SAMBA4_PORTNAME}
@@ -63,7 +65,7 @@ CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LDFLAGS="${PTHREAD_LIBS}"
USE_PYTHON= 2
-USES= shebangfix compiler perl5 pkgconfig iconv readline
+USES= shebangfix compiler perl5 pkgconfig iconv readline cpe
USE_PERL5= build
USE_LDCONFIG= ${SAMBA4_LIBDIR}
WAF_TOOL= buildtools/bin/waf
diff --git a/net/samba41/Makefile b/net/samba41/Makefile
index 82f3751ec99d..389d7db6d470 100644
--- a/net/samba41/Makefile
+++ b/net/samba41/Makefile
@@ -24,6 +24,8 @@ SAMBA4_DISTNAME= ${SAMBA4_BASENAME}-${SAMBA4_VERSION:S|.p|pre|:S|.r|rc|:S|.t|tp|
WRKSRC?= ${WRKDIR}/${DISTNAME}
.if !defined(SAMBA4_SUBPORT)
+CPE_VENDOR= samba
+CPE_PRODUCT= samba
# Directories
VARDIR= ${DESTDIR}/var
SAMBA4_RUNDIR= ${VARDIR}/run/${SAMBA4_PORTNAME}
@@ -63,7 +65,7 @@ CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LDFLAGS="${PTHREAD_LIBS}"
USE_PYTHON= 2
-USES= shebangfix compiler perl5 pkgconfig iconv readline
+USES= shebangfix compiler perl5 pkgconfig iconv readline cpe
USE_PERL5= build
USE_LDCONFIG= ${SAMBA4_LIBDIR}
WAF_TOOL= buildtools/bin/waf