aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2010-05-11 10:09:51 +0000
committerDima Panov <fluffy@FreeBSD.org>2010-05-11 10:09:51 +0000
commit0a0091d28781f493a9a8b9669f218a51d72706ec (patch)
tree2483d98c40609a374ff9e65ea9fdef0a4fbddb83
parentd068758a6797f495a85869ad42da22d1ecaa676f (diff)
Notes
-rw-r--r--Mk/bsd.qt.mk6
-rw-r--r--accessibility/qt4-accessible/Makefile1
-rw-r--r--devel/dbus-qt4/Makefile1
-rw-r--r--devel/qmake4/pkg-plist2
-rw-r--r--devel/qt4-assistant-adp/Makefile1
-rw-r--r--devel/qt4-assistant/Makefile1
-rw-r--r--devel/qt4-designer/Makefile1
-rw-r--r--devel/qt4-help-tools/Makefile1
-rw-r--r--devel/qt4-help/Makefile1
-rw-r--r--devel/qt4-libqtassistantclient/Makefile1
-rw-r--r--devel/qt4-linguist/Makefile1
-rw-r--r--devel/qt4-makeqpf/Makefile1
-rw-r--r--devel/qt4-qdbusviewer/Makefile7
-rw-r--r--devel/qt4-qvfb/Makefile1
-rw-r--r--devel/qt4-scripttools/Makefile1
-rw-r--r--devel/qt4-uic3/Makefile1
-rw-r--r--devel/qt4/Makefile5
-rw-r--r--devel/qt4/distinfo6
-rw-r--r--graphics/qt4-iconengines/Makefile1
-rw-r--r--graphics/qt4-imageformats/Makefile1
-rw-r--r--graphics/qt4-pixeltool/Makefile1
-rw-r--r--graphics/qt4-svg/Makefile1
-rw-r--r--misc/qt4-doc/pkg-plist67
-rw-r--r--misc/qt4-l10n/Makefile1
-rw-r--r--misc/qt4-qtconfig/Makefile1
-rw-r--r--misc/qt4-qtdemo/Makefile1
-rw-r--r--misc/qt4-qtdemo/pkg-plist11
-rw-r--r--multimedia/qt4-multimedia/Makefile1
-rw-r--r--multimedia/qt4-phonon-gst/Makefile3
-rw-r--r--multimedia/qt4-phonon/Makefile3
-rw-r--r--multimedia/qt4-phonon/pkg-plist1
-rw-r--r--www/qt4-webkit/Makefile1
-rw-r--r--x11-toolkits/qt4-gui/Makefile1
-rw-r--r--x11/qt4-inputmethods/Makefile1
-rw-r--r--x11/qt4-opengl/Makefile1
35 files changed, 93 insertions, 43 deletions
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index d00341ea373d..6715cc303a27 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -115,7 +115,7 @@ QTCGFLIBS?=
# QT4 version
# Don't forget to update ${PORTSDIR}/devel/qt4/files/patch-configure !
#
-QT4_VERSION?= 4.6.1
+QT4_VERSION?= 4.6.2
_QT_COMPONENTS_ALL= accessible assistant assistant-adp assistantclient \
clucene codecs-cn codecs-jp codecs-kr codecs-tw corelib \
@@ -210,14 +210,14 @@ opengl_DEPENDS= ${QT_LIBDIR}/libQtOpenGL.so
pixeltool_PORT= graphics/qt4-pixeltool
pixeltool_DEPENDS= ${QT_PREFIX}/bin/pixeltool
-.if defined(WITH_KDE_PHONON)
+.if !defined(WITH_QT_PHONON)
phonon_PORT= multimedia/phonon
.else
phonon_PORT= multimedia/qt4-phonon
.endif
phonon_DEPENDS= ${QT_LIBDIR}/libphonon.so
-.if defined(WITH_KDE_PHONON)
+.if !defined(WITH_QT_PHONON)
phonon-gst_PORT= multimedia/phonon-gstreamer
.else
phonon-gst_PORT= multimedia/qt4-phonon-gst
diff --git a/accessibility/qt4-accessible/Makefile b/accessibility/qt4-accessible/Makefile
index 84e4df1e995c..7f8009ebd053 100644
--- a/accessibility/qt4-accessible/Makefile
+++ b/accessibility/qt4-accessible/Makefile
@@ -8,7 +8,6 @@
PORTNAME= accessible
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= accessibility
PKGNAMEPREFIX= qt4-
diff --git a/devel/dbus-qt4/Makefile b/devel/dbus-qt4/Makefile
index 79fa3256f003..f5fb5df3341f 100644
--- a/devel/dbus-qt4/Makefile
+++ b/devel/dbus-qt4/Makefile
@@ -8,7 +8,6 @@
PORTNAME= dbus
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
diff --git a/devel/qmake4/pkg-plist b/devel/qmake4/pkg-plist
index 2d0f68521217..7a750191ac72 100644
--- a/devel/qmake4/pkg-plist
+++ b/devel/qmake4/pkg-plist
@@ -72,6 +72,8 @@ share/qt4/mkspecs/features/staticlib.prf
share/qt4/mkspecs/features/symbian/application_icon.prf
share/qt4/mkspecs/features/symbian/armcc_warnings.prf
share/qt4/mkspecs/features/symbian/data_caging_paths.prf
+share/qt4/mkspecs/features/symbian/def_files.prf
+share/qt4/mkspecs/features/symbian/def_files_disabled.prf
share/qt4/mkspecs/features/symbian/default_post.prf
share/qt4/mkspecs/features/symbian/default_pre.prf
share/qt4/mkspecs/features/symbian/epocallowdlldata.prf
diff --git a/devel/qt4-assistant-adp/Makefile b/devel/qt4-assistant-adp/Makefile
index 4b3282343308..f9fe3e889a97 100644
--- a/devel/qt4-assistant-adp/Makefile
+++ b/devel/qt4-assistant-adp/Makefile
@@ -7,7 +7,6 @@
PORTNAME= assistant
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
PKGNAMESUFFIX= -adp
diff --git a/devel/qt4-assistant/Makefile b/devel/qt4-assistant/Makefile
index dc79111f095e..15a108183fb0 100644
--- a/devel/qt4-assistant/Makefile
+++ b/devel/qt4-assistant/Makefile
@@ -8,7 +8,6 @@
PORTNAME= assistant
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4-designer/Makefile b/devel/qt4-designer/Makefile
index 8e2e67297f46..3dd7e55f2c3e 100644
--- a/devel/qt4-designer/Makefile
+++ b/devel/qt4-designer/Makefile
@@ -8,7 +8,6 @@
PORTNAME= designer
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4-help-tools/Makefile b/devel/qt4-help-tools/Makefile
index 81895ea11f37..dc9beaccfa69 100644
--- a/devel/qt4-help-tools/Makefile
+++ b/devel/qt4-help-tools/Makefile
@@ -7,7 +7,6 @@
PORTNAME= help
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4-help/Makefile b/devel/qt4-help/Makefile
index 607ea7123d6d..ce0f55d9d9f3 100644
--- a/devel/qt4-help/Makefile
+++ b/devel/qt4-help/Makefile
@@ -7,7 +7,6 @@
PORTNAME= help
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4-libqtassistantclient/Makefile b/devel/qt4-libqtassistantclient/Makefile
index 4882bf881976..23c7e069f0d3 100644
--- a/devel/qt4-libqtassistantclient/Makefile
+++ b/devel/qt4-libqtassistantclient/Makefile
@@ -8,7 +8,6 @@
PORTNAME= libQtAssistantClient
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4-linguist/Makefile b/devel/qt4-linguist/Makefile
index e37fddc0c0fa..da647b6fb122 100644
--- a/devel/qt4-linguist/Makefile
+++ b/devel/qt4-linguist/Makefile
@@ -8,7 +8,6 @@
PORTNAME= linguist
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4-makeqpf/Makefile b/devel/qt4-makeqpf/Makefile
index 765de9536cc9..de50dc7462ee 100644
--- a/devel/qt4-makeqpf/Makefile
+++ b/devel/qt4-makeqpf/Makefile
@@ -8,7 +8,6 @@
PORTNAME= makeqpf
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4-qdbusviewer/Makefile b/devel/qt4-qdbusviewer/Makefile
index 3522a34c92d9..83d61d8e604f 100644
--- a/devel/qt4-qdbusviewer/Makefile
+++ b/devel/qt4-qdbusviewer/Makefile
@@ -8,7 +8,6 @@
PORTNAME= qdbusviewer
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
@@ -49,12 +48,10 @@ INSTALL_WRKSRC= ${BUILD_WRKSRC}
EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
-.include <bsd.port.pre.mk>
-
-pre-configure:
+post-patch:
${MKDIR} ${WRKSRC}/mkspecs
${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/bin/moc
${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/bin/rcc
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/qt4-qvfb/Makefile b/devel/qt4-qvfb/Makefile
index abaa7f7be921..23ee6b354887 100644
--- a/devel/qt4-qvfb/Makefile
+++ b/devel/qt4-qvfb/Makefile
@@ -8,7 +8,6 @@
PORTNAME= qvfb
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4-scripttools/Makefile b/devel/qt4-scripttools/Makefile
index 3938dd067de8..89a8b889efdb 100644
--- a/devel/qt4-scripttools/Makefile
+++ b/devel/qt4-scripttools/Makefile
@@ -7,7 +7,6 @@
PORTNAME= scripttools
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4-uic3/Makefile b/devel/qt4-uic3/Makefile
index f2cc25aa681c..9a35743c7efc 100644
--- a/devel/qt4-uic3/Makefile
+++ b/devel/qt4-uic3/Makefile
@@ -8,7 +8,6 @@
PORTNAME= uic3
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4/Makefile b/devel/qt4/Makefile
index 04e615ec1ba6..544a028c1e49 100644
--- a/devel/qt4/Makefile
+++ b/devel/qt4/Makefile
@@ -7,7 +7,6 @@
PORTNAME= qt4
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= # empty
DISTFILES= # none
@@ -32,7 +31,7 @@ QT_COMPONENTS= accessible assistant assistant-adp assistantclient \
NO_BUILD= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if !defined(WITHOUT_NLS)
QT_COMPONENTS+= l10n
@@ -69,4 +68,4 @@ do-patch: #empty
do-install: #empty
${DO_NADA}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/qt4/distinfo b/devel/qt4/distinfo
index 6c9994b1a77e..312ec0de93d7 100644
--- a/devel/qt4/distinfo
+++ b/devel/qt4/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/qt-everywhere-opensource-src-4.6.1.tar.gz) = 0542a4be6425451ab5f668c6899cac36
-SHA256 (KDE/qt-everywhere-opensource-src-4.6.1.tar.gz) = 4c84b39b8a2546854ce9c0c9f761dd55da76dab2c33eeb876e3d17db1d2ea0c5
-SIZE (KDE/qt-everywhere-opensource-src-4.6.1.tar.gz) = 160197277
+MD5 (KDE/qt-everywhere-opensource-src-4.6.2.tar.gz) = eb651ee4b157c01696aa56777fc6e0e5
+SHA256 (KDE/qt-everywhere-opensource-src-4.6.2.tar.gz) = 176f51ddb06dce67ab4b2efc6b327dc21ed8f764c5d97acc15ff1f907c2affae
+SIZE (KDE/qt-everywhere-opensource-src-4.6.2.tar.gz) = 160601949
diff --git a/graphics/qt4-iconengines/Makefile b/graphics/qt4-iconengines/Makefile
index b58ce609afcc..3fbd8c784390 100644
--- a/graphics/qt4-iconengines/Makefile
+++ b/graphics/qt4-iconengines/Makefile
@@ -8,7 +8,6 @@
PORTNAME= iconengines
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= graphics
PKGNAMEPREFIX= qt4-
diff --git a/graphics/qt4-imageformats/Makefile b/graphics/qt4-imageformats/Makefile
index 968f02239210..9c21375da7ac 100644
--- a/graphics/qt4-imageformats/Makefile
+++ b/graphics/qt4-imageformats/Makefile
@@ -8,7 +8,6 @@
PORTNAME= imageformats
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 2
CATEGORIES?= graphics
PKGNAMEPREFIX= qt4-
diff --git a/graphics/qt4-pixeltool/Makefile b/graphics/qt4-pixeltool/Makefile
index 077ba6f4ccdf..63a522876dbf 100644
--- a/graphics/qt4-pixeltool/Makefile
+++ b/graphics/qt4-pixeltool/Makefile
@@ -8,7 +8,6 @@
PORTNAME= pixeltool
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= graphics
PKGNAMEPREFIX= qt4-
diff --git a/graphics/qt4-svg/Makefile b/graphics/qt4-svg/Makefile
index 0c77e83ccbce..b880a95ad0e1 100644
--- a/graphics/qt4-svg/Makefile
+++ b/graphics/qt4-svg/Makefile
@@ -8,7 +8,6 @@
PORTNAME= svg
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= graphics
PKGNAMEPREFIX= qt4-
diff --git a/misc/qt4-doc/pkg-plist b/misc/qt4-doc/pkg-plist
index 5daa43733db0..96bd4485ca79 100644
--- a/misc/qt4-doc/pkg-plist
+++ b/misc/qt4-doc/pkg-plist
@@ -263,6 +263,8 @@
%%DOCSDIR%%/html/demos-embedded-anomaly-src-main-cpp.html
%%DOCSDIR%%/html/demos-embedded-anomaly-src-titlebar-cpp.html
%%DOCSDIR%%/html/demos-embedded-anomaly-src-titlebar-h.html
+%%DOCSDIR%%/html/demos-embedded-anomaly-src-webview-cpp.html
+%%DOCSDIR%%/html/demos-embedded-anomaly-src-webview-h.html
%%DOCSDIR%%/html/demos-embedded-anomaly-src-zoomstrip-cpp.html
%%DOCSDIR%%/html/demos-embedded-anomaly-src-zoomstrip-h.html
%%DOCSDIR%%/html/demos-embedded-anomaly.html
@@ -300,6 +302,7 @@
%%DOCSDIR%%/html/demos-embedded-flightinfo-flightinfo-qrc.html
%%DOCSDIR%%/html/demos-embedded-flightinfo-form-ui.html
%%DOCSDIR%%/html/demos-embedded-flightinfo.html
+%%DOCSDIR%%/html/demos-embedded-fluidlauncher-backup-registration-xml.html
%%DOCSDIR%%/html/demos-embedded-fluidlauncher-config-s60-config-xml.html
%%DOCSDIR%%/html/demos-embedded-fluidlauncher-config-wince-config-xml.html
%%DOCSDIR%%/html/demos-embedded-fluidlauncher-config-xml.html
@@ -823,6 +826,9 @@
%%DOCSDIR%%/html/gestures-imagegestures.html
%%DOCSDIR%%/html/gestures-overview.html
%%DOCSDIR%%/html/gpl.html
+%%DOCSDIR%%/html/graphicsview-anchorlayout-anchorlayout-pro.html
+%%DOCSDIR%%/html/graphicsview-anchorlayout-main-cpp.html
+%%DOCSDIR%%/html/graphicsview-anchorlayout.html
%%DOCSDIR%%/html/graphicsview-api.html
%%DOCSDIR%%/html/graphicsview-basicgraphicslayouts-basicgraphicslayouts-pro.html
%%DOCSDIR%%/html/graphicsview-basicgraphicslayouts-basicgraphicslayouts-qrc.html
@@ -886,6 +892,13 @@
%%DOCSDIR%%/html/graphicsview-elasticnodes-node-cpp.html
%%DOCSDIR%%/html/graphicsview-elasticnodes-node-h.html
%%DOCSDIR%%/html/graphicsview-elasticnodes.html
+%%DOCSDIR%%/html/graphicsview-flowlayout-flowlayout-cpp.html
+%%DOCSDIR%%/html/graphicsview-flowlayout-flowlayout-h.html
+%%DOCSDIR%%/html/graphicsview-flowlayout-flowlayout-pro.html
+%%DOCSDIR%%/html/graphicsview-flowlayout-main-cpp.html
+%%DOCSDIR%%/html/graphicsview-flowlayout-window-cpp.html
+%%DOCSDIR%%/html/graphicsview-flowlayout-window-h.html
+%%DOCSDIR%%/html/graphicsview-flowlayout.html
%%DOCSDIR%%/html/graphicsview-padnavigator-backside-ui.html
%%DOCSDIR%%/html/graphicsview-padnavigator-images-artsfftscope-png.html
%%DOCSDIR%%/html/graphicsview-padnavigator-images-kontact-contacts-png.html
@@ -927,6 +940,14 @@
%%DOCSDIR%%/html/graphicsview-portedcanvas-portedcanvas-qrc.html
%%DOCSDIR%%/html/graphicsview-portedcanvas.html
%%DOCSDIR%%/html/graphicsview-porting.html
+%%DOCSDIR%%/html/graphicsview-simpleanchorlayout-main-cpp.html
+%%DOCSDIR%%/html/graphicsview-simpleanchorlayout-simpleanchorlayout-pro.html
+%%DOCSDIR%%/html/graphicsview-simpleanchorlayout.html
+%%DOCSDIR%%/html/graphicsview-weatheranchorlayout-images-weather-few-clouds-png.html
+%%DOCSDIR%%/html/graphicsview-weatheranchorlayout-main-cpp.html
+%%DOCSDIR%%/html/graphicsview-weatheranchorlayout-weatheranchorlayout-pro.html
+%%DOCSDIR%%/html/graphicsview-weatheranchorlayout-weatheranchorlayout-qrc.html
+%%DOCSDIR%%/html/graphicsview-weatheranchorlayout.html
%%DOCSDIR%%/html/graphicsview.html
%%DOCSDIR%%/html/groups.html
%%DOCSDIR%%/html/gui-framework-edition-classes.html
@@ -2225,6 +2246,7 @@
%%DOCSDIR%%/html/images/used-in-examples/graphicsview/padnavigator/images/kopeteavailable.png
%%DOCSDIR%%/html/images/used-in-examples/graphicsview/padnavigator/images/metacontact_online.png
%%DOCSDIR%%/html/images/used-in-examples/graphicsview/padnavigator/images/minitools.png
+%%DOCSDIR%%/html/images/used-in-examples/graphicsview/weatheranchorlayout/images/weather-few-clouds.png
%%DOCSDIR%%/html/images/used-in-examples/itemviews/pixelator/images/qt.png
%%DOCSDIR%%/html/images/used-in-examples/mainwindows/application/images/copy.png
%%DOCSDIR%%/html/images/used-in-examples/mainwindows/application/images/cut.png
@@ -2802,6 +2824,16 @@
%%DOCSDIR%%/html/network-broadcastsender-sender-cpp.html
%%DOCSDIR%%/html/network-broadcastsender-sender-h.html
%%DOCSDIR%%/html/network-broadcastsender.html
+%%DOCSDIR%%/html/network-download-download-pro.html
+%%DOCSDIR%%/html/network-download-main-cpp.html
+%%DOCSDIR%%/html/network-download.html
+%%DOCSDIR%%/html/network-downloadmanager-downloadmanager-cpp.html
+%%DOCSDIR%%/html/network-downloadmanager-downloadmanager-h.html
+%%DOCSDIR%%/html/network-downloadmanager-downloadmanager-pro.html
+%%DOCSDIR%%/html/network-downloadmanager-main-cpp.html
+%%DOCSDIR%%/html/network-downloadmanager-textprogressbar-cpp.html
+%%DOCSDIR%%/html/network-downloadmanager-textprogressbar-h.html
+%%DOCSDIR%%/html/network-downloadmanager.html
%%DOCSDIR%%/html/network-fortuneclient-client-cpp.html
%%DOCSDIR%%/html/network-fortuneclient-client-h.html
%%DOCSDIR%%/html/network-fortuneclient-fortuneclient-pro.html
@@ -5646,6 +5678,20 @@
%%DOCSDIR%%/html/script-helloscript-helloscript-qrc.html
%%DOCSDIR%%/html/script-helloscript-main-cpp.html
%%DOCSDIR%%/html/script-helloscript.html
+%%DOCSDIR%%/html/script-marshal-main-cpp.html
+%%DOCSDIR%%/html/script-marshal-marshal-pro.html
+%%DOCSDIR%%/html/script-marshal.html
+%%DOCSDIR%%/html/script-qscript-main-cpp.html
+%%DOCSDIR%%/html/script-qscript-qscript-pro.html
+%%DOCSDIR%%/html/script-qscript.html
+%%DOCSDIR%%/html/script-qsdbg-example-js.html
+%%DOCSDIR%%/html/script-qsdbg-main-cpp.html
+%%DOCSDIR%%/html/script-qsdbg-qsdbg-pro.html
+%%DOCSDIR%%/html/script-qsdbg-scriptbreakpointmanager-cpp.html
+%%DOCSDIR%%/html/script-qsdbg-scriptbreakpointmanager-h.html
+%%DOCSDIR%%/html/script-qsdbg-scriptdebugger-cpp.html
+%%DOCSDIR%%/html/script-qsdbg-scriptdebugger-h.html
+%%DOCSDIR%%/html/script-qsdbg.html
%%DOCSDIR%%/html/script-qstetrix-main-cpp.html
%%DOCSDIR%%/html/script-qstetrix-qstetrix-pro.html
%%DOCSDIR%%/html/script-qstetrix-tetrix-qrc.html
@@ -6062,6 +6108,11 @@
%%DOCSDIR%%/html/webkit-formextractor-mainwindow-cpp.html
%%DOCSDIR%%/html/webkit-formextractor-mainwindow-h.html
%%DOCSDIR%%/html/webkit-formextractor.html
+%%DOCSDIR%%/html/webkit-framecapture-framecapture-cpp.html
+%%DOCSDIR%%/html/webkit-framecapture-framecapture-h.html
+%%DOCSDIR%%/html/webkit-framecapture-framecapture-pro.html
+%%DOCSDIR%%/html/webkit-framecapture-main-cpp.html
+%%DOCSDIR%%/html/webkit-framecapture.html
%%DOCSDIR%%/html/webkit-googlechat-form-ui.html
%%DOCSDIR%%/html/webkit-googlechat-googlechat-cpp.html
%%DOCSDIR%%/html/webkit-googlechat-googlechat-h.html
@@ -6182,6 +6233,11 @@
%%DOCSDIR%%/html/widgets-sliders-window-cpp.html
%%DOCSDIR%%/html/widgets-sliders-window-h.html
%%DOCSDIR%%/html/widgets-sliders.html
+%%DOCSDIR%%/html/widgets-softkeys-main-cpp.html
+%%DOCSDIR%%/html/widgets-softkeys-softkeys-cpp.html
+%%DOCSDIR%%/html/widgets-softkeys-softkeys-h.html
+%%DOCSDIR%%/html/widgets-softkeys-softkeys-pro.html
+%%DOCSDIR%%/html/widgets-softkeys.html
%%DOCSDIR%%/html/widgets-spinboxes-main-cpp.html
%%DOCSDIR%%/html/widgets-spinboxes-spinboxes-pro.html
%%DOCSDIR%%/html/widgets-spinboxes-window-cpp.html
@@ -6269,6 +6325,15 @@
%%DOCSDIR%%/html/widgets-tooltips-tooltips-qrc.html
%%DOCSDIR%%/html/widgets-tooltips.html
%%DOCSDIR%%/html/widgets-tutorial.html
+%%DOCSDIR%%/html/widgets-validators-ledwidget-cpp.html
+%%DOCSDIR%%/html/widgets-validators-ledwidget-h.html
+%%DOCSDIR%%/html/widgets-validators-localeselector-cpp.html
+%%DOCSDIR%%/html/widgets-validators-localeselector-h.html
+%%DOCSDIR%%/html/widgets-validators-main-cpp.html
+%%DOCSDIR%%/html/widgets-validators-validators-pro.html
+%%DOCSDIR%%/html/widgets-validators-validators-qrc.html
+%%DOCSDIR%%/html/widgets-validators-validators-ui.html
+%%DOCSDIR%%/html/widgets-validators.html
%%DOCSDIR%%/html/widgets-wiggly-dialog-cpp.html
%%DOCSDIR%%/html/widgets-wiggly-dialog-h.html
%%DOCSDIR%%/html/widgets-wiggly-main-cpp.html
@@ -6444,6 +6509,8 @@
@dirrm %%DOCSDIR%%/html/images/used-in-examples/itemviews/pixelator/images
@dirrm %%DOCSDIR%%/html/images/used-in-examples/itemviews/pixelator
@dirrm %%DOCSDIR%%/html/images/used-in-examples/itemviews
+@dirrm %%DOCSDIR%%/html/images/used-in-examples/graphicsview/weatheranchorlayout/images
+@dirrm %%DOCSDIR%%/html/images/used-in-examples/graphicsview/weatheranchorlayout
@dirrm %%DOCSDIR%%/html/images/used-in-examples/graphicsview/padnavigator/images
@dirrm %%DOCSDIR%%/html/images/used-in-examples/graphicsview/padnavigator
@dirrm %%DOCSDIR%%/html/images/used-in-examples/graphicsview/dragdroprobot/images
diff --git a/misc/qt4-l10n/Makefile b/misc/qt4-l10n/Makefile
index ad24b7f5515e..99e5783be075 100644
--- a/misc/qt4-l10n/Makefile
+++ b/misc/qt4-l10n/Makefile
@@ -7,7 +7,6 @@
PORTNAME= l10n
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= misc
PKGNAMEPREFIX= qt4-
diff --git a/misc/qt4-qtconfig/Makefile b/misc/qt4-qtconfig/Makefile
index fbfd901b96ae..61425f8a6ac1 100644
--- a/misc/qt4-qtconfig/Makefile
+++ b/misc/qt4-qtconfig/Makefile
@@ -7,7 +7,6 @@
PORTNAME= qtconfig
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= misc
PKGNAMEPREFIX= qt4-
diff --git a/misc/qt4-qtdemo/Makefile b/misc/qt4-qtdemo/Makefile
index ea1c02dc43dc..5b91393e479a 100644
--- a/misc/qt4-qtdemo/Makefile
+++ b/misc/qt4-qtdemo/Makefile
@@ -8,7 +8,6 @@
PORTNAME= qtdemo
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 2
CATEGORIES?= misc
PKGNAMEPREFIX= qt4-
diff --git a/misc/qt4-qtdemo/pkg-plist b/misc/qt4-qtdemo/pkg-plist
index a65cdc1b4b20..ee416bf16bff 100644
--- a/misc/qt4-qtdemo/pkg-plist
+++ b/misc/qt4-qtdemo/pkg-plist
@@ -1181,6 +1181,10 @@ share/examples/qt4/examples/graphicsview/portedcanvas/portedcanvas.pro
share/examples/qt4/examples/graphicsview/portedcanvas/portedcanvas.qrc
share/examples/qt4/examples/graphicsview/portedcanvas/qt-trans.xpm
share/examples/qt4/examples/graphicsview/portedcanvas/qtlogo.png
+share/examples/qt4/examples/graphicsview/simpleanchorlayout/main.cpp
+share/examples/qt4/examples/graphicsview/simpleanchorlayout/simpleanchorlayout
+%%DEBUG%%share/examples/qt4/examples/graphicsview/simpleanchorlayout/simpleanchorlayout.debug
+share/examples/qt4/examples/graphicsview/simpleanchorlayout/simpleanchorlayout.pro
share/examples/qt4/examples/graphicsview/weatheranchorlayout/images/5days.jpg
share/examples/qt4/examples/graphicsview/weatheranchorlayout/images/details.jpg
share/examples/qt4/examples/graphicsview/weatheranchorlayout/images/place.jpg
@@ -2504,6 +2508,11 @@ share/examples/qt4/examples/webkit/formextractor/formextractor.ui
share/examples/qt4/examples/webkit/formextractor/main.cpp
share/examples/qt4/examples/webkit/formextractor/mainwindow.cpp
share/examples/qt4/examples/webkit/formextractor/mainwindow.h
+share/examples/qt4/examples/webkit/framecapture/framecapture
+%%DEBUG%%share/examples/qt4/examples/webkit/framecapture/framecapture.debug
+share/examples/qt4/examples/webkit/framecapture/framecapture.cpp
+share/examples/qt4/examples/webkit/framecapture/framecapture.h
+share/examples/qt4/examples/webkit/framecapture/main.cpp
share/examples/qt4/examples/webkit/googlechat/form.ui
share/examples/qt4/examples/webkit/googlechat/googlechat
share/examples/qt4/examples/webkit/googlechat/googlechat.cpp
@@ -2951,6 +2960,7 @@ share/examples/qt4/examples/xmlpatterns/xquery/xquery.pro
@dirrm share/examples/qt4/examples/webkit/simpleselector
@dirrm share/examples/qt4/examples/webkit/previewer
@dirrm share/examples/qt4/examples/webkit/googlechat
+@dirrm share/examples/qt4/examples/webkit/framecapture
@dirrm share/examples/qt4/examples/webkit/formextractor
@dirrm share/examples/qt4/examples/webkit/fancybrowser
@dirrm share/examples/qt4/examples/webkit/domtraversal
@@ -3155,6 +3165,7 @@ share/examples/qt4/examples/xmlpatterns/xquery/xquery.pro
@dirrm share/examples/qt4/examples/help
@dirrm share/examples/qt4/examples/graphicsview/weatheranchorlayout/images
@dirrm share/examples/qt4/examples/graphicsview/weatheranchorlayout
+@dirrm share/examples/qt4/examples/graphicsview/simpleanchorlayout
@dirrm share/examples/qt4/examples/graphicsview/portedcanvas
@dirrm share/examples/qt4/examples/graphicsview/portedasteroids/sprites/ship
@dirrm share/examples/qt4/examples/graphicsview/portedasteroids/sprites/shield
diff --git a/multimedia/qt4-multimedia/Makefile b/multimedia/qt4-multimedia/Makefile
index 51346879f5e0..573f03d20be8 100644
--- a/multimedia/qt4-multimedia/Makefile
+++ b/multimedia/qt4-multimedia/Makefile
@@ -7,7 +7,6 @@
PORTNAME= multimedia
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= multimedia
PKGNAMEPREFIX= qt4-
diff --git a/multimedia/qt4-phonon-gst/Makefile b/multimedia/qt4-phonon-gst/Makefile
index 868c0083e413..0ff7ea34b0a9 100644
--- a/multimedia/qt4-phonon-gst/Makefile
+++ b/multimedia/qt4-phonon-gst/Makefile
@@ -7,7 +7,6 @@
PORTNAME= phonon
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= multimedia
PKGNAMEPREFIX= qt4-
PKGNAMESUFFIX= -gst
@@ -46,7 +45,7 @@ INSTALL_WRKSRC= ${BUILD_WRKSRC}
EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
-.if defined(WITH_KDE_PHONON)
+.if !defined(WITH_QT_PHONON)
IGNORE= conflicts with multimedia/phonon-gstreamer. You have defined WITH_KDE_PHONON to override Qt4 phonon
.endif
diff --git a/multimedia/qt4-phonon/Makefile b/multimedia/qt4-phonon/Makefile
index 1156c5128568..9fae43627f0d 100644
--- a/multimedia/qt4-phonon/Makefile
+++ b/multimedia/qt4-phonon/Makefile
@@ -7,7 +7,6 @@
PORTNAME= phonon
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= multimedia
PKGNAMEPREFIX= qt4-
@@ -49,7 +48,7 @@ EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
.include <bsd.port.pre.mk>
-.if defined(WITH_KDE_PHONON)
+.if !defined(WITH_QT_PHONON)
IGNORE= conflicts with multimedia/phonon. You have defined WITH_KDE_PHONON to override Qt4 phonon
.endif
diff --git a/multimedia/qt4-phonon/pkg-plist b/multimedia/qt4-phonon/pkg-plist
index f85ff269236e..d306ac2b6f93 100644
--- a/multimedia/qt4-phonon/pkg-plist
+++ b/multimedia/qt4-phonon/pkg-plist
@@ -32,6 +32,7 @@ include/qt4/phonon/ObjectDescriptionData
include/qt4/phonon/ObjectDescriptionModel
include/qt4/phonon/ObjectDescriptionModelData
include/qt4/phonon/Path
+include/qt4/phonon/Phonon
include/qt4/phonon/PlatformPlugin
include/qt4/phonon/SeekSlider
include/qt4/phonon/StreamInterface
diff --git a/www/qt4-webkit/Makefile b/www/qt4-webkit/Makefile
index 8331e9959dd5..cee79f5286bd 100644
--- a/www/qt4-webkit/Makefile
+++ b/www/qt4-webkit/Makefile
@@ -7,7 +7,6 @@
PORTNAME= webkit
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= www
PKGNAMEPREFIX= qt4-
diff --git a/x11-toolkits/qt4-gui/Makefile b/x11-toolkits/qt4-gui/Makefile
index 952d38859bab..057936b982ad 100644
--- a/x11-toolkits/qt4-gui/Makefile
+++ b/x11-toolkits/qt4-gui/Makefile
@@ -8,7 +8,6 @@
PORTNAME= gui
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= x11-toolkits
PKGNAMEPREFIX= qt4-
diff --git a/x11/qt4-inputmethods/Makefile b/x11/qt4-inputmethods/Makefile
index e8b3a92aa93a..6542bfdd9394 100644
--- a/x11/qt4-inputmethods/Makefile
+++ b/x11/qt4-inputmethods/Makefile
@@ -8,7 +8,6 @@
PORTNAME= inputmethods
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= x11
PKGNAMEPREFIX= qt4-
diff --git a/x11/qt4-opengl/Makefile b/x11/qt4-opengl/Makefile
index d942c42b1fea..fe002c362cef 100644
--- a/x11/qt4-opengl/Makefile
+++ b/x11/qt4-opengl/Makefile
@@ -8,7 +8,6 @@
PORTNAME= opengl
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= x11
PKGNAMEPREFIX= qt4-