aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2009-10-24 17:56:07 +0000
committerBrooks Davis <brooks@FreeBSD.org>2009-10-24 17:56:07 +0000
commit171487d8fcaaec39c073ef59c9fa35d9463c8d19 (patch)
treea247a0e9c1f76aa041234c391d3b5b7a0ac29c40
parentb0ae83b84390b735ba30dcced08e91e81c883970 (diff)
downloadports-171487d8fcaaec39c073ef59c9fa35d9463c8d19.tar.gz
ports-171487d8fcaaec39c073ef59c9fa35d9463c8d19.zip
Notes
-rw-r--r--audio/squeezeboxserver/Makefile13
-rw-r--r--audio/squeezeboxserver/distinfo6
-rw-r--r--audio/squeezeboxserver/pkg-plist44
3 files changed, 35 insertions, 28 deletions
diff --git a/audio/squeezeboxserver/Makefile b/audio/squeezeboxserver/Makefile
index 287eefef23cd..927967323f06 100644
--- a/audio/squeezeboxserver/Makefile
+++ b/audio/squeezeboxserver/Makefile
@@ -6,15 +6,17 @@
#
PORTNAME= squeezeboxserver
-PORTVERSION= 7.4.0
+PORTVERSION= 7.4.1
CATEGORIES= audio
MASTER_SITES= http://downloads.slimdevices.com/SqueezeboxServer_v${PORTVERSION}/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-28672-noCPAN
+DISTNAME= ${PORTNAME}-${PORTVERSION}-noCPAN
EXTRACT_SUFX= .tgz
MAINTAINER= brooks@FreeBSD.org
COMMENT= Slim Devices audio streaming server
+CONFLICTS= squeezecenter-*
+
# Defaults support playback of relativly unrestricted formats on SB2 or
# SB3 devices and wired SB1 devices.
OPTIONS= APE "Support Monkey's Audio Codec input" on \
@@ -27,7 +29,7 @@ OPTIONS= APE "Support Monkey's Audio Codec input" on \
RESTRICTED= Contains non-redistributable firmware, documentation, and images
-WRKSRC= ${WRKDIR}/squeezeboxserver-${PORTVERSION}-28672-noCPAN
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-28947-noCPAN
RUN_DEPENDS+= ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
${SITE_PERL}/DBIx/Class.pm:${PORTSDIR}/databases/p5-DBIx-Class \
@@ -52,11 +54,12 @@ RUN_DEPENDS+= ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zl
PKGINSTALL= ${WRKDIR}/pkg-install
USE_PERL5= yes
-USE_MYSQL= yes
-IGNORE_WITH_MYSQL= 323 40
.include <bsd.port.pre.mk>
+USE_MYSQL= yes
+IGNORE_WITH_MYSQL= 323 40
+
# We need a dependency on the server because squeezecenter runs the binary
# directly with a non-standard config.
RUN_DEPENDS+= ${LOCALBASE}/libexec/mysqld:${PORTSDIR}/databases/mysql${MYSQL_VER}-server
diff --git a/audio/squeezeboxserver/distinfo b/audio/squeezeboxserver/distinfo
index 1274aa22e1e3..48ff664f64bc 100644
--- a/audio/squeezeboxserver/distinfo
+++ b/audio/squeezeboxserver/distinfo
@@ -1,3 +1,3 @@
-MD5 (squeezeboxserver-7.4.0-28672-noCPAN.tgz) = dab286a6d5197d5752592b074f4b36f6
-SHA256 (squeezeboxserver-7.4.0-28672-noCPAN.tgz) = 1eccb221e81e194a95cbce9372ec830afa81e406f2c8c95029fe88fbbefc868a
-SIZE (squeezeboxserver-7.4.0-28672-noCPAN.tgz) = 21848495
+MD5 (squeezeboxserver-7.4.1-noCPAN.tgz) = cf3a87ac33925842dfe7d404cab5de0a
+SHA256 (squeezeboxserver-7.4.1-noCPAN.tgz) = 8236bcc3acf802bd4fc0fa2761930f1f14d4b578460057e7d3d8c7b4b7e8910c
+SIZE (squeezeboxserver-7.4.1-noCPAN.tgz) = 22145277
diff --git a/audio/squeezeboxserver/pkg-plist b/audio/squeezeboxserver/pkg-plist
index f6255de08cff..56352d2e14f7 100644
--- a/audio/squeezeboxserver/pkg-plist
+++ b/audio/squeezeboxserver/pkg-plist
@@ -1,4 +1,6 @@
bin/softsqueeze
+@unexec if cmp -s %D/%%SLIMDIR%%/convert.conf %D/%%SLIMDIR%%/convert.conf.sample; then rm -f %D/%%SLIMDIR%%/convert.conf; fi
+@unexec if cmp -s %D/%%SLIMDIR%%/types.conf %D/%%SLIMDIR%%/types.conf.sample; then rm -f %D/%%SLIMDIR%%/types.conf; fi
%%PORTDOCS%%%%DOCSDIR%%/Changelog.html
%%PORTDOCS%%%%DOCSDIR%%/Installation.txt
%%PORTDOCS%%%%DOCSDIR%%/License.txt
@@ -432,7 +434,6 @@ bin/softsqueeze
%%SLIMDIR%%/CPAN/enum.pm
%%SLIMDIR%%/CPAN/version.pm
%%SLIMDIR%%/CPAN/version/vpp.pm
-%%SLIMDIR%%/Cache
%%SLIMDIR%%/Changelog1.html
%%SLIMDIR%%/Changelog2.html
%%SLIMDIR%%/Changelog3.html
@@ -1491,8 +1492,6 @@ bin/softsqueeze
%%SLIMDIR%%/License.nl.txt
%%SLIMDIR%%/MySQL/COPYING
%%SLIMDIR%%/MySQL/README
-%%SLIMDIR%%/MySQL/errmsg.sys
-%%SLIMDIR%%/MySQL/errmsg.txt
%%SLIMDIR%%/MySQL/my.tt
%%SLIMDIR%%/MySQL/system.sql
%%SLIMDIR%%/SQL/mysql/schema_10_down.sql
@@ -1828,6 +1827,11 @@ bin/softsqueeze
%%SLIMDIR%%/Slim/Plugin/Podcast/Settings.pm
%%SLIMDIR%%/Slim/Plugin/Podcast/install.xml
%%SLIMDIR%%/Slim/Plugin/Podcast/strings.txt
+%%SLIMDIR%%/Slim/Plugin/Queen/HTML/EN/plugins/Queen/html/images/icon.png
+%%SLIMDIR%%/Slim/Plugin/Queen/Plugin.pm
+%%SLIMDIR%%/Slim/Plugin/Queen/ProtocolHandler.pm
+%%SLIMDIR%%/Slim/Plugin/Queen/install.xml
+%%SLIMDIR%%/Slim/Plugin/Queen/strings.txt
%%SLIMDIR%%/Slim/Plugin/RS232/HTML/EN/plugins/RS232/settings/basic.html
%%SLIMDIR%%/Slim/Plugin/RS232/Plugin.pm
%%SLIMDIR%%/Slim/Plugin/RS232/Settings.pm
@@ -1957,7 +1961,6 @@ bin/softsqueeze
%%SLIMDIR%%/Slim/Utils/MySQLHelper.pm
%%SLIMDIR%%/Slim/Utils/Network.pm
%%SLIMDIR%%/Slim/Utils/OS.pm
-%%SLIMDIR%%/Slim/Utils/OS/Custom.pm
%%SLIMDIR%%/Slim/Utils/OS/Debian.pm
%%SLIMDIR%%/Slim/Utils/OS/Linux.pm
%%SLIMDIR%%/Slim/Utils/OS/OSX.pm
@@ -2048,7 +2051,6 @@ bin/softsqueeze
%%SLIMDIR%%/Slim/Web/XMLBrowser.pm
%%SLIMDIR%%/Slim/bootstrap.pm
%%SLIMDIR%%/cleanup.pl
-%%SLIMDIR%%/convert.conf
%%SLIMDIR%%/convert.conf.sample
%%SLIMDIR%%/lib/AnyEvent/DNS.pm
%%SLIMDIR%%/lib/AnyEvent/Impl/PerfMonEV.pm
@@ -2075,8 +2077,11 @@ bin/softsqueeze
%%SLIMDIR%%/slimservice-strings.txt
%%SLIMDIR%%/slimservice.pl
%%SLIMDIR%%/strings.txt
-%%SLIMDIR%%/types.conf
%%SLIMDIR%%/types.conf.sample
+%%SLIMDIR%%/Cache
+%%SLIMDIR%%/MySQL/errmsg.txt
+%%SLIMDIR%%/MySQL/errmsg.sys
+%%SLIMDIR%%/Slim/Utils/OS/Custom.pm
@dirrm %%SLIMDIR%%/lib/Template
@dirrm %%SLIMDIR%%/lib/Net/UPnP
@dirrm %%SLIMDIR%%/lib/Net
@@ -2187,12 +2192,13 @@ bin/softsqueeze
@dirrm %%SLIMDIR%%/Slim/Plugin/RS232/HTML/EN
@dirrm %%SLIMDIR%%/Slim/Plugin/RS232/HTML
@dirrm %%SLIMDIR%%/Slim/Plugin/RS232
-@dirrm %%SLIMDIR%%/Slim/Plugin/PreventStandby/HTML/EN/plugins/PreventStandby/settings
-@dirrm %%SLIMDIR%%/Slim/Plugin/PreventStandby/HTML/EN/plugins/PreventStandby
-@dirrm %%SLIMDIR%%/Slim/Plugin/PreventStandby/HTML/EN/plugins
-@dirrm %%SLIMDIR%%/Slim/Plugin/PreventStandby/HTML/EN
-@dirrm %%SLIMDIR%%/Slim/Plugin/PreventStandby/HTML
-@dirrm %%SLIMDIR%%/Slim/Plugin/PreventStandby
+@dirrm %%SLIMDIR%%/Slim/Plugin/Queen/HTML/EN/plugins/Queen/html/images
+@dirrm %%SLIMDIR%%/Slim/Plugin/Queen/HTML/EN/plugins/Queen/html
+@dirrm %%SLIMDIR%%/Slim/Plugin/Queen/HTML/EN/plugins/Queen
+@dirrm %%SLIMDIR%%/Slim/Plugin/Queen/HTML/EN/plugins
+@dirrm %%SLIMDIR%%/Slim/Plugin/Queen/HTML/EN
+@dirrm %%SLIMDIR%%/Slim/Plugin/Queen/HTML
+@dirrm %%SLIMDIR%%/Slim/Plugin/Queen
@dirrm %%SLIMDIR%%/Slim/Plugin/Podcast/HTML/EN/plugins/Podcast/settings
@dirrm %%SLIMDIR%%/Slim/Plugin/Podcast/HTML/EN/plugins/Podcast/html/images
@dirrm %%SLIMDIR%%/Slim/Plugin/Podcast/HTML/EN/plugins/Podcast/html
@@ -2417,7 +2423,6 @@ bin/softsqueeze
@dirrm %%SLIMDIR%%/SQL/slimservice
@dirrm %%SLIMDIR%%/SQL/mysql
@dirrm %%SLIMDIR%%/SQL
-@dirrm %%SLIMDIR%%/Plugins
@dirrm %%SLIMDIR%%/MySQL
@dirrm %%SLIMDIR%%/IR
@dirrm %%SLIMDIR%%/HTML/xml/html
@@ -2565,11 +2570,10 @@ bin/softsqueeze
@dirrm %%SLIMDIR%%/CPAN/AnyEvent
@dirrm %%SLIMDIR%%/CPAN/Algorithm
@dirrm %%SLIMDIR%%/CPAN
-@dirrm squeezeboxserver
+@dirrmtry %%SLIMDIR%%/Plugins
+@dirrmtry %%SLIMDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@unexec rm -rf /var/db/squeezecenter/cache > /dev/null 2>&1 || true
-@dirrmtry /var/db/squeezecenter/playlists
-@dirrmtry /var/db/squeezecenter
-@unexec test -d /var/db/squeezecenter && (echo "Configuration information saved. If you will *NOT* use this package anymore," && echo "please remove /var/db/squeezecenter and its contents manually.")
-@exec mkdir -p %D/%%SLIMDIR%%/Slim/Plugin/PreventStandby/HTML/EN/plugins/PreventStandby/settings
-@exec mkdir -p %D/%%SLIMDIR%%/Plugins
+@unexec rm -rf /var/db/squeezeboxserver/cache > /dev/null 2>&1 || true
+@dirrmtry /var/db/squeezeboxserver/playlists
+@dirrmtry /var/db/squeezeboxserver
+@unexec test -d /var/db/squeezeboxserver && (echo "Configuration information saved. If you will *NOT* use this package anymore," && echo "please remove /var/db/squeezeboxserver and its contents manually.")