aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2005-01-02 00:56:40 +0000
committerKris Kennaway <kris@FreeBSD.org>2005-01-02 00:56:40 +0000
commit1a9f977f3f73791d624f472e795f19ce8a7a3ed9 (patch)
tree533e8d2ee5eb5ba53991af0a134b657f20bda473
parentce3d881cbed80fde4a036819edd3288f2c9b4701 (diff)
downloadports-1a9f977f3f73791d624f472e795f19ce8a7a3ed9.tar.gz
ports-1a9f977f3f73791d624f472e795f19ce8a7a3ed9.zip
Notes
-rw-r--r--devel/cocktail/Makefile8
-rw-r--r--games/flightgear/Makefile8
-rw-r--r--games/freedoko/Makefile8
-rw-r--r--graphics/digikam-kde4/Makefile4
-rw-r--r--graphics/digikam/Makefile4
5 files changed, 29 insertions, 3 deletions
diff --git a/devel/cocktail/Makefile b/devel/cocktail/Makefile
index 05e8e9ac4995..d416aaf81548 100644
--- a/devel/cocktail/Makefile
+++ b/devel/cocktail/Makefile
@@ -19,8 +19,14 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAN1= ag.1 puma.1 mpp.1 lalr.1 ell.1 bnf.1 ast.1 rex.1 mtc.1
MAN2= mtc.2
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
post-extract:
${RM} -f ${WRKSRC}/mtc/m2c/SYSTEM_.h
${RM} -f ${WRKSRC}/mtc/m2c/SYSTEM_.c
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index 9be1cacd7d96..b0a1c2b2774d 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -41,6 +41,12 @@ CONFIGURE_ARGS= --program-transform-name='s/^${CONFIGURE_TARGET}-//' \
MAN1= est-epsilon.1 fgfs.1 fgjs.1 gl-info.1 js_demo.1 pstest.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
post-extract:
@${FIND} ${WRKSRC} \( -name '.#*' -or -name '*~' \) -delete
@@ -48,4 +54,4 @@ do-install:
@${ECHO} ">> Installing program"
@(cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/freedoko/Makefile b/games/freedoko/Makefile
index 62403586454a..db93b90b7696 100644
--- a/games/freedoko/Makefile
+++ b/games/freedoko/Makefile
@@ -27,6 +27,12 @@ MAKE_ENV= OSTYPE=linux-gnu DATADIR=${DATADIR}
CPIOFLAGS= --quiet -pdum -R ${SHAREOWN}:${SHAREGRP}
DATASUBDIRS= ai backgrounds cardsets rules translations
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/FreeDoko ${PREFIX}/bin
${LN} ${PREFIX}/bin/FreeDoko ${PREFIX}/bin/freedoko
@@ -38,4 +44,4 @@ do-install:
@cd ${WRKSRC}/../doc && \
${FIND} . ! -name Makefile\* | ${CPIO} ${CPIOFLAGS} ${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/digikam-kde4/Makefile b/graphics/digikam-kde4/Makefile
index 175ddc115bbc..90acfa07fd2a 100644
--- a/graphics/digikam-kde4/Makefile
+++ b/graphics/digikam-kde4/Makefile
@@ -30,6 +30,10 @@ INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
@${REINPLACE_CMD} -e 's@-lpthread@${PTHREAD_LIBS}@g' ${WRKSRC}/${CONFIGURE_SCRIPT}
diff --git a/graphics/digikam/Makefile b/graphics/digikam/Makefile
index 175ddc115bbc..90acfa07fd2a 100644
--- a/graphics/digikam/Makefile
+++ b/graphics/digikam/Makefile
@@ -30,6 +30,10 @@ INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
@${REINPLACE_CMD} -e 's@-lpthread@${PTHREAD_LIBS}@g' ${WRKSRC}/${CONFIGURE_SCRIPT}