aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2018-12-27 10:49:36 +0000
committerAlex Dupre <ale@FreeBSD.org>2018-12-27 10:49:36 +0000
commit24a56e410a25558cf0063d1f140c6d6fedc1c8c4 (patch)
treeb02ac0df319bf32ebd9f80cf38f2d09fa61428d0
parent7473f9316bb2dbfe7bd08a453933bd09a793c3dc (diff)
downloadports-24a56e410a25558cf0063d1f140c6d6fedc1c8c4.tar.gz
ports-24a56e410a25558cf0063d1f140c6d6fedc1c8c4.zip
MFH: r481614 r482814 r486504 r488526
Update to 1.2.7 release. Use java getLastModifiedTime now that openjdk8 port supports millisecond resolution. 'struct stat' ABI changed in FreeBSD 12, breaking FreeBSD specific JNA code that is no longer needed. Approved by: portmgr (bapt)
Notes
Notes: svn path=/branches/2018Q4/; revision=488532
-rw-r--r--devel/sbt/Makefile3
-rw-r--r--devel/sbt/distinfo6
-rw-r--r--devel/sbt/files/patch-bin_sbt-launch-lib.bash31
-rw-r--r--devel/sbt/files/sbt.sh.in2
-rw-r--r--devel/sbt/files/sbtopts3
5 files changed, 24 insertions, 21 deletions
diff --git a/devel/sbt/Makefile b/devel/sbt/Makefile
index 814a8f9737bc..694e7349866a 100644
--- a/devel/sbt/Makefile
+++ b/devel/sbt/Makefile
@@ -2,7 +2,8 @@
# $FreeBSD$
PORTNAME= sbt
-PORTVERSION= 1.2.3
+PORTVERSION= 1.2.7
+PORTREVISION= 1
CATEGORIES= devel java
MASTER_SITES= https://github.com/sbt/sbt/releases/download/v${PORTVERSION}/
diff --git a/devel/sbt/distinfo b/devel/sbt/distinfo
index ab0fd3db0565..b3d8ed87f696 100644
--- a/devel/sbt/distinfo
+++ b/devel/sbt/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1538119815
-SHA256 (sbt-1.2.3.tgz) = d502fbe587a6c2181d6acc688741ae4131386bb10ca50c73c923effc60bafeeb
-SIZE (sbt-1.2.3.tgz) = 46849530
+TIMESTAMP = 1543826287
+SHA256 (sbt-1.2.7.tgz) = 2625cbd8db75ec9b4a57e9a0af55a5ee8ad7700e1eba7d97ad78d9296450e781
+SIZE (sbt-1.2.7.tgz) = 47171488
diff --git a/devel/sbt/files/patch-bin_sbt-launch-lib.bash b/devel/sbt/files/patch-bin_sbt-launch-lib.bash
index b33892183f5e..f973c28e3925 100644
--- a/devel/sbt/files/patch-bin_sbt-launch-lib.bash
+++ b/devel/sbt/files/patch-bin_sbt-launch-lib.bash
@@ -1,6 +1,6 @@
---- bin/sbt-launch-lib.bash.orig 2017-08-29 21:39:02 UTC
+--- bin/sbt-launch-lib.bash.orig 2018-12-03 08:50:53 UTC
+++ bin/sbt-launch-lib.bash
-@@ -26,7 +26,7 @@ while [ -h "$SCRIPT" ] ; do
+@@ -27,7 +27,7 @@ while [ -h "$SCRIPT" ] ; do
fi
done
declare -r sbt_bin_dir="$(dirname "$SCRIPT")"
@@ -9,7 +9,7 @@
echoerr () {
echo 1>&2 "$@"
-@@ -39,7 +39,7 @@ dlog () {
+@@ -40,7 +40,7 @@ dlog () {
}
jar_file () {
@@ -18,21 +18,20 @@
}
acquire_sbt_jar () {
-@@ -172,14 +172,14 @@ process_args () {
+@@ -249,14 +249,14 @@ getPreloaded() {
+ }
+
syncPreloaded() {
+- local source_preloaded="$sbt_home/lib/local-preloaded"
++ local source_preloaded="$sbt_home/local-preloaded"
+ local target_preloaded="$(getPreloaded)"
if [[ "$init_sbt_version" == "" ]]; then
# FIXME: better $init_sbt_version detection
-- init_sbt_version="$(ls -1 "$sbt_home/lib/local-preloaded/org.scala-sbt/sbt/")"
-+ init_sbt_version="$(ls -1 "$sbt_home/local-preloaded/org.scala-sbt/sbt/")"
+ init_sbt_version="$(ls -1 "$source_preloaded/org.scala-sbt/sbt/")"
fi
- [[ -f "$HOME/.sbt/preloaded/org.scala-sbt/sbt/$init_sbt_version/jars/sbt.jar" ]] || {
- # lib/local-preloaded exists (This is optional)
-- [[ -d "$sbt_home/lib/local-preloaded/" ]] && {
-+ [[ -d "$sbt_home/local-preloaded/" ]] && {
+ [[ -f "$target_preloaded/org.scala-sbt/sbt/$init_sbt_version/jars/sbt.jar" ]] || {
+- # lib/local-preloaded exists (This is optional)
++ # local-preloaded exists (This is optional)
+ [[ -d "$source_preloaded" ]] && {
command -v rsync >/dev/null 2>&1 && {
- mkdir -p "$HOME/.sbt/preloaded"
-- rsync -a --ignore-existing "$sbt_home/lib/local-preloaded/" "$HOME/.sbt/preloaded"
-+ rsync -a --ignore-existing "$sbt_home/local-preloaded/" "$HOME/.sbt/preloaded"
- }
- }
- }
+ mkdir -p "$target_preloaded"
diff --git a/devel/sbt/files/sbt.sh.in b/devel/sbt/files/sbt.sh.in
index e6a79db2b589..1aa20eb75d3c 100644
--- a/devel/sbt/files/sbt.sh.in
+++ b/devel/sbt/files/sbt.sh.in
@@ -1,2 +1,2 @@
#!/bin/sh
-exec "%%LOCALBASE%%/bin/java" -Xms512M -Xmx1536M -Xss1M -XX:+CMSClassUnloadingEnabled -XX:MaxPermSize=256M -Dsbt.watch.mode=polling -jar "%%DATADIR%%/sbt-launch.jar" "$@"
+exec "%%LOCALBASE%%/bin/java" -Xms512M -Xmx1536M -Xss1M -XX:+CMSClassUnloadingEnabled -XX:MaxPermSize=256M -Dsbt.watch.mode=polling -Dsbt.io.jdktimestamps=true -jar "%%DATADIR%%/sbt-launch.jar" "$@"
diff --git a/devel/sbt/files/sbtopts b/devel/sbt/files/sbtopts
index 1c3e7937f85e..c9dba617cc33 100644
--- a/devel/sbt/files/sbtopts
+++ b/devel/sbt/files/sbtopts
@@ -2,3 +2,6 @@
# This triggers rebuilds on src changes after max. 0.5 seconds (instead of 10 seconds).
# Reference: https://github.com/sbt/sbt/issues/3868
-Dsbt.watch.mode=polling
+# Use java getLastModifiedTime now that it supports millisecond resolution
+# 'struct stat' ABI changed in FreeBSD 12, breaking JNA code
+-Dsbt.io.jdktimestamps=true