aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2006-10-07 03:32:29 +0000
committerShaun Amott <shaun@FreeBSD.org>2006-10-07 03:32:29 +0000
commit300106826850aeb789f0a52ceca1327c5aa828bf (patch)
tree9d78ebff4584e7ede4fc2391fee3eb67139ef5df
parentd5084d308ea012fa62efb8de7dba503ed8dbf678 (diff)
downloadports-300106826850aeb789f0a52ceca1327c5aa828bf.tar.gz
ports-300106826850aeb789f0a52ceca1327c5aa828bf.zip
Notes
-rw-r--r--shells/bash-completion-classic/Makefile1
-rw-r--r--shells/bash-completion-classic/files/patch-bash_completion19
-rw-r--r--shells/bash-completion/Makefile1
-rw-r--r--shells/bash-completion/files/patch-bash_completion19
4 files changed, 40 insertions, 0 deletions
diff --git a/shells/bash-completion-classic/Makefile b/shells/bash-completion-classic/Makefile
index 2fe6ea0ac133..2618cd19ddd2 100644
--- a/shells/bash-completion-classic/Makefile
+++ b/shells/bash-completion-classic/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bash-completion
PORTVERSION= 20060301
+PORTREVISION= 1
CATEGORIES= shells
MASTER_SITES= http://www.caliban.org/files/bash/
diff --git a/shells/bash-completion-classic/files/patch-bash_completion b/shells/bash-completion-classic/files/patch-bash_completion
new file mode 100644
index 000000000000..3d06ec6850e3
--- /dev/null
+++ b/shells/bash-completion-classic/files/patch-bash_completion
@@ -0,0 +1,19 @@
+--- bash_completion.old Sat Sep 23 20:42:29 2006
++++ bash_completion Sun Sep 24 10:55:26 2006
+@@ -5485,14 +5485,10 @@
+ local cur portsdir prev indexfile
+ local -a COMPREPLY2
+
+- portsdir=${PORTSDIR:-/usr/ports}/
++ portsdir=${PORTSDIR:-/usr/ports}
+ cur=${COMP_WORDS[COMP_CWORD]}
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+- # First try INDEX-5
+- indexfile=$portsdir/INDEX-5
+- # Then INDEX if INDEX-5 does not exist or system is not FreeBSD 5.x
+- [ "${OSTYPE%.*}" = "freebsd5" -a -f $indexfile ] ||
+- indexfile=$portsdir/INDEX
++ indexfile="${portsdir}/INDEX-${OSTYPE:7:1}"
+
+ [ "$prev" = "-l" -o "$prev" = "-L" -o "$prev" = "-o" ] && return 0
+
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index 2fe6ea0ac133..2618cd19ddd2 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bash-completion
PORTVERSION= 20060301
+PORTREVISION= 1
CATEGORIES= shells
MASTER_SITES= http://www.caliban.org/files/bash/
diff --git a/shells/bash-completion/files/patch-bash_completion b/shells/bash-completion/files/patch-bash_completion
new file mode 100644
index 000000000000..3d06ec6850e3
--- /dev/null
+++ b/shells/bash-completion/files/patch-bash_completion
@@ -0,0 +1,19 @@
+--- bash_completion.old Sat Sep 23 20:42:29 2006
++++ bash_completion Sun Sep 24 10:55:26 2006
+@@ -5485,14 +5485,10 @@
+ local cur portsdir prev indexfile
+ local -a COMPREPLY2
+
+- portsdir=${PORTSDIR:-/usr/ports}/
++ portsdir=${PORTSDIR:-/usr/ports}
+ cur=${COMP_WORDS[COMP_CWORD]}
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+- # First try INDEX-5
+- indexfile=$portsdir/INDEX-5
+- # Then INDEX if INDEX-5 does not exist or system is not FreeBSD 5.x
+- [ "${OSTYPE%.*}" = "freebsd5" -a -f $indexfile ] ||
+- indexfile=$portsdir/INDEX
++ indexfile="${portsdir}/INDEX-${OSTYPE:7:1}"
+
+ [ "$prev" = "-l" -o "$prev" = "-L" -o "$prev" = "-o" ] && return 0
+