aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-12-27 19:46:49 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-12-27 19:46:49 +0000
commit5999d65d7b76f007f5afb540599b73282b66bdbe (patch)
treefabd3de469152f9cbd34e2e0455f8244ffd87b5a
parent24a56e410a25558cf0063d1f140c6d6fedc1c8c4 (diff)
downloadports-5999d65d7b76f007f5afb540599b73282b66bdbe.tar.gz
ports-5999d65d7b76f007f5afb540599b73282b66bdbe.zip
MFH: r488561
games/aquaria: unbreak on GCC architectures after r455508 In file included from /usr/local/include/glm/detail/setup.hpp:30, from /usr/local/include/glm/detail/type_int.hpp:6, from /usr/local/include/glm/fwd.hpp:6, from /usr/local/include/glm/glm.hpp:61, from BBGE/RenderObject.cpp:29: /usr/local/include/glm/detail/../simd/platform.h:206:4: error: #error "GLM requires GCC 4.7 or higher" /usr/local/include/glm/detail/../simd/platform.h:230:3: error: #error "GLM_COMPILER undefined, your compiler may not be supported by GLM. Add #define GLM_COMPILER 0 to ignore this message." https://github.com/g-truc/glm/commit/dd48b56e44d6 PR: 234348 Submitted by: Piotr Kubaj Approved by: ports-secteam blanket
Notes
Notes: svn path=/branches/2018Q4/; revision=488562
-rw-r--r--games/aquaria/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/games/aquaria/Makefile b/games/aquaria/Makefile
index 6615764fb558..aa79a33c48f1 100644
--- a/games/aquaria/Makefile
+++ b/games/aquaria/Makefile
@@ -22,7 +22,7 @@ USE_GITHUB= yes
GH_ACCOUNT= AquariaOSE
GH_PROJECT= Aquaria
-USES= cmake lua:51 openal pkgconfig
+USES= cmake compiler:c++11-lang lua:51 openal pkgconfig
EXCLUDE= AL FTGL GL SDL* freetype2 glm glpng/png glpng/zlib \
libogg-* libvorbis-* lua-* tinyxml2*
EXTRACT_AFTER_ARGS=${EXCLUDE:S,^,--exclude ExternalLibs/,}