aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-07-15 08:43:08 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-07-15 08:43:08 +0000
commit72c8ba5f07cb72fe93e95081cf871ebb0ec93ff6 (patch)
treeb041af312153eea772a3c9b8c1c15e009f5f636b
parent00783341192655d4353daf86c20b84dc80948088 (diff)
downloadports-72c8ba5f07cb72fe93e95081cf871ebb0ec93ff6.tar.gz
ports-72c8ba5f07cb72fe93e95081cf871ebb0ec93ff6.zip
Notes
-rw-r--r--lang/php5/Makefile4
-rw-r--r--lang/php5/distinfo4
-rw-r--r--lang/php5/files/patch-sapi::apache::mod_php5.c11
-rw-r--r--lang/php5/pkg-plist1
-rw-r--r--lang/php53/Makefile4
-rw-r--r--lang/php53/distinfo4
-rw-r--r--lang/php53/files/patch-sapi::apache::mod_php5.c11
-rw-r--r--lang/php53/pkg-plist1
8 files changed, 32 insertions, 8 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index f52a6e3f15ba..2055b17e2c1b 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -21,8 +21,8 @@
#
PORTNAME= php5
-PORTVERSION= 5.0.0.r3
-PORTREVISION?= 2
+PORTVERSION= 5.0.0
+PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,}
MASTER_SITE_SUBDIR= distributions/:release
diff --git a/lang/php5/distinfo b/lang/php5/distinfo
index 05688432e927..714746a082cf 100644
--- a/lang/php5/distinfo
+++ b/lang/php5/distinfo
@@ -1,2 +1,2 @@
-MD5 (php-5.0.0RC3.tar.bz2) = aa24589d3c173052998792e4a6d255fa
-SIZE (php-5.0.0RC3.tar.bz2) = 4535975
+MD5 (php-5.0.0.tar.bz2) = 562b7ad1e903248bbe77884cb904b8b7
+SIZE (php-5.0.0.tar.bz2) = 4554054
diff --git a/lang/php5/files/patch-sapi::apache::mod_php5.c b/lang/php5/files/patch-sapi::apache::mod_php5.c
new file mode 100644
index 000000000000..6bdc5bcd5601
--- /dev/null
+++ b/lang/php5/files/patch-sapi::apache::mod_php5.c
@@ -0,0 +1,11 @@
+--- sapi/apache/mod_php5.c.orig Thu Jul 15 09:29:05 2004
++++ sapi/apache/mod_php5.c Thu Jul 15 09:30:01 2004
+@@ -485,7 +485,7 @@
+ tmp = uudecode(r->pool, authorization);
+ SG(request_info).auth_user = NULL;
+ tmp_user = getword_nulls_nc(r->pool, &tmp, ':');
+- if (SG(request_info).auth_user) {
++ if (tmp_user) {
+ r->connection->user = pstrdup(r->connection->pool, tmp_user);
+ r->connection->ap_auth_type = "Basic";
+ SG(request_info).auth_user = estrdup(tmp_user);
diff --git a/lang/php5/pkg-plist b/lang/php5/pkg-plist
index 293e320ad596..96b42bd00d88 100644
--- a/lang/php5/pkg-plist
+++ b/lang/php5/pkg-plist
@@ -249,6 +249,7 @@ lib/php/build/shtool
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/DependencyDB.php
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Downloader.php
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/ErrorStack.php
+%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Exception.php
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Frontend/CLI.php
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Installer.php
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Packager.php
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index f52a6e3f15ba..2055b17e2c1b 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -21,8 +21,8 @@
#
PORTNAME= php5
-PORTVERSION= 5.0.0.r3
-PORTREVISION?= 2
+PORTVERSION= 5.0.0
+PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,}
MASTER_SITE_SUBDIR= distributions/:release
diff --git a/lang/php53/distinfo b/lang/php53/distinfo
index 05688432e927..714746a082cf 100644
--- a/lang/php53/distinfo
+++ b/lang/php53/distinfo
@@ -1,2 +1,2 @@
-MD5 (php-5.0.0RC3.tar.bz2) = aa24589d3c173052998792e4a6d255fa
-SIZE (php-5.0.0RC3.tar.bz2) = 4535975
+MD5 (php-5.0.0.tar.bz2) = 562b7ad1e903248bbe77884cb904b8b7
+SIZE (php-5.0.0.tar.bz2) = 4554054
diff --git a/lang/php53/files/patch-sapi::apache::mod_php5.c b/lang/php53/files/patch-sapi::apache::mod_php5.c
new file mode 100644
index 000000000000..6bdc5bcd5601
--- /dev/null
+++ b/lang/php53/files/patch-sapi::apache::mod_php5.c
@@ -0,0 +1,11 @@
+--- sapi/apache/mod_php5.c.orig Thu Jul 15 09:29:05 2004
++++ sapi/apache/mod_php5.c Thu Jul 15 09:30:01 2004
+@@ -485,7 +485,7 @@
+ tmp = uudecode(r->pool, authorization);
+ SG(request_info).auth_user = NULL;
+ tmp_user = getword_nulls_nc(r->pool, &tmp, ':');
+- if (SG(request_info).auth_user) {
++ if (tmp_user) {
+ r->connection->user = pstrdup(r->connection->pool, tmp_user);
+ r->connection->ap_auth_type = "Basic";
+ SG(request_info).auth_user = estrdup(tmp_user);
diff --git a/lang/php53/pkg-plist b/lang/php53/pkg-plist
index 293e320ad596..96b42bd00d88 100644
--- a/lang/php53/pkg-plist
+++ b/lang/php53/pkg-plist
@@ -249,6 +249,7 @@ lib/php/build/shtool
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/DependencyDB.php
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Downloader.php
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/ErrorStack.php
+%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Exception.php
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Frontend/CLI.php
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Installer.php
%%CLI%%%%PEAR%%share/pear/bootstrap/PEAR/Packager.php