aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2010-01-03 04:59:15 +0000
committerGabor Pali <pgj@FreeBSD.org>2010-01-03 04:59:15 +0000
commit81793cc1beb1c973be34fb76f80c1b6571b5d22b (patch)
treec40759fa136e4ceb9a9f419c17fda7550e7bb775
parente341fa6f8c0de52b8c8a1ab10fb5d793d9c4a50b (diff)
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/hs-oeis/Makefile85
-rw-r--r--www/hs-oeis/distinfo3
-rw-r--r--www/hs-oeis/pkg-descr3
-rw-r--r--www/hs-oeis/pkg-plist14
5 files changed, 106 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 0e6fff90141c..f4d27f2e7ffd 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -290,6 +290,7 @@
SUBDIR += horde-wicked
SUBDIR += hs-HTTP
SUBDIR += hs-cgi
+ SUBDIR += hs-oeis
SUBDIR += hs-url
SUBDIR += htdump
SUBDIR += html2hdml
diff --git a/www/hs-oeis/Makefile b/www/hs-oeis/Makefile
new file mode 100644
index 000000000000..c9114a779b10
--- /dev/null
+++ b/www/hs-oeis/Makefile
@@ -0,0 +1,85 @@
+# New ports collection makefile for: hs-oeis
+# Date created: December 20 2009
+# Whom: Giuseppe Pilichi aka Jacula Modyun <jacula@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= oeis
+PORTVERSION= 0.2.2
+CATEGORIES= www haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= jacula@gmail.com
+COMMENT= A Haskell interface to the Online Encyclopedia of Integer Sequences
+
+BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
+ hs-HTTP>=4000.0.2:${PORTSDIR}/www/hs-HTTP
+RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
+ hs-HTTP>=4000.0.2:${PORTSDIR}/www/hs-HTTP
+
+GHC_VERSION= 6.10.4
+OEIS_VERSION= ${PORTVERSION}
+
+GHC_CMD= ${LOCALBASE}/bin/ghc
+SETUP_CMD= ./setup
+
+DATADIR= ${PREFIX}/share/${DISTNAME}
+PORTDATA= *
+
+DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
+OEIS_LIBDIR_REL= lib/${DISTNAME}
+
+PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
+ OEIS_VERSION=${OEIS_VERSION} \
+ OEIS_LIBDIR_REL=${OEIS_LIBDIR_REL}
+
+.if defined(NOPORTDOCS)
+PLIST_SUB+= NOPORTDOCS=""
+.else
+PLIST_SUB+= NOPORTDOCS="@comment "
+.endif
+
+.if !defined(NOPORTDOCS)
+
+PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
+.if !empty(PORT_HADDOCK:M?0)
+BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+.endif
+BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
+
+HSCOLOUR_VERSION= 1.15
+HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
+
+PORTDOCS= *
+.endif
+
+.SILENT:
+
+do-configure:
+ cd ${WRKSRC} && ${GHC_CMD} --make Setup.lhs -o setup -package Cabal
+.if !defined(NOPORTDATA)
+ cd ${WRKSRC} && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX}
+.else
+ cd ${WRKSRC} && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX} \
+ --datadir='' --datasubdir='' --docdir='${DOCSDIR}'
+.endif
+
+do-build:
+ cd ${WRKSRC} && ${SETUP_CMD} build \
+ && ${SETUP_CMD} register --gen-script
+
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${SETUP_CMD} haddock --hyperlink-source \
+ --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
+.endif
+
+do-install:
+ cd ${WRKSRC} && ${SETUP_CMD} install \
+ && ${INSTALL_SCRIPT} register.sh ${PREFIX}/${OEIS_LIBDIR_REL}/register.sh
+
+post-install:
+ ${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
+
+.include <bsd.port.mk>
diff --git a/www/hs-oeis/distinfo b/www/hs-oeis/distinfo
new file mode 100644
index 000000000000..9ea2dd11a345
--- /dev/null
+++ b/www/hs-oeis/distinfo
@@ -0,0 +1,3 @@
+MD5 (oeis-0.2.2.tar.gz) = 3e5f1a94647081033a27336d9a34f7fb
+SHA256 (oeis-0.2.2.tar.gz) = ac69aa48b29ea89c58c7ead5d0c2d62280526618667a024f35e89a71380606d0
+SIZE (oeis-0.2.2.tar.gz) = 7287
diff --git a/www/hs-oeis/pkg-descr b/www/hs-oeis/pkg-descr
new file mode 100644
index 000000000000..fe31ed201757
--- /dev/null
+++ b/www/hs-oeis/pkg-descr
@@ -0,0 +1,3 @@
+Haskell interface to the Online Encyclopedia of Integer Sequences.
+
+WWW: http://code.haskell.org/oeis
diff --git a/www/hs-oeis/pkg-plist b/www/hs-oeis/pkg-plist
new file mode 100644
index 000000000000..5c380d4a86e6
--- /dev/null
+++ b/www/hs-oeis/pkg-plist
@@ -0,0 +1,14 @@
+@comment $FreeBSD$
+%%OEIS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HSoeis-%%OEIS_VERSION%%.o
+%%OEIS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Math/OEIS.hi
+%%OEIS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHSoeis-%%OEIS_VERSION%%.a
+%%OEIS_LIBDIR_REL%%/register.sh
+%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
+%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrm %%OEIS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Math
+@dirrm %%OEIS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%OEIS_LIBDIR_REL%%
+@exec /bin/sh %D/%%OEIS_LIBDIR_REL%%/register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister oeis
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old