aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-10-12 13:14:35 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-10-12 13:14:35 +0000
commit82bcd30467050d8c3cc456294a48388340b2c54e (patch)
treebce9abf270ff1e9c3d2943f18aec8ae4c155f290
parent64ab122e739bc526b0da01573c6f898c27d13844 (diff)
downloadports-82bcd30467050d8c3cc456294a48388340b2c54e.tar.gz
ports-82bcd30467050d8c3cc456294a48388340b2c54e.zip
Notes
-rw-r--r--www/youtube_dl/Makefile1
-rw-r--r--www/youtube_dl/files/conv2avi.patch18
2 files changed, 9 insertions, 10 deletions
diff --git a/www/youtube_dl/Makefile b/www/youtube_dl/Makefile
index 166090a1d1e8..f8ea198547d9 100644
--- a/www/youtube_dl/Makefile
+++ b/www/youtube_dl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= youtube_dl
PORTVERSION= 2008.08.09
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.arrakis.es/~rggi3/youtube-dl/
DISTNAME= youtube-dl-${PORTVERSION}
diff --git a/www/youtube_dl/files/conv2avi.patch b/www/youtube_dl/files/conv2avi.patch
index 05408e6b6c6c..dc57ddded6b5 100644
--- a/www/youtube_dl/files/conv2avi.patch
+++ b/www/youtube_dl/files/conv2avi.patch
@@ -1,14 +1,13 @@
---- youtube-dl.orig 2008-07-27 11:21:44.000000000 +0400
-+++ youtube-dl 2008-07-27 11:24:01.000000000 +0400
-@@ -288,6 +288,22 @@
- except (urllib2.URLError, httplib.HTTPException, socket.error), err:
- retcode = self.trouble('ERROR: unable to download video data: %s' % str(err))
+--- youtube-dl.orig 2008-10-12 16:49:43.000000000 +0400
++++ youtube-dl 2008-10-12 16:54:22.000000000 +0400
+@@ -309,6 +309,20 @@
+ retcode = self.trouble('ERROR: postprocessing: %s' % str(err))
continue
-+
+
+ # Convert to avi if needed
+ if self._params['useavi']:
+ avi_filename = '%s.avi' % filename
-+
++
+ try:
+ os.system('%%CONV2AVI_CMD%% "%s" "%s" > %s 2> %s' % (filename, avi_filename, os.path.devnull, os.path.devnull))
+ self.to_stdout('Video file converted to %s' % avi_filename)
@@ -19,11 +18,10 @@
+ os.unlink(filename)
+ except OSError, e:
+ retcode = self.trouble('ERROR: unable to remove downloaded file: %s' % e.strerror)
-+
break
if not suitable_found:
retcode = self.trouble('ERROR: no suitable InfoExtractor: %s' % url)
-@@ -773,6 +789,8 @@
+@@ -859,6 +873,8 @@
action='store_true', dest='useliteral', help='use literal title in file name', default=False)
parser.add_option('-n', '--netrc',
action='store_true', dest='usenetrc', help='use .netrc authentication data', default=False)
@@ -32,7 +30,7 @@
parser.add_option('-g', '--get-url',
action='store_true', dest='geturl', help='simulate, quiet but print URL', default=False)
parser.add_option('-e', '--get-title',
-@@ -829,6 +847,7 @@
+@@ -915,6 +931,7 @@
or u'%(id)s.%(ext)s'),
'ignoreerrors': opts.ignoreerrors,
'ratelimit': opts.ratelimit,