aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2015-05-05 10:33:57 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2015-05-05 10:33:57 +0000
commit8519328476dbd9c91b678b28ed59ca3cea4dae10 (patch)
tree9d6596e2269b9e130f7aa3e67c24cf5f273903bb
parent9a0b474491e9aa2a37dce11576029276c8f6fd02 (diff)
downloadports-8519328476dbd9c91b678b28ed59ca3cea4dae10.tar.gz
ports-8519328476dbd9c91b678b28ed59ca3cea4dae10.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/erlang-protobuffs/Makefile40
-rw-r--r--devel/erlang-protobuffs/distinfo2
-rw-r--r--devel/erlang-protobuffs/files/patch-rebar.config13
-rw-r--r--devel/erlang-protobuffs/files/patch-src_protobuffs.app.src13
-rw-r--r--devel/erlang-protobuffs/pkg-descr3
-rw-r--r--devel/erlang-protobuffs/pkg-plist18
7 files changed, 90 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8e3305f88fcb..e47fabba9b3b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -408,6 +408,7 @@
SUBDIR += eric6
SUBDIR += eris
SUBDIR += erlang-msgpack
+ SUBDIR += erlang-protobuffs
SUBDIR += esdl
SUBDIR += etcd
SUBDIR += etcdctl
diff --git a/devel/erlang-protobuffs/Makefile b/devel/erlang-protobuffs/Makefile
new file mode 100644
index 000000000000..670f7318e90f
--- /dev/null
+++ b/devel/erlang-protobuffs/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= protobuffs
+PORTVERSION= 0.8.1p5
+CATEGORIES= devel
+PKGNAMEPREFIX= erlang-
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= Protocol Buffers interface for Erlang
+
+BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang \
+ rebar:${PORTSDIR}/devel/rebar
+RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang
+
+PLIST_SUB= VERSION="${PORTVERSION}"
+
+USE_GITHUB= yes
+GH_ACCOUNT= basho
+GH_PROJECT= erlang_protobuffs
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e "s/%%PORTVERSION%%/${PORTVERSION}/" ${WRKSRC}/src/protobuffs.app.src
+ @${RM} ${WRKSRC}/src/*.bak ${WRKSRC}/src/*.orig
+
+do-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.markdown ${STAGEDIR}${DOCSDIR}
+.endif
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/protobuffs-${PORTVERSION}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/protobuffs-${PORTVERSION}/ebin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/protobuffs-${PORTVERSION}/src
+ ${INSTALL_DATA} ${WRKSRC}/ebin/* ${STAGEDIR}${PREFIX}/lib/erlang/lib/protobuffs-${PORTVERSION}/ebin
+ ${INSTALL_DATA} ${WRKSRC}/src/* ${STAGEDIR}${PREFIX}/lib/erlang/lib/protobuffs-${PORTVERSION}/src
+
+.include <bsd.port.mk>
diff --git a/devel/erlang-protobuffs/distinfo b/devel/erlang-protobuffs/distinfo
new file mode 100644
index 000000000000..29f6db89c575
--- /dev/null
+++ b/devel/erlang-protobuffs/distinfo
@@ -0,0 +1,2 @@
+SHA256 (basho-erlang_protobuffs-0.8.1p5_GH0.tar.gz) = da82e70e7e725b0a2c5794e7fd39ddbb014012bc1ec2846574fe0ffc442e8fa8
+SIZE (basho-erlang_protobuffs-0.8.1p5_GH0.tar.gz) = 132265
diff --git a/devel/erlang-protobuffs/files/patch-rebar.config b/devel/erlang-protobuffs/files/patch-rebar.config
new file mode 100644
index 000000000000..f25b03fa1db0
--- /dev/null
+++ b/devel/erlang-protobuffs/files/patch-rebar.config
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- rebar.config.orig
++++ rebar.config
+@@ -1,7 +1,6 @@
+ {erl_opts, [debug_info]}.
+
+ {deps,[
+- {meck, "0.8.2", {git, "git://github.com/basho/meck.git", {tag, "0.8.2"}}}
+ ]}.
+
+ {clean_files, ["*~","**/*~","**/*.beam","logs/*","test/Emakefile"]}.
diff --git a/devel/erlang-protobuffs/files/patch-src_protobuffs.app.src b/devel/erlang-protobuffs/files/patch-src_protobuffs.app.src
new file mode 100644
index 000000000000..714b4178422e
--- /dev/null
+++ b/devel/erlang-protobuffs/files/patch-src_protobuffs.app.src
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- src/protobuffs.app.src.orig
++++ src/protobuffs.app.src
+@@ -1,6 +1,6 @@
+ { application, protobuffs,
+ [ { description, "Google protobuffs implementation for Erlang." },
+- { vsn, git },
++ { vsn, "%%PORTVERSION%%" },
+ { registered, [] },
+ { applications, [kernel,stdlib] },
+ { env, [] }
diff --git a/devel/erlang-protobuffs/pkg-descr b/devel/erlang-protobuffs/pkg-descr
new file mode 100644
index 000000000000..8876288ce83d
--- /dev/null
+++ b/devel/erlang-protobuffs/pkg-descr
@@ -0,0 +1,3 @@
+Protocol Buffers interface for Erlang.
+
+WWW: https://github.com/basho/erlang_protobuffs
diff --git a/devel/erlang-protobuffs/pkg-plist b/devel/erlang-protobuffs/pkg-plist
new file mode 100644
index 000000000000..71cd61227f6c
--- /dev/null
+++ b/devel/erlang-protobuffs/pkg-plist
@@ -0,0 +1,18 @@
+lib/erlang/lib/protobuffs-%%VERSION%%/ebin/pokemon_pb.beam
+lib/erlang/lib/protobuffs-%%VERSION%%/ebin/protobuffs.app
+lib/erlang/lib/protobuffs-%%VERSION%%/ebin/protobuffs.beam
+lib/erlang/lib/protobuffs-%%VERSION%%/ebin/protobuffs_compile.beam
+lib/erlang/lib/protobuffs-%%VERSION%%/ebin/protobuffs_file.beam
+lib/erlang/lib/protobuffs-%%VERSION%%/ebin/protobuffs_parser.beam
+lib/erlang/lib/protobuffs-%%VERSION%%/ebin/protobuffs_scanner.beam
+lib/erlang/lib/protobuffs-%%VERSION%%/src/overview.edoc
+lib/erlang/lib/protobuffs-%%VERSION%%/src/pokemon_pb.erl
+lib/erlang/lib/protobuffs-%%VERSION%%/src/protobuffs.app.src
+lib/erlang/lib/protobuffs-%%VERSION%%/src/protobuffs.erl
+lib/erlang/lib/protobuffs-%%VERSION%%/src/protobuffs_compile.erl
+lib/erlang/lib/protobuffs-%%VERSION%%/src/protobuffs_file.erl
+lib/erlang/lib/protobuffs-%%VERSION%%/src/protobuffs_parser.erl
+lib/erlang/lib/protobuffs-%%VERSION%%/src/protobuffs_parser.yrl
+lib/erlang/lib/protobuffs-%%VERSION%%/src/protobuffs_scanner.erl
+lib/erlang/lib/protobuffs-%%VERSION%%/src/protobuffs_scanner.xrl
+%%PORTDOCS%%%%DOCSDIR%%/README.markdown