aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2018-12-19 09:10:11 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2018-12-19 09:10:11 +0000
commit8daad6cb3be62b1e7e429531fb99792aa7673ef5 (patch)
treea57a4a32f5312b36319568427de97b16d0b7b61b
parent14d5429703477bc0366a97a9608923f1ee5ae5db (diff)
downloadports-8daad6cb3be62b1e7e429531fb99792aa7673ef5.tar.gz
ports-8daad6cb3be62b1e7e429531fb99792aa7673ef5.zip
MFH: r486833
lang/php72: Upgrade from 7.2.12 to 7.2.13 Changelog: http://www.php.net/ChangeLog-7.php#7.2.13 Approved by: ports-secteam (miwi)
Notes
Notes: svn path=/branches/2018Q4/; revision=487790
-rw-r--r--lang/php72/Makefile2
-rw-r--r--lang/php72/distinfo6
-rw-r--r--mail/php72-imap/Makefile1
-rw-r--r--mail/php72-imap/files/patch-php__imap.c40
-rw-r--r--mail/php72-imap/files/patch-php__imap.h10
5 files changed, 4 insertions, 55 deletions
diff --git a/lang/php72/Makefile b/lang/php72/Makefile
index cae76cbde941..8235942c85b8 100644
--- a/lang/php72/Makefile
+++ b/lang/php72/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= php72
-DISTVERSION= 7.2.10
+DISTVERSION= 7.2.13
PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
diff --git a/lang/php72/distinfo b/lang/php72/distinfo
index 1bb5208614e0..26270b954d39 100644
--- a/lang/php72/distinfo
+++ b/lang/php72/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1536863011
-SHA256 (php-7.2.10.tar.xz) = 01c2154a3a8e3c0818acbdbc1a956832c828a0380ce6d1d14fea495ea21804f0
-SIZE (php-7.2.10.tar.xz) = 12160864
+TIMESTAMP = 1544005077
+SHA256 (php-7.2.13.tar.xz) = 14b0429abdb46b65c843e5882c9a8c46b31dfbf279c747293b8ab950c2644a4b
+SIZE (php-7.2.13.tar.xz) = 12116484
diff --git a/mail/php72-imap/Makefile b/mail/php72-imap/Makefile
index 8391b4ca8c1d..0d9e7835f449 100644
--- a/mail/php72-imap/Makefile
+++ b/mail/php72-imap/Makefile
@@ -1,7 +1,6 @@
# $FreeBSD$
CATEGORIES= mail
-PORTREVISION= 1
MASTERDIR= ${.CURDIR}/../../lang/php72
diff --git a/mail/php72-imap/files/patch-php__imap.c b/mail/php72-imap/files/patch-php__imap.c
deleted file mode 100644
index faa12adafa16..000000000000
--- a/mail/php72-imap/files/patch-php__imap.c
+++ /dev/null
@@ -1,40 +0,0 @@
---- php_imap.c.orig 2018-09-11 22:12:36 UTC
-+++ php_imap.c
-@@ -562,6 +562,15 @@ static const zend_module_dep imap_deps[]
- };
- /* }}} */
-
-+
-+/* {{{ PHP_INI
-+ */
-+PHP_INI_BEGIN()
-+STD_PHP_INI_BOOLEAN("imap.enable_insecure_rsh", "0", PHP_INI_SYSTEM, OnUpdateBool, enable_rsh, zend_imap_globals, imap_globals)
-+PHP_INI_END()
-+/* }}} */
-+
-+
- /* {{{ imap_module_entry
- */
- zend_module_entry imap_module_entry = {
-@@ -835,6 +844,8 @@ PHP_MINIT_FUNCTION(imap)
- {
- unsigned long sa_all = SA_MESSAGES | SA_RECENT | SA_UNSEEN | SA_UIDNEXT | SA_UIDVALIDITY;
-
-+ REGISTER_INI_ENTRIES();
-+
- #ifndef PHP_WIN32
- mail_link(&unixdriver); /* link in the unix driver */
- mail_link(&mhdriver); /* link in the mh driver */
-@@ -1052,6 +1063,12 @@ PHP_MINIT_FUNCTION(imap)
- GC_TEXTS texts
- */
-
-+ if (!IMAPG(enable_rsh)) {
-+ /* disable SSH and RSH, see https://bugs.php.net/bug.php?id=77153 */
-+ mail_parameters (NIL, SET_RSHTIMEOUT, 0);
-+ mail_parameters (NIL, SET_SSHTIMEOUT, 0);
-+ }
-+
- le_imap = zend_register_list_destructors_ex(mail_close_it, NULL, "imap", module_number);
- return SUCCESS;
- }
diff --git a/mail/php72-imap/files/patch-php__imap.h b/mail/php72-imap/files/patch-php__imap.h
deleted file mode 100644
index f27f888f2ee7..000000000000
--- a/mail/php72-imap/files/patch-php__imap.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- php_imap.h.orig 2018-09-11 22:12:36 UTC
-+++ php_imap.h
-@@ -214,6 +214,7 @@ ZEND_BEGIN_MODULE_GLOBALS(imap)
- #endif
- /* php_stream for php_mail_gets() */
- php_stream *gets_stream;
-+ zend_bool enable_rsh;
- ZEND_END_MODULE_GLOBALS(imap)
-
- #ifdef ZTS