aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2008-08-30 18:05:09 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2008-08-30 18:05:09 +0000
commit98d153478b26b0845d1d9553e9323d4359bc0780 (patch)
treec8107c1c86fe5e5a16ae4710330d6e5eb57e59aa
parent6ac71c1f27b503328f9fae0742ae5ac634db8d69 (diff)
downloadports-98d153478b26b0845d1d9553e9323d4359bc0780.tar.gz
ports-98d153478b26b0845d1d9553e9323d4359bc0780.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Sub-Current/Makefile22
-rw-r--r--devel/p5-Sub-Current/distinfo3
-rw-r--r--devel/p5-Sub-Current/pkg-descr10
-rw-r--r--devel/p5-Sub-Current/pkg-plist7
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4cba1e2cf811..8dbe43acf593 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1665,6 +1665,7 @@
SUBDIR += p5-String-Random
SUBDIR += p5-String-RexxParse
SUBDIR += p5-String-Similarity
+ SUBDIR += p5-Sub-Current
SUBDIR += p5-Sub-Exporter
SUBDIR += p5-Sub-Identify
SUBDIR += p5-Sub-Install
diff --git a/devel/p5-Sub-Current/Makefile b/devel/p5-Sub-Current/Makefile
new file mode 100644
index 000000000000..e5cd92fbeca6
--- /dev/null
+++ b/devel/p5-Sub-Current/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Sub-Current
+# Date created: 2008/08/30
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sub-Current
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/R/RG/RGARCIA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Get the current subroutine
+
+PERL_CONFIGURE= yes
+
+MAN3= Sub::Current.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Sub-Current/distinfo b/devel/p5-Sub-Current/distinfo
new file mode 100644
index 000000000000..f29e66ea280f
--- /dev/null
+++ b/devel/p5-Sub-Current/distinfo
@@ -0,0 +1,3 @@
+MD5 (Sub-Current-0.02.tar.gz) = 67ffe5f248410c6f8f225a39f7420d19
+SHA256 (Sub-Current-0.02.tar.gz) = c98cb4edaa7db2f33e9ae9c1032ac2fce65a45cc223a0136c4c02e2bb5d2a59b
+SIZE (Sub-Current-0.02.tar.gz) = 2405
diff --git a/devel/p5-Sub-Current/pkg-descr b/devel/p5-Sub-Current/pkg-descr
new file mode 100644
index 000000000000..ee3df98227ec
--- /dev/null
+++ b/devel/p5-Sub-Current/pkg-descr
@@ -0,0 +1,10 @@
+Sub::Current makes available a function ROUTINE(), that returns a code
+reference pointing at the currently executing subroutine.
+
+In a special block (BEGIN, END, CHECK, INIT, and UNITCHECK in Perl 5.10)
+this function will return undef.
+
+Outside of a special block (that is, at the top level of a program)
+ROUTINE() will return undef as well.
+
+WWW: http://search.cpan.org/dist/Sub-Current/
diff --git a/devel/p5-Sub-Current/pkg-plist b/devel/p5-Sub-Current/pkg-plist
new file mode 100644
index 000000000000..fe082919a2ff
--- /dev/null
+++ b/devel/p5-Sub-Current/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Current/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Current/Current.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Current/Current.so
+%%SITE_PERL%%/%%PERL_ARCH%%/Sub/Current.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Current
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Sub