aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-12-05 05:19:29 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-12-05 05:19:29 +0000
commit99372820495372dae1ec86469e172a952960c751 (patch)
treeb7fd09c2fea0f38a69f7edb41720c1be268f0fe2
parentb4fdb54f4e73323fabe394d3d80c9fdd0225c3f7 (diff)
downloadports-99372820495372dae1ec86469e172a952960c751.tar.gz
ports-99372820495372dae1ec86469e172a952960c751.zip
MFH: r486650
textproc/ripgrep: unbreak AVX=on on i386 after r454995 error[E0432]: unresolved import `simd::x86::avx` --> cargo-crates/bytecount-0.3.2/src/lib.rs:49:16 | 49 | use simd::x86::avx::{LowHigh128, u8x32}; | ^^^ could not find `avx` in `x86` https://github.com/rust-lang/rust/issues/56527 Approved by: ports-secteam blanket
Notes
Notes: svn path=/branches/2018Q4/; revision=486651
-rw-r--r--textproc/ripgrep/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/textproc/ripgrep/Makefile b/textproc/ripgrep/Makefile
index e65b60d4b649..4eedada8dd63 100644
--- a/textproc/ripgrep/Makefile
+++ b/textproc/ripgrep/Makefile
@@ -96,7 +96,7 @@ AVX_IMPLIES= SIMD
# unstable features similar to how lang/rust bootstraps. www/firefox
# uses the same hack when building with --enable-rust-simd.
SIMD_MAKE_ENV= RUSTC_BOOTSTRAP=1
-SIMD_VARS= CARGO_FEATURES+=simd-accel ${SIMD_VARS_${ARCH}}
+SIMD_VARS= CARGO_FEATURES+=simd-accel ${SIMD_VARS_${ARCH}${PORT_OPTIONS:MAVX}}
SIMD_VARS_i386= RUSTFLAGS+="-C target-feature=+sse2"
post-patch: