aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2006-07-05 22:12:13 +0000
committerMichael Johnson <ahze@FreeBSD.org>2006-07-05 22:12:13 +0000
commit997d9367d911f112ef3a121a1cbe916ca0dae706 (patch)
tree928738530956fe431f5f504c65dd56402c8eba7d
parent5cc8b1f47545ed3c14ee17263163e2835bce130c (diff)
downloadports-997d9367d911f112ef3a121a1cbe916ca0dae706.tar.gz
ports-997d9367d911f112ef3a121a1cbe916ca0dae706.zip
Notes
-rw-r--r--mail/thunderbird-esr/Makefile8
-rw-r--r--mail/thunderbird/Makefile8
-rw-r--r--mail/thunderbird3/Makefile8
-rw-r--r--www/firefox-esr/Makefile6
-rw-r--r--www/firefox/Makefile6
-rw-r--r--www/firefox15/Makefile6
-rw-r--r--www/firefox36/Makefile6
-rw-r--r--www/kompozer/Makefile6
-rw-r--r--www/mozilla/bsd.gecko.mk2
-rw-r--r--www/nvu/Makefile6
10 files changed, 49 insertions, 13 deletions
diff --git a/mail/thunderbird-esr/Makefile b/mail/thunderbird-esr/Makefile
index 5eed6514383b..e89d58c4f69b 100644
--- a/mail/thunderbird-esr/Makefile
+++ b/mail/thunderbird-esr/Makefile
@@ -44,9 +44,13 @@ OPTIONS=
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../../www/mozilla/Makefile.common"
-.if ( ${ARCH} == "alpha" && ${OSVERSION} < 500035 ) || ${ARCH} == "sparc64"
+.if ( ${ARCH} == "alpha" && ${OSVERSION} < 500035 )
IGNORE= core dumps at runtime
-.endif # ( ${ARCH} == "alpha" && ${OSVERSION} < 500035 ) || ${ARCH} == "sparc64"
+.endif # ( ${ARCH} == "alpha" && ${OSVERSION} < 500035 )
+
+.if (${ARCH}=="sparc64" && ${OSVERSION} < 601101)
+IGNORE= core dumps on ${ARCH}, kern.osreldate>=601101 needed
+.endif
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 5eed6514383b..e89d58c4f69b 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -44,9 +44,13 @@ OPTIONS=
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../../www/mozilla/Makefile.common"
-.if ( ${ARCH} == "alpha" && ${OSVERSION} < 500035 ) || ${ARCH} == "sparc64"
+.if ( ${ARCH} == "alpha" && ${OSVERSION} < 500035 )
IGNORE= core dumps at runtime
-.endif # ( ${ARCH} == "alpha" && ${OSVERSION} < 500035 ) || ${ARCH} == "sparc64"
+.endif # ( ${ARCH} == "alpha" && ${OSVERSION} < 500035 )
+
+.if (${ARCH}=="sparc64" && ${OSVERSION} < 601101)
+IGNORE= core dumps on ${ARCH}, kern.osreldate>=601101 needed
+.endif
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
diff --git a/mail/thunderbird3/Makefile b/mail/thunderbird3/Makefile
index 5eed6514383b..e89d58c4f69b 100644
--- a/mail/thunderbird3/Makefile
+++ b/mail/thunderbird3/Makefile
@@ -44,9 +44,13 @@ OPTIONS=
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../../www/mozilla/Makefile.common"
-.if ( ${ARCH} == "alpha" && ${OSVERSION} < 500035 ) || ${ARCH} == "sparc64"
+.if ( ${ARCH} == "alpha" && ${OSVERSION} < 500035 )
IGNORE= core dumps at runtime
-.endif # ( ${ARCH} == "alpha" && ${OSVERSION} < 500035 ) || ${ARCH} == "sparc64"
+.endif # ( ${ARCH} == "alpha" && ${OSVERSION} < 500035 )
+
+.if (${ARCH}=="sparc64" && ${OSVERSION} < 601101)
+IGNORE= core dumps on ${ARCH}, kern.osreldate>=601101 needed
+.endif
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 94b4262825b7..5ba9750a7998 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -44,10 +44,14 @@ OPTIONS= NEWTAB "Open external links in a new tab" on \
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500035 || ${ARCH}=="sparc64"
+.if ${ARCH}=="alpha" && ${OSVERSION} < 500035
IGNORE= core dumps on ${ARCH}
.endif
+.if ${ARCH}=="sparc64" && ${OSVERSION} < 601101
+IGNORE= core dumps on ${ARCH}, kern.osreldate>=601101 needed
+.endif
+
.if ${OSVERSION} >= 600000
MOZ_OPTIONS+= --enable-svg --enable-svg-renderer=cairo
.endif
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 94b4262825b7..5ba9750a7998 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -44,10 +44,14 @@ OPTIONS= NEWTAB "Open external links in a new tab" on \
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500035 || ${ARCH}=="sparc64"
+.if ${ARCH}=="alpha" && ${OSVERSION} < 500035
IGNORE= core dumps on ${ARCH}
.endif
+.if ${ARCH}=="sparc64" && ${OSVERSION} < 601101
+IGNORE= core dumps on ${ARCH}, kern.osreldate>=601101 needed
+.endif
+
.if ${OSVERSION} >= 600000
MOZ_OPTIONS+= --enable-svg --enable-svg-renderer=cairo
.endif
diff --git a/www/firefox15/Makefile b/www/firefox15/Makefile
index 94b4262825b7..5ba9750a7998 100644
--- a/www/firefox15/Makefile
+++ b/www/firefox15/Makefile
@@ -44,10 +44,14 @@ OPTIONS= NEWTAB "Open external links in a new tab" on \
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500035 || ${ARCH}=="sparc64"
+.if ${ARCH}=="alpha" && ${OSVERSION} < 500035
IGNORE= core dumps on ${ARCH}
.endif
+.if ${ARCH}=="sparc64" && ${OSVERSION} < 601101
+IGNORE= core dumps on ${ARCH}, kern.osreldate>=601101 needed
+.endif
+
.if ${OSVERSION} >= 600000
MOZ_OPTIONS+= --enable-svg --enable-svg-renderer=cairo
.endif
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index 94b4262825b7..5ba9750a7998 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -44,10 +44,14 @@ OPTIONS= NEWTAB "Open external links in a new tab" on \
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500035 || ${ARCH}=="sparc64"
+.if ${ARCH}=="alpha" && ${OSVERSION} < 500035
IGNORE= core dumps on ${ARCH}
.endif
+.if ${ARCH}=="sparc64" && ${OSVERSION} < 601101
+IGNORE= core dumps on ${ARCH}, kern.osreldate>=601101 needed
+.endif
+
.if ${OSVERSION} >= 600000
MOZ_OPTIONS+= --enable-svg --enable-svg-renderer=cairo
.endif
diff --git a/www/kompozer/Makefile b/www/kompozer/Makefile
index 4ee15f053f37..418c8176e070 100644
--- a/www/kompozer/Makefile
+++ b/www/kompozer/Makefile
@@ -29,10 +29,14 @@ CFLAGS+= -I${X11BASE}/include
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../mozilla/Makefile.common"
-.if ${ARCH} == "sparc64" || ${ARCH} == "ia64"
+.if ${ARCH} == "ia64"
BROKEN= does not build
.endif
+.if ${ARCH}=="sparc64" && ${OSVERSION} < 601101
+IGNORE= does not build
+.endif
+
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif
diff --git a/www/mozilla/bsd.gecko.mk b/www/mozilla/bsd.gecko.mk
index 0528be0b2867..b3be01bded07 100644
--- a/www/mozilla/bsd.gecko.mk
+++ b/www/mozilla/bsd.gecko.mk
@@ -68,7 +68,7 @@ Gecko_Pre_Include= bsd.gecko.mk
# .endif
.if ${OSVERSION} >= 500000
-.if ${ARCH}!="sparc64" && ${ARCH}!="ia64"
+.if (${ARCH}!="sparc64" || ${OSVERSION} >= 601101) && ${ARCH}!="ia64"
_GECKO_ALL= firefox nvu seamonkey sunbird thunderbird xulrunner firefox-devel flock
.endif
_GECKO_ALL+= firefox10
diff --git a/www/nvu/Makefile b/www/nvu/Makefile
index 4ee15f053f37..418c8176e070 100644
--- a/www/nvu/Makefile
+++ b/www/nvu/Makefile
@@ -29,10 +29,14 @@ CFLAGS+= -I${X11BASE}/include
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../mozilla/Makefile.common"
-.if ${ARCH} == "sparc64" || ${ARCH} == "ia64"
+.if ${ARCH} == "ia64"
BROKEN= does not build
.endif
+.if ${ARCH}=="sparc64" && ${OSVERSION} < 601101
+IGNORE= does not build
+.endif
+
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif