aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-06-27 09:13:28 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2014-06-27 09:13:28 +0000
commit9d61cdae1a0ec16006ece5bc87ed96ec3f1e8e9c (patch)
tree27053b60254731ceffeeb3e922ab983a525b73d9
parentcf9bc4fce4c0bdf12c459764375b69269cd25b62 (diff)
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-redis/Makefile21
-rw-r--r--www/py-django-redis/distinfo2
-rw-r--r--www/py-django-redis/pkg-descr17
4 files changed, 41 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index ec6d2c621483..e01e0286b7f2 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1522,6 +1522,7 @@
SUBDIR += py-django-pipeline12
SUBDIR += py-django-piston
SUBDIR += py-django-profiles
+ SUBDIR += py-django-redis
SUBDIR += py-django-registration
SUBDIR += py-django-registration-defaults
SUBDIR += py-django-reversion
diff --git a/www/py-django-redis/Makefile b/www/py-django-redis/Makefile
new file mode 100644
index 000000000000..b97edbc55a67
--- /dev/null
+++ b/www/py-django-redis/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= django-redis
+PORTVERSION= 3.6.2
+CATEGORIES= www databases
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= melvyn@magemana.nl
+COMMENT= Full featured Redis cache/session backend for Django
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django>=1.3:${PORTSDIR}/www/py-django \
+ ${PYTHON_PKGNAMEPREFIX}redis>=2.9.0:${PORTSDIR}/databases/py-redis
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-django-redis/distinfo b/www/py-django-redis/distinfo
new file mode 100644
index 000000000000..9ca33caae705
--- /dev/null
+++ b/www/py-django-redis/distinfo
@@ -0,0 +1,2 @@
+SHA256 (django-redis-3.6.2.tar.gz) = 98174cde8abaa2552308eebf6b89ac45d6d174efb004418185dcba858d18feee
+SIZE (django-redis-3.6.2.tar.gz) = 12246
diff --git a/www/py-django-redis/pkg-descr b/www/py-django-redis/pkg-descr
new file mode 100644
index 000000000000..920f29ce2d74
--- /dev/null
+++ b/www/py-django-redis/pkg-descr
@@ -0,0 +1,17 @@
+Django-redis is a BSD Licensed, full featured Redis cache/session
+backend for Django.
+
+Why use django-redis?
+
+ * Modular client system (pluggable clients).
+ * Master-Slave support in the default client.
+ * Used in production in several projects as cache and session storage.
+ * Supports infinite timeouts.
+ * Python 3 support in same code base.
+ * Facilities for raw access to Redis client/connection pool.
+ * Highly configurable (can emulate memcached exception behavior, for
+ example).
+ * Unix sockets supported by default.
+ * Pluggable parsers.
+
+WWW: http://niwibe.github.io/django-redis