aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2003-02-27 18:09:09 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2003-02-27 18:09:09 +0000
commit9ea8fec662042e892d228d66c4d64a90193572e8 (patch)
tree3f1c3c607231a69e22a93bbd57898112da132d5c
parentfd6c59a744e99257549f3f8d48fe26fc9ef403ba (diff)
downloadports-9ea8fec662042e892d228d66c4d64a90193572e8.tar.gz
ports-9ea8fec662042e892d228d66c4d64a90193572e8.zip
Notes
-rw-r--r--security/openssl/Makefile.ssl9
1 files changed, 6 insertions, 3 deletions
diff --git a/security/openssl/Makefile.ssl b/security/openssl/Makefile.ssl
index f135538c89d9..320a472fa25c 100644
--- a/security/openssl/Makefile.ssl
+++ b/security/openssl/Makefile.ssl
@@ -28,10 +28,13 @@
!defined(USE_OPENSSL_BETA) && \
!defined(USE_OPENSSL_PORT) && \
!exists(${LOCALBASE}/lib/libcrypto.so)
-# 4.7-STABLE has not yet 0.9.7a
-# 5.0-CURRENT has not yet 0.9.7a
+# Security: version in base must be 0.9.7a
.if exists(/usr/lib/libcrypto.so.3)
-#USE_OPENSSL_BASE=yes
+OPENSSLVER!= ${AWK} '/OPENSSL_VERSION_NUMBER/ { print $$3 }' \
+ /usr/include/openssl/opensslv.h
+.if ${OPENSSLVER} == 0x0090701fL
+USE_OPENSSL_BASE=yes
+.endif
.endif
.endif