aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2018-12-05 23:20:48 +0000
committerMatthias Andree <mandree@FreeBSD.org>2018-12-05 23:20:48 +0000
commita0054741a0c616bfb884b369fc0b78f64c5e4bd1 (patch)
treeab33fcf337e61d20ebcdcfcda04770bebb32a878
parentf16354d1d5fcc603afb296da9178b40bbc3c6bc1 (diff)
downloadports-a0054741a0c616bfb884b369fc0b78f64c5e4bd1.tar.gz
ports-a0054741a0c616bfb884b369fc0b78f64c5e4bd1.zip
MFH: r486634
Align *_DEPENDS and use paths for bash in my ports; fix var name. On systems where bash is in $PATH but not in ${LOCALBASE}/bin/bash, ilmbase would fail to build, and e2fsprogs might fail if the BASHTESTS option was enabled. Make sure that the _DEPENDS and the actual path handed to the configure or test rig match to the letter, to avoid a time-of-check vs. time-of-use discrepancy. In e2fsprogs, the helper variable was also mistyped and would never amend to BUILD_DEPENDS. Fix typo. Check my other ports, but wiggle and xmlto [textproc/] seem unaffected. Reported by: J R Matthews (direct email) Approved by: ports-secteam (miwi)
Notes
Notes: svn path=/branches/2018Q4/; revision=486724
-rw-r--r--graphics/ilmbase/Makefile9
-rw-r--r--sysutils/e2fsprogs/Makefile5
2 files changed, 10 insertions, 4 deletions
diff --git a/graphics/ilmbase/Makefile b/graphics/ilmbase/Makefile
index 9952bda5a073..5e7df6eee91d 100644
--- a/graphics/ilmbase/Makefile
+++ b/graphics/ilmbase/Makefile
@@ -11,14 +11,17 @@ COMMENT= ILM Base libraries a.k.a. Half, IlmThread, Imath, and Iex
LICENSE= BSD3CLAUSE
-BUILD_DEPENDS= bash:shells/bash
+# there are some systems that have a static /bin/bash, so
+# in order to make BUILD_DEPENDS effective, use the same absolute
+# path we will pass down through CONFIGURE_SHELL below.
+BUILD_DEPENDS= ${BASH_CMD}:shells/bash
USES= compiler:c++14-lang pkgconfig libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
# The configure script uses bash arrays
-CONFIGURE_SHELL= ${LOCALBASE}/bin/bash
+CONFIGURE_SHELL=${BASH_CMD}
CONFIGURE_ARGS= --disable-static
TEST_TARGET= check
@@ -27,6 +30,8 @@ OPTIONS_DEFINE= DOCS LARGE_STACK
LARGE_STACK_DESC= Enable sys-dependent large stack optimizations
LARGE_STACK_CONFIGURE_ENABLE= large-stack
+BASH_CMD= ${LOCALBASE}/bin/bash
+
OPTIONS_SUB= yes
MAJORVER= 2_3
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index cd13a1a98871..dc5e7a2969cf 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -66,7 +66,8 @@ BASHTESTS_DESC= Enable tests that require the GNU bash shell
FUSEFS_CONFIGURE_ENABLE= fuse2fs
BUILD_DEPENDS+= gdd:sysutils/coreutils
-BASHTEST_BUILD_DEPENDS= bash:shells/bash
+BASHTESTS_BUILD_DEPENDS= ${BASH_CMD}:shells/bash
+BASH_CMD= ${LOCALBASE}/bin/bash
LIB_DEPENDS+= libblkid.so:misc/e2fsprogs-libblkid
LIB_DEPENDS+= libss.so:devel/e2fsprogs-libss
@@ -207,7 +208,7 @@ _checkaddargs+=TMPDIR=${WRKDIR}/tmp
.endif
.if ${PORT_OPTIONS:MBASHTESTS}
-_checkaddargs+=--eval SHELL:=${LOCALBASE}/bin/bash
+_checkaddargs+=--eval SHELL:=${BASH_CMD}
.endif
.if ${PORT_OPTIONS:MSLOWTESTS}