aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2018-12-19 09:12:32 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2018-12-19 09:12:32 +0000
commita12a9da496a2a2d2c0419c09b16bd71d7be4ca66 (patch)
treecffc0d6a4358ac64bdd9668bd7c52dc9e1820164
parent8daad6cb3be62b1e7e429531fb99792aa7673ef5 (diff)
downloadports-a12a9da496a2a2d2c0419c09b16bd71d7be4ca66.tar.gz
ports-a12a9da496a2a2d2c0419c09b16bd71d7be4ca66.zip
MFH: r486832
lang/php71: Upgrade from 7.1.24 to 7.1.25 Changelog: http://www.php.net/ChangeLog-7.php#7.1.25 Approved by: ports-secteam (miwi)
Notes
Notes: svn path=/branches/2018Q4/; revision=487791
-rw-r--r--lang/php71/Makefile2
-rw-r--r--lang/php71/distinfo6
-rw-r--r--mail/php71-imap/Makefile1
-rw-r--r--mail/php71-imap/files/patch-php__imap.c40
-rw-r--r--mail/php71-imap/files/patch-php__imap.h10
5 files changed, 4 insertions, 55 deletions
diff --git a/lang/php71/Makefile b/lang/php71/Makefile
index 4c1b607bdeb2..20be898ce112 100644
--- a/lang/php71/Makefile
+++ b/lang/php71/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= php71
-PORTVERSION= 7.1.24
+PORTVERSION= 7.1.25
PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
diff --git a/lang/php71/distinfo b/lang/php71/distinfo
index 221563d82fcf..39d18cf88337 100644
--- a/lang/php71/distinfo
+++ b/lang/php71/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1542299453
-SHA256 (php-7.1.24.tar.xz) = e70dcec0ae28b6bc308b78972ec15aa850808819cc765f505aa51e5a7e2fa5d7
-SIZE (php-7.1.24.tar.xz) = 12205112
+TIMESTAMP = 1544005139
+SHA256 (php-7.1.25.tar.xz) = 0fd8dad1903cd0b2d615a1fe4209f99e53b7292403c8ffa1919c0f4dd1eada88
+SIZE (php-7.1.25.tar.xz) = 12205972
SHA256 (php-7.1.x-mail-header.patch) = 8f173d89672f7ebfabfcc3c5d7f8dec1c4243aba665db4b4046e67c34d9d4dc7
SIZE (php-7.1.x-mail-header.patch) = 4504
diff --git a/mail/php71-imap/Makefile b/mail/php71-imap/Makefile
index 076bb217f5af..7c56e35e9865 100644
--- a/mail/php71-imap/Makefile
+++ b/mail/php71-imap/Makefile
@@ -1,7 +1,6 @@
# $FreeBSD$
CATEGORIES= mail
-PORTREVISION= 1
MASTERDIR= ${.CURDIR}/../../lang/php71
diff --git a/mail/php71-imap/files/patch-php__imap.c b/mail/php71-imap/files/patch-php__imap.c
deleted file mode 100644
index faa12adafa16..000000000000
--- a/mail/php71-imap/files/patch-php__imap.c
+++ /dev/null
@@ -1,40 +0,0 @@
---- php_imap.c.orig 2018-09-11 22:12:36 UTC
-+++ php_imap.c
-@@ -562,6 +562,15 @@ static const zend_module_dep imap_deps[]
- };
- /* }}} */
-
-+
-+/* {{{ PHP_INI
-+ */
-+PHP_INI_BEGIN()
-+STD_PHP_INI_BOOLEAN("imap.enable_insecure_rsh", "0", PHP_INI_SYSTEM, OnUpdateBool, enable_rsh, zend_imap_globals, imap_globals)
-+PHP_INI_END()
-+/* }}} */
-+
-+
- /* {{{ imap_module_entry
- */
- zend_module_entry imap_module_entry = {
-@@ -835,6 +844,8 @@ PHP_MINIT_FUNCTION(imap)
- {
- unsigned long sa_all = SA_MESSAGES | SA_RECENT | SA_UNSEEN | SA_UIDNEXT | SA_UIDVALIDITY;
-
-+ REGISTER_INI_ENTRIES();
-+
- #ifndef PHP_WIN32
- mail_link(&unixdriver); /* link in the unix driver */
- mail_link(&mhdriver); /* link in the mh driver */
-@@ -1052,6 +1063,12 @@ PHP_MINIT_FUNCTION(imap)
- GC_TEXTS texts
- */
-
-+ if (!IMAPG(enable_rsh)) {
-+ /* disable SSH and RSH, see https://bugs.php.net/bug.php?id=77153 */
-+ mail_parameters (NIL, SET_RSHTIMEOUT, 0);
-+ mail_parameters (NIL, SET_SSHTIMEOUT, 0);
-+ }
-+
- le_imap = zend_register_list_destructors_ex(mail_close_it, NULL, "imap", module_number);
- return SUCCESS;
- }
diff --git a/mail/php71-imap/files/patch-php__imap.h b/mail/php71-imap/files/patch-php__imap.h
deleted file mode 100644
index f27f888f2ee7..000000000000
--- a/mail/php71-imap/files/patch-php__imap.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- php_imap.h.orig 2018-09-11 22:12:36 UTC
-+++ php_imap.h
-@@ -214,6 +214,7 @@ ZEND_BEGIN_MODULE_GLOBALS(imap)
- #endif
- /* php_stream for php_mail_gets() */
- php_stream *gets_stream;
-+ zend_bool enable_rsh;
- ZEND_END_MODULE_GLOBALS(imap)
-
- #ifdef ZTS