aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-11-30 11:20:35 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-11-30 11:20:35 +0000
commita32054e27e48a43f510d8492e6b3576631d7f78b (patch)
tree4f2575b21e1e56fb382ab5d276467a708cec2a64
parentfcc2e35e3d253759b70e167ec3381bdff8af376d (diff)
downloadports-a32054e27e48a43f510d8492e6b3576631d7f78b.tar.gz
ports-a32054e27e48a43f510d8492e6b3576631d7f78b.zip
Notes
-rw-r--r--devel/kdevelop-pg-qt/files/patch-kdev-pg_kdev-pg-parser.yy11
-rw-r--r--lang/parrot/files/patch-compilers_imcc_imcc.y11
-rw-r--r--security/nessus-libnasl/files/patch-nasl_nasl__grammar.y37
-rw-r--r--security/nessus-libnasl/pkg-plist2
-rw-r--r--security/openvas-libnasl/files/patch-nasl_nasl__grammar.y37
-rw-r--r--www/htmlcxx/Makefile5
-rw-r--r--www/htmlcxx/files/patch-css_syntax.y27
-rw-r--r--www/htmlcxx/pkg-plist5
-rw-r--r--www/webkit-gtk2/files/patch-Source_ThirdParty_ANGLE_src_compiler_glslang.y13
-rw-r--r--x11/xstroke/files/patch-rec_parse.y32
10 files changed, 165 insertions, 15 deletions
diff --git a/devel/kdevelop-pg-qt/files/patch-kdev-pg_kdev-pg-parser.yy b/devel/kdevelop-pg-qt/files/patch-kdev-pg_kdev-pg-parser.yy
new file mode 100644
index 000000000000..91d6b913ecbd
--- /dev/null
+++ b/devel/kdevelop-pg-qt/files/patch-kdev-pg_kdev-pg-parser.yy
@@ -0,0 +1,11 @@
+--- kdev-pg/kdev-pg-parser.yy.orig 2012-01-27 21:40:18 UTC
++++ kdev-pg/kdev-pg-parser.yy
+@@ -309,7 +309,7 @@ opt_lexer_action
+ | T_CONTINUE {
+ r = "\nlxCONTINUE;\n";
+ }
+- | /* empty */ { r = "\nlxSKIP\n" }
++ | /* empty */ { r = "\nlxSKIP\n"; }
+ ;
+
+ regexp
diff --git a/lang/parrot/files/patch-compilers_imcc_imcc.y b/lang/parrot/files/patch-compilers_imcc_imcc.y
new file mode 100644
index 000000000000..3245e8f2e85b
--- /dev/null
+++ b/lang/parrot/files/patch-compilers_imcc_imcc.y
@@ -0,0 +1,11 @@
+--- compilers/imcc/imcc.y.orig 2013-01-28 19:57:42 UTC
++++ compilers/imcc/imcc.y
+@@ -45,7 +45,7 @@ This file contains the grammar of the PI
+
+ /* prevent declarations of malloc() and free() in the generated parser. */
+ #define YYMALLOC
+-#define YYFREE(Ptr) do { /* empty */; } while (YYID (0))
++#define YYFREE(Ptr) do { /* empty */; } while (0)
+
+ #ifndef YYENABLE_NLS
+ # define YYENABLE_NLS 0
diff --git a/security/nessus-libnasl/files/patch-nasl_nasl__grammar.y b/security/nessus-libnasl/files/patch-nasl_nasl__grammar.y
new file mode 100644
index 000000000000..702e88d2cf83
--- /dev/null
+++ b/security/nessus-libnasl/files/patch-nasl_nasl__grammar.y
@@ -0,0 +1,37 @@
+--- nasl/nasl_grammar.y.orig 2005-11-01 18:27:57 UTC
++++ nasl/nasl_grammar.y
+@@ -1,4 +1,6 @@
+ %pure_parser
++%parse-param {naslctxt * parm}
++%lex-param {naslctxt * parm}
+ %expect 1
+ %{
+ /* Nessus Attack Scripting Language version 2
+@@ -19,9 +21,6 @@
+ * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+
+-#define YYPARSE_PARAM parm
+-#define YYLEX_PARAM parm
+-
+ #define LNB (((naslctxt*)parm)->line_nb)
+ #include "includes.h"
+ #include "nasl_tree.h"
+@@ -31,7 +30,7 @@
+ #include "nasl_lex_ctxt.h"
+ #include "nasl_debug.h"
+
+-static void naslerror(const char *);
++static void naslerror(naslctxt *, const char *);
+ #define YYERROR_VERBOSE
+ %}
+
+@@ -466,7 +465,7 @@ glob: GLOBAL arg_decl
+ #include <stdlib.h>
+
+ static void
+-naslerror(const char *s)
++naslerror(naslctxt *parm, const char *s)
+ {
+ fputs(s, stderr);
+ }
diff --git a/security/nessus-libnasl/pkg-plist b/security/nessus-libnasl/pkg-plist
index 2506dcaf0db3..3ca60aa85f94 100644
--- a/security/nessus-libnasl/pkg-plist
+++ b/security/nessus-libnasl/pkg-plist
@@ -8,5 +8,3 @@ lib/libnasl.so.2.2.9
man/man1/nasl.1.gz
man/man1/nasl-config.1.gz
var/nessus/nessus_org.pem
-@dirrmtry var/nessus
-@dirrmtry var
diff --git a/security/openvas-libnasl/files/patch-nasl_nasl__grammar.y b/security/openvas-libnasl/files/patch-nasl_nasl__grammar.y
new file mode 100644
index 000000000000..71aaba95da76
--- /dev/null
+++ b/security/openvas-libnasl/files/patch-nasl_nasl__grammar.y
@@ -0,0 +1,37 @@
+--- nasl/nasl_grammar.y.orig 2009-02-10 11:14:10 UTC
++++ nasl/nasl_grammar.y
+@@ -1,4 +1,6 @@
+ %pure_parser
++%parse-param {void *parm}
++%lex-param {void *parm}
+ %expect 1
+ %{
+ /* Nessus Attack Scripting Language version 2
+@@ -19,9 +21,6 @@
+ * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+
+-#define YYPARSE_PARAM parm
+-#define YYLEX_PARAM parm
+-
+ #define LNB (((naslctxt*)parm)->line_nb)
+ #include "includes.h"
+ #include "nasl_tree.h"
+@@ -32,7 +31,7 @@
+ #include "nasl_debug.h"
+ #include "nasl_signature.h"
+
+-static void naslerror(const char *);
++static void naslerror(naslctxt *, const char *);
+ #define YYERROR_VERBOSE
+ %}
+
+@@ -470,7 +469,7 @@ glob: GLOBAL arg_decl
+ #include <stdlib.h>
+
+ static void
+-naslerror(const char *s)
++naslerror(naslctxt *parm, const char *s)
+ {
+ fputs(s, stderr);
+ }
diff --git a/www/htmlcxx/Makefile b/www/htmlcxx/Makefile
index 9c50e4cde503..7ee8eb6cc1db 100644
--- a/www/htmlcxx/Makefile
+++ b/www/htmlcxx/Makefile
@@ -12,13 +12,12 @@ COMMENT= HTML and CSS APIs for C++
LICENSE= LGPL20
LICENSE_FILE= ${WRKSRC}/LGPL_V2
-BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison
-
-USES= iconv libtool
+USES= bison iconv libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
MAKE_JOBS_UNSAFE=yes
diff --git a/www/htmlcxx/files/patch-css_syntax.y b/www/htmlcxx/files/patch-css_syntax.y
index e3c6863cf777..143e76298f83 100644
--- a/www/htmlcxx/files/patch-css_syntax.y
+++ b/www/htmlcxx/files/patch-css_syntax.y
@@ -1,9 +1,30 @@
---- css/css_syntax.y.orig 2012-09-19 15:27:03.000000000 +0800
-+++ css/css_syntax.y 2012-09-19 15:28:12.000000000 +0800
-@@ -1,5 +1,6 @@
+--- css/css_syntax.y.orig 2011-02-13 22:24:53 UTC
++++ css/css_syntax.y
+@@ -1,16 +1,17 @@
%{
#include <stdio.h>
+#include <stdlib.h>
#include <string.h>
#include "css_lex.h"
#include "parser.h"
+
+-#define YYPARSE_PARAM yyparam
+ #define YYERROR_VERBOSE 1
+ //#define YYDEBUG 1
+
+ %}
+
+ %pure_parser
++%parse-param { struct selector_list_t **yyparam }
+
+ %union {
+ char *lexeme;
+@@ -571,7 +572,7 @@ hexcolor
+
+ %%
+
+-int yyerror(char *s) {
++int yyerror(struct selector_list_t **yyparam, char *s) {
+ #if YYDEBUG
+ fprintf(stderr, "Error: %s\n", s);
+ #endif
diff --git a/www/htmlcxx/pkg-plist b/www/htmlcxx/pkg-plist
index e5af6fce728b..a2b68a80c112 100644
--- a/www/htmlcxx/pkg-plist
+++ b/www/htmlcxx/pkg-plist
@@ -23,8 +23,3 @@ lib/libhtmlcxx.so
lib/libhtmlcxx.so.3
lib/libhtmlcxx.so.3.1.0
share/htmlcxx/css/default.css
-@dirrm share/htmlcxx/css
-@dirrm share/htmlcxx
-@dirrm include/htmlcxx/html
-@dirrm include/htmlcxx/css
-@dirrm include/htmlcxx
diff --git a/www/webkit-gtk2/files/patch-Source_ThirdParty_ANGLE_src_compiler_glslang.y b/www/webkit-gtk2/files/patch-Source_ThirdParty_ANGLE_src_compiler_glslang.y
new file mode 100644
index 000000000000..99d78abc05c6
--- /dev/null
+++ b/www/webkit-gtk2/files/patch-Source_ThirdParty_ANGLE_src_compiler_glslang.y
@@ -0,0 +1,13 @@
+Allow building with bison 3
+Obtained from http://trac.webkit.org/changeset/154109/trunk/Source/ThirdParty/ANGLE/src/compiler/glslang.y
+
+--- Source/ThirdParty/ANGLE/src/compiler/glslang.y.orig 2012-08-20 16:26:06 UTC
++++ Source/ThirdParty/ANGLE/src/compiler/glslang.y
+@@ -32,6 +32,7 @@ WHICH GENERATES THE GLSL ES PARSER (glsl
+ %expect 1 /* One shift reduce conflict because of if | else */
+ %pure-parser
+ %parse-param {TParseContext* context}
++%lex-param {YYLEX_PARAM}
+
+ %union {
+ struct {
diff --git a/x11/xstroke/files/patch-rec_parse.y b/x11/xstroke/files/patch-rec_parse.y
index 3e2e427de96a..505937ecdf8c 100644
--- a/x11/xstroke/files/patch-rec_parse.y
+++ b/x11/xstroke/files/patch-rec_parse.y
@@ -1,5 +1,24 @@
---- rec_parse.y.orig 2001-12-10 18:01:17.000000000 +0100
-+++ rec_parse.y 2009-03-03 00:57:09.000000000 +0100
+--- rec_parse.y.orig 2001-12-10 17:01:17 UTC
++++ rec_parse.y
+@@ -32,9 +32,8 @@
+ #include "dmalloc.h"
+ #endif
+
+-static int yyerror(char *err);
++static int yyerror(rec_t *rec, char *err);
+
+-#define YYPARSE_PARAM rec
+ #define YYERROR_VERBOSE
+
+ #ifdef REC_PARSE_DEBUG
+@@ -47,6 +46,7 @@ static feature_list_t FEATURE_ERROR = {
+ %}
+
+ %pure_parser
++%parse-param { rec_t *rec }
+
+ %union {
+ int ival;
@@ -141,7 +141,7 @@ mode_decl : MODE STRING
| MODE STRING
{
@@ -24,3 +43,12 @@
gesture_list : gesture
{
+@@ -342,7 +344,7 @@ option : OPTION STRING STRING
+
+ %%
+
+-static int yyerror(char *err)
++static int yyerror(rec_t *rec, char *err)
+ {
+ char *loc = rec_lex_location_alloc();
+ fprintf(stderr, "%s: %s\n", loc, err);