aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinícius Zavam <egypcio@FreeBSD.org>2018-12-04 13:32:08 +0000
committerVinícius Zavam <egypcio@FreeBSD.org>2018-12-04 13:32:08 +0000
commitb4fdb54f4e73323fabe394d3d80c9fdd0225c3f7 (patch)
tree960aa734fa1df2c07174d2f273e4faaba5fde8b2
parent5549f09acbee7acc65faefb300357d5dfe659bd5 (diff)
downloadports-b4fdb54f4e73323fabe394d3d80c9fdd0225c3f7.tar.gz
ports-b4fdb54f4e73323fabe394d3d80c9fdd0225c3f7.zip
MFH: r486592
security/py-yubikey-manager: add missing (required) dependencies - add missing depends to RUN_DEPENDS; - add concurrent to USE_PYTHON, remove flavors; - bump PORTREVISION. PR: 233709 Submitted by: Daniel Shafer <daniel % shafer.cc> Reviewed by: koobs Approved by: araujo (mentor), miwi (ports-secteam) Differential Revision: https://reviews.freebsd.org/D18419 Approved by: ports-secteam
Notes
Notes: svn path=/branches/2018Q4/; revision=486597
-rw-r--r--security/py-yubikey-manager/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/security/py-yubikey-manager/Makefile b/security/py-yubikey-manager/Makefile
index 16cad2685fae..1d687aee8e46 100644
--- a/security/py-yubikey-manager/Makefile
+++ b/security/py-yubikey-manager/Makefile
@@ -1,26 +1,30 @@
# $FreeBSD$
PORTNAME= yubikey-manager
-PORTVERSION= 0.7.1
+PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= egypcio@googlemail.com
COMMENT= Python library and command line tool for configuring a YubiKey
-LICENSE= GPLv3
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyscard>0:security/py-pyscard@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}fido2>0:security/py-fido2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openssl>0:security/py-openssl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyscard>0:security/py-pyscard@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pycrypto>0:security/py-pycrypto@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}usb>0:devel/py-usb@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${PY_FLAVOR} \
- pcsc-spy:devel/pcsc-lite \
${LOCALBASE}/lib/pcsc/drivers/ifd-ccid.bundle/Contents/${OPSYS}/libccid.so:devel/libccid \
+ pcsc-spy:devel/pcsc-lite \
u2f-host:security/libu2f-host \
ykpers>0:security/ykpers
USES= python:3.4+
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist concurrent distutils
.include <bsd.port.mk>